VirtualBox

Opened 9 years ago

Closed 9 years ago

#13435 closed defect (fixed)

iScsi CHAP auth failing since v4.3.14 => fixed in next maintenance release

Reported by: MickSx Owned by:
Component: other Version: VirtualBox 4.3.16
Keywords: iscsi CHAP Cc:
Guest type: Windows Host type: Windows

Description

I am seeing a problem with iScsi authentication since version 4.3.14 same problem on v4.3.16

I am attaching two Wireshark traces - one from each version of Vbox. I have forced the target to use the same challenge in both cases.

The response returned by 4.3.12 is the same as I would expect if calculating manually. MD5 of attached file x.txt gives MD5(x.txt)= 3d3de31c2fdba8db30f40d10a80650d3

Attachments (4)

CHAP_v4.3.12.pcapng (3.3 KB ) - added by MickSx 9 years ago.
WireShark trace using v4.3.12
CHAP_v4.3.16.pcapng (2.4 KB ) - added by MickSx 9 years ago.
WireShark trace using v4.3.16
X.TXT (29 bytes ) - added by MickSx 9 years ago.
expected data for MD5
VBoxSvc.log (1.2 KB ) - added by MickSx 9 years ago.
Extract from VBoxSvc.log

Download all attachments as: .zip

Change History (8)

by MickSx, 9 years ago

Attachment: CHAP_v4.3.12.pcapng added

WireShark trace using v4.3.12

by MickSx, 9 years ago

Attachment: CHAP_v4.3.16.pcapng added

WireShark trace using v4.3.16

by MickSx, 9 years ago

Attachment: X.TXT added

expected data for MD5

by MickSx, 9 years ago

Attachment: VBoxSvc.log added

Extract from VBoxSvc.log

comment:1 by MickSx, 9 years ago

May be related to ticket #13386

comment:2 by Frank Mehnert, 9 years ago

Ticket #13386 talks about 4.3.12 being the first release where it does not work while you say that 4.3.12 worked. Is that still true?

I see that you are on a Windows host. Could you provide a VBoxStartup.log file of such a VM session where you try to connect to an iSCSI target? There is a slight chance that the problem results from some hardening changes we did in VBox 4.3.14. VBoxStartup.log would probably show that.

comment:3 by aeichner, 9 years ago

Summary: iScsi CHAP auth failing since v4.3.14iScsi CHAP auth failing since v4.3.14 => fixed in next maintenance release

Thanks for the report, this is indeed a regression introduced with 4.3.14. This will be fixed in the next maintenance release.

comment:4 by Frank Mehnert, 9 years ago

Resolution: fixed
Status: newclosed

Fix is part of VBox 4.3.18.

Note: See TracTickets for help on using tickets.

© 2023 Oracle
ContactPrivacy policyTerms of Use