VirtualBox

Ticket #13386 (closed defect: fixed)

Opened 3 years ago

Last modified 3 years ago

iscsi not working since 4.3.12 on host Centos 6,5 => fixed in next maintenance release

Reported by: KurtMielke Owned by:
Priority: major Component: other
Version: VirtualBox 4.3.16 Keywords: iscsi 4.3.14-regression
Cc: Guest type: all
Host type: Linux

Description

when upgrading 4.3.12 to .14 or .16, machines with ISCSI disk fails on startup, with something like:

Error: failed to start machine. Error message: Could not open the medium 'nas0.lan|iqn.2004-04.com.qnap:ts-419uplus:iscsi.vtest.cad87c'. VD: error VERR_IO_GEN_FAILURE opening image file 'nas0.lan|iqn.2004-04.com.qnap:ts-419uplus:iscsi.vtest.cad87c' (VERR_IO_GEN_FAILURE)

downgrading to 4.3.12 again, and everything is fine again.

Tried to install 4.3.16 on clean machine. Same result when I tried to start it. I then uninstalled .16 and put .12 on, and the machine was up and running.

Attachments

VBox.log Download (84.8 KB) - added by KurtMielke 3 years ago.

Change History

Changed 3 years ago by KurtMielke

comment:1 Changed 3 years ago by wonko1953

I have a similar issue after just having upgraded from 4.3.12 to 4.3.16 on FreeBSD.

Host: FreeBSD 9.2 amd64 Client: Various.

Clients using iSCSI fail to attach the disk with the following message:

Error: failed to start machine. Error message: Could not open the medium 'hal.xyzzy|iqn.1995-06.xyzzy.hal.istgt:disk905'. VD: error VERR_NET_CONNECTION_REFUSED opening image file 'hal.xyzzy|iqn.1995-06.xyzzy.hal.istgt:disk905' (VERR_NET_CONNECTION_REFUSED)

In the server the iSCSI daemon indicates an authentication failure.

Last edited 3 years ago by wonko1953 (previous) (diff)

comment:2 Changed 3 years ago by aeichner

  • Summary changed from iscsi not working since 4.3.12 on host Centos 6,5 to iscsi not working since 4.3.12 on host Centos 6,5 => fixed in next maintenance release

Thanks for the report, this is indeed a regression introduced with 4.3.14. This will be fixed in the next maintenance release.

comment:3 Changed 3 years ago by frank

  • Status changed from new to closed
  • Resolution set to fixed

Fix is part of VBox 4.3.18.

Note: See TracTickets for help on using tickets.

www.oracle.com
ContactPrivacy policyTerms of Use