VirtualBox

Ticket #13239 (closed defect: obsolete)

Opened 5 years ago

Last modified 3 years ago

USB Disconnect causes VM to abort

Reported by: RayC Owned by:
Component: USB Version: VirtualBox 4.3.14
Keywords: USB disconnect Cc:
Guest type: Windows Host type: Linux

Description

Guest - Windows 8.1 64-bit Host - Linux Mint 17 Quiana

VirtualBox log added, although there is nothing notable around the time of failure in the log.

[1383007.564892] EMT-0[24455]: segfault at 0 ip 00007fbdfd68a7f1 sp 00007fbe2d221b90 error 6 in VBoxDD.so[7fbdfd5de000+254000]

To reproduce: 1) I am attaching an iPhone 5c. I have a USB filter setup for vendor ID 05ac so it automatically is attached to VirtualBox once I plug in the device. 2) Start VM 3) Connect USB device 4) Unplug USB device - segfault occurs and VirtualBox goes bye-bye (technical term...).

This does not happen to me if I don't have USB 2.0 support enabled...but then again my device won't work without USB 2.0 support enabled either (identify fails if I don't have 2.0 enabled).

Attachments

Bug.log Download (59.8 KB) - added by RayC 5 years ago.
VirtualBox log - no errors noted in log at time of failure, but perhaps some other info will help.

Change History

Changed 5 years ago by RayC

VirtualBox log - no errors noted in log at time of failure, but perhaps some other info will help.

comment:1 Changed 5 years ago by jlavi

I am also seeing USB disconnect causing very frequent aborts due to a segault. When trying to restore iPad with iTunes, it is occurinning almost always. When iPad reboots the virtualbox almost always dies. This also happens often but not always if I remove the USB cable from iPad. At the end of log I see typically line like:

Reaper: Pid XXXX (YYYY) was signalled: 11 (0xb)

Using WinXP, vbox 4.3 on Debian testing.

comment:2 follow-up: ↓ 10 Changed 5 years ago by ImEdwardo

I was just about to add a ticket for this!
Host is Ubuntu 14.04, guest is win7-64bit
device is a Logitech Webcam I use for video conferencing.
Worked fine as pass-through in 4.2.12, broke in 4.3.14
still works as web-cam pass-through at low rez.
It connects, updates about 1 frame every 3 seconds. after about 15min the guest BSOD's.
If I try to disconnect it the VM aborts with the same error as above.
from lsusb:
Bus 001 Device 005: ID 046d:0809 Logitech, Inc. Webcam Pro 9000

from my syslog:
kernel: [628048.139061] ------------[ cut here ]------------
kernel: [628048.139069] WARNING: CPU: 2 PID: 8453 at /build/buildd/linux-3.13.0/drivers/usb/host/ehci-hcd.c:1040 ehci_endpoint_reset+0x104/0x110()
kernel: [628048.139070] clear_halt for a busy endpoint
kernel: [628048.139071] Modules linked in: nls_utf8 udf crc_itu_t udl drm_usb syscopyarea sysfillrect sysimgblt pci_stub vboxpci(OF) vboxnetadp(OF) vboxnetflt(OF) vboxdrv(OF) bnep rfcomm binfmt_misc snd_hda_codec_hdmi snd_hda_codec_realtek dcdbas intel_rapl x86_pkg_temp_thermal intel_powerclamp coretemp kvm_intel snd_usb_audio kvm uvcvideo snd_usbmidi_lib videobuf2_vmalloc videobuf2_memops videobuf2_core videodev joydev crct10dif_pclmul crc32_pclmul ghash_clmulni_intel snd_hda_intel snd_hda_codec snd_hwdep aesni_intel aes_x86_64 lrw gf128mul glue_helper snd_pcm ablk_helper cryptd snd_page_alloc btusb bluetooth serio_raw snd_seq_midi snd_seq_midi_event snd_rawmidi i915 drm_kms_helper drm snd_seq i2c_algo_bit snd_seq_device snd_timer snd mac_hid video lpc_ich soundcore parport_pc ppdev lp parport hid_generic usbhid hid usb_storage e1000e psmouse ahci ptp libahci pps_core
kernel: [628048.139107] CPU: 2 PID: 8453 Comm: EhciFramer Tainted: GF O 3.13.0-32-generic #57-Ubuntu
kernel: [628048.139108] Hardware name: Dell Inc. OptiPlex 7010/0GY6Y8, BIOS A17 12/23/2013
kernel: [628048.139109] 0000000000000009 ffff88024d477d08 ffffffff8171bcb4 ffff88024d477d50
kernel: [628048.139111] ffff88024d477d40 ffffffff810676cd 0000000000000003 ffff880409621800
kernel: [628048.139113] 0000000000000087 ffff880409621b1c 0000000000000246 ffff88024d477da0
kernel: [628048.139115] Call Trace:
kernel: [628048.139120] [<ffffffff8171bcb4>] dump_stack+0x45/0x56
kernel: [628048.139122] [<ffffffff810676cd>] warn_slowpath_common+0x7d/0xa0
kernel: [628048.139124] [<ffffffff8106773c>] warn_slowpath_fmt+0x4c/0x50
kernel: [628048.139128] [<ffffffff81542df4>] ? usb_control_msg+0xd4/0x110
kernel: [628048.139129] [<ffffffff8155b944>] ehci_endpoint_reset+0x104/0x110
kernel: [628048.139131] [<ffffffff81541655>] usb_hcd_reset_endpoint+0x25/0x70
kernel: [628048.139133] [<ffffffff81543868>] usb_reset_endpoint+0x28/0x40
kernel: [628048.139135] [<ffffffff815438ee>] usb_clear_halt+0x6e/0x80
kernel: [628048.139137] [<ffffffff8154ec4f>] usbdev_do_ioctl+0xa8f/0xf30
kernel: [628048.139139] [<ffffffff8154f11e>] usbdev_ioctl+0xe/0x20
kernel: [628048.139142] [<ffffffff811cfd10>] do_vfs_ioctl+0x2e0/0x4c0
kernel: [628048.139144] [<ffffffff8109ddf4>] ? vtime_account_user+0x54/0x60
kernel: [628048.139146] [<ffffffff811cff71>] SyS_ioctl+0x81/0xa0
kernel: [628048.139149] [<ffffffff8172c87f>] tracesys+0xe1/0xe6
kernel: [628048.139150] ---[ end trace 836ab97a2eb603d7 ]---
kernel: [628066.256471] EMT-0[8423]: segfault at b0 ip 00007faa03651b3e sp 00007faa2bac7b90 error 4 in VBoxDD.so[7faa03541000+254000]

comment:3 Changed 5 years ago by mauromol

I also have this problem after upgrading to VirtualBox 4.3.14. This did not happen with 4.3.12. In /var/log/syslog I find:

Aug  4 22:10:51 hppb kernel: [65858.534563] usb 3-6: USB disconnect, device number 17
Aug  4 22:10:51 hppb kernel: [65858.710715] EMT-0[16540]: segfault at 0 ip 00007fac173ec7f1 sp 00007fac4d6a7b60 error 6 in VBoxDD.so[7fac17340000+254000]
Aug  4 22:10:51 hppb kernel: [65858.749427] vboxnetflt: 0 out of 175 packets were not sent (directed to host)

In my case, I disconnecting a Tom Tom GO 500 GPS device (it's seen as a network adapter by the OS).

Guest: Windows XP SP3 Host: Linux Mint 16 KDE VirtualBox 4.3.14 r95030 installed from Oracle PPA.

comment:4 Changed 5 years ago by lyallp

Ticket https://www.virtualbox.org/ticket/13309 relates to the same problem.

comment:5 Changed 5 years ago by lavacano

comment:6 Changed 5 years ago by lavacano

Confirming 4.3.12 works. nothing changed in virtualmachine only host software and kernel modules.

comment:7 Changed 5 years ago by MrFredH

I can confirm that this exists on my setup also. Fedora 20 Host, Win 7 Guest Same version as above ticket. I found no indication in the logs as to what went wrong. Occured twice so far, USB Memory disconnect and Digital Camera disconnect.

Last edited 5 years ago by MrFredH (previous) (diff)

comment:8 Changed 5 years ago by Ben4612

Same here, Ubuntu 12.04 as Host, Ubuntu 14.04 /Windows 7 guest (independent from guest os?) VirtualBox 4.3.14, crashes on unplug of a mapped USB device. Does not crash if mapping to guest removed before unplug.

comment:9 Changed 5 years ago by RayC

I installed 4.3.16 and it appears to have resolved the problem. I first installed 4.3.16 and the 4.3.16 USB 2.0 extension, but left the guest addition at 4.3.12. I was able to plug/unplug my iPhone without the VM aborting. I then installed 4.3.16 guest additions, rebooted and was still able to plug/unplug my iPhone at will without a crash.

I assume this line in the change log probably fixed it:

• USB: fixed several regressions from 4.3.14 (bug #13320)

comment:10 in reply to: ↑ 2 Changed 5 years ago by ImEdwardo

Replying to ImEdwardo:

Just an fyi, Logitech Webcam Pro 9000 still not working properly in 4.3.16 I have not had it crash yet, but still only updates the images once every 5-10 seconds. reverted back to 4.3.12 and it is working properly.

comment:11 Changed 5 years ago by RayC

Tried upgrading my iPhone to iOS 8 and when it put the iPhone into recovery mode VirtualBox froze up. Had to kill -9 it... Went back to 4.3.12 and the upgrade was successful. So still something "broken" in 4.3.16 around this. In this case I suppose it looks like a quick disconnect and reconnect of the device.

comment:12 follow-up: ↓ 13 Changed 5 years ago by RayC

4.3.18 appears to have really cured this. Guess bug 13400 may have been a duplicate? Given this ticket is still marked 'new' I assume bugs are worked by highest number first or something? :-)

comment:13 in reply to: ↑ 12 Changed 5 years ago by hoeferbe

Replying to RayC:

===

4.3.18 appears to have really cured this. Guess bug 13400 may have been a duplicate? Given this ticket is still marked 'new' I assume bugs are worked by highest number first or something? :-)

===

I'm still experiencing guest aborts when de-selecting VirtualBox's Device menu --> "USB Devices" --> "PNY Technologies USB 2.0 FD". (I.e. a 2GB USB thumbdrive.)

Host: CentOS 5.11 x86_64 (running VirtualBox-4.3-4.3.18_96516_el5-1.x86_64) Guest: Fedora 19 x86_64 (with Guest Additions 4.3.18 installed)

I'm willing to upload the /var/log/messages of the guest & host and the guest's VBox.log file, but none of them show any errors before the guest abort. If there are debug options I can enable, I'm willing to gather more logs and/or test new releases.

comment:14 Changed 5 years ago by mauromol

@RayC: I think yours is another issue, because the issue here is guest stop when the device is physically disconnected and not when unchecked from the devices menu. You may open a new bug I think.

comment:15 Changed 3 years ago by aeichner

  • Status changed from new to closed
  • Resolution set to obsolete

Please reopen if still relevant with a recent VirtualBox release.

Note: See TracTickets for help on using tickets.

www.oracle.com
ContactPrivacy policyTerms of Use