VirtualBox

Ticket #13320 (closed defect: obsolete)

Opened 3 years ago

Last modified 9 months ago

Centos 6.5 x86_64 host running VirtualBox 4.3.14. windows 7 VM crashes

Reported by: don2012 Owned by:
Priority: major Component: USB
Version: VirtualBox 4.3.14 Keywords:
Cc: Guest type: Windows
Host type: Linux

Description

Centos 6.5 x86_64 host running VirtualBox 4.3.14 windows 7 VM suddenlly closes when ipad 2 with IOS 7.1.2 is attached for first time and trust is touched on ipad to allow vm OS (windows 7) to connect to the ipad through apple device usb driver. the vm status shows as aborted in vb gui

Attachments

VBox.log Download (60.7 KB) - added by don2012 3 years ago.

Change History

Changed 3 years ago by don2012

comment:1 follow-up: ↓ 2 Changed 3 years ago by frank

So the host crashes, not only the VM aborts, is that correct? Are there any relevant items in the host log file?

comment:2 in reply to: ↑ 1 Changed 3 years ago by don2012

Replying to frank:

So the host crashes, not only the VM aborts, is that correct? Are there any relevant items in the host log file?

No the host is fine only the VM aborts(closes). the VB GUI remains open and i can restart the VM and make it abort again by trying to connect ipad as above. itunes does not need to be running. the vm closes when i touch trust on ipad popup to allow usb connection to continue with guest OS (win 7).

Last edited 3 years ago by don2012 (previous) (diff)

comment:3 follow-up: ↓ 4 Changed 3 years ago by frank

In that case I would be interested in a core dump. Could you send it to frank _dot _mehnert _at_ oracle _dot_ com? Please don't forget to compress it.

comment:4 in reply to: ↑ 3 Changed 3 years ago by don2012

Replying to frank:

In that case I would be interested in a core dump. Could you send it to frank _dot _mehnert _at_ oracle _dot_ com? Please don't forget to compress it.

ok will try to create core dump. not sure how to do but will give it a go. using centos 6.5. and email to you

thanks don

vm core dump sent

Last edited 3 years ago by don2012 (previous) (diff)

comment:5 Changed 3 years ago by frank

Thanks. I've got the core dump and could extract the relevant backtrace. We are investigating.

comment:6 follow-up: ↓ 7 Changed 3 years ago by frank

We think that we already fixed this crash in the code after VBox 4.3.14 was released. Would you be able to install + test this test build together with this extension pack? Thank you!

comment:7 in reply to: ↑ 6 ; follow-up: ↓ 8 Changed 3 years ago by don2012

Replying to frank:

We think that we already fixed this crash in the code after VBox 4.3.14 was released. Would you be able to install + test this test build together with this extension pack? Thank you!

OK. I updated VB + VB extentions ran windows vm and updated guest additions started itunes connected ipad. ipad trust this computer popup appeared touched trust and vm crashed. have messed around alot uninstalling all apple software from vm then reinstalled itunes, plug in ipad ra ra ,same thing happened, vm crashed. restarted vm and replugged ipad and now it is connecting properly with itunes. unplug ipad without diconeccting usb device in vb device manager at bottom of vm gui window and vm crashes. if i desconnect usb device from vm device manager and then unplug ipad vm does not crash. the problem with ipad connecting only occurs when authorizing the first connection of ipad to the vm os, once trusted the ipad connects without problem.

I will create a new win 7 vm install itunes and send you another core dump. now that i have the otherone working i don't want to upset it

Last edited 3 years ago by don2012 (previous) (diff)

comment:8 in reply to: ↑ 7 Changed 3 years ago by don2012

Replying to don2012:

Replying to frank:

We think that we already fixed this crash in the code after VBox 4.3.14 was released. Would you be able to install + test this test build together with this extension pack? Thank you!

OK. I updated VB + VB extentions ran windows vm and updated guest additions started itunes connected ipad. ipad trust this computer popup appeared touched trust and vm crashed. have messed around alot uninstalling all apple software from vm then reinstalled itunes, plug in ipad ra ra ,same thing happened, vm crashed. restarted vm and replugged ipad and now it is connecting properly with itunes. unplug ipad without diconnecting usb device in vb device manager at bottom of vm gui window and vm crashes. if i desconnect usb device from vm device manager and then unplug ipad vm does not crash. the problem with ipad connecting only occurs when authorizing the first connection of ipad to the vm os, once trusted the ipad connects without problem.

I will create a new win 7 vm install itunes and send you another core dump. now that i have the other one working i don't want to upset it

new core dump sent

comment:9 follow-up: ↓ 12 Changed 3 years ago by frank

Could you verify that VBox 4.3.16 fixes the problem for you? Please don't forget to update the Extension Pack.

comment:10 Changed 3 years ago by mikep

I recently upgraded from 4.3.12 to 4.3.16, and this bug (or a version thereof) appeared for me after the upgrade. I have the exact same symptoms as the ticket opener, except my USB device is a Ralink Corp. RT5370 Wireless Adapter, and my host is Debian x64 with kernel 3.2.0-4-amd64 #1 SMP Debian 3.2.60-1+deb7u3. I upgraded both the VirtualBox core and the extension pack to 4.3.16 at the same time. When the machine aborts and crashes, the following is seen in the kernel log:

[ 636.609576] EhciFramer[4214]: segfault at 0 ip 00007ffd3355401f sp 00007ffd2f884a80 error 6 in VBoxDD.so[7ffd33443000+254000]

Rolling VirtualBox and the extension back to version 4.3.12 causes the problem to go away, and the USB pass-through to behave as normal.

Last edited 3 years ago by mikep (previous) (diff)

comment:11 Changed 3 years ago by elipajuelo

I upgraded yesterday from 4.3.14 to 4.3.16, and experienced the two issues. 1) With 4.3.14 and Windows 7 guest the VM would abort after disconnecting my Galaxy S3; the USB pass through worked fine up to the point when I disconnected. 2) With 4.3.16 and Windows XP guest the VM would abort when trying to scan a document with my Canon Lide 210, during the time the Canon is trying to get a Preview of the document. In case 1) I did not have chance to test if the issue is resolved with 4.3.16, but in case 2) the problem went away by rolling back to 4.3.14. The host system is Ubuntu 12.04 AMD64, kernel 3.2.0-68-generic.

comment:12 in reply to: ↑ 9 Changed 3 years ago by don2012

Replying to frank:

Could you verify that VBox 4.3.16 fixes the problem for you? Please don't forget to update the Extension Pack.

yes VBox 4.3.16 has fixed the problem. everything working properly now. Has also fixed crash on hot unplug of ipad.

Thanks frank + team.

comment:13 Changed 3 years ago by frank

Great, thanks for the feedback! elipajuelo, please could you open separate tickets for your problems?

mikep, please could you provide a core dump? Please compress it and send it to frank _dot_ mehnert _at _oracle _dot_ com together with the corresponding VBox.log file. Thank you!

comment:14 Changed 3 years ago by Suboptimal

Your fix works and I just updated my iPad to iOS 8 via Windows running in your VirtualBox. Thanks!

comment:15 Changed 9 months ago by aeichner

  • Status changed from new to closed
  • Resolution set to obsolete

Please reopen if still relevant with a recent VirtualBox release.

Note: See TracTickets for help on using tickets.

www.oracle.com
ContactPrivacy policyTerms of Use