VirtualBox

Ticket #12828 (closed defect: fixed)

Opened 4 years ago

Last modified 3 years ago

Unable to change Host Key Combination

Reported by: jvd64 Owned by:
Priority: major Component: other
Version: VirtualBox 4.3.8 Keywords: Host Key Combination
Cc: Guest type: Windows
Host type: Mac OS X

Description

I have installed VirtualBox 4.3.8 on my Mac OS X (both 10.9.2 and 10.8.5) and no matter what I change the Host Key Combination to, it reverts to left CMD key ..

Best regards, Johannes

Change History

comment:1 Changed 4 years ago by Dsen

Hi Johannes.

Could you please test it that way:

  1. Open VBox "Preferences..." / Input page / Virtual Machine tab.
  2. Change the shortcut for "Host Key Combination" in embedded-editor of the shortcut table and (!) press Enter (or Return) key while this shortcut embedded-editor is opened. GUI applying shortcut changes only in that case as this is the default Qt behavior. If you simple press OK button instead your change will be discarded.

If you will confirm that was the reason for your issue we will think if we should change that behavior. Thanks in advance.

comment:2 Changed 3 years ago by CG

I reported #12937 - I can confirm that pressing enter works but this is quite counterintuitive.

comment:3 Changed 3 years ago by Dsen

Yep, I agree. There are already plenty of similar defects created.
Issue is fixed and fix will be available in nearest maintenance release.

comment:4 Changed 3 years ago by frank

  • Status changed from new to closed
  • Resolution set to fixed

Fix is part of VBox 4.3.14.

Note: See TracTickets for help on using tickets.

www.oracle.com
ContactPrivacy policyTerms of Use