VirtualBox

Ticket #12744 (closed defect: fixed)

Opened 13 months ago

Last modified 5 months ago

Error 0x000000C4 when booting Windows 7 x64 (Ubuntu 12.04 x64 host) after update to 4.3.8-92456 [FIXED in SVN]

Reported by: uchuujin Owned by:
Priority: major Component: other
Version: VirtualBox 4.3.8 Keywords:
Cc: Guest type: Windows
Host type: Linux

Description

Hello!

I just encountered the following error:

  • Host OS: Ubuntu 12.04 x64
  • Updated Virtualbox 4.3.6-91406 to 4.3.8-92456 from the official Virtualbox repository
  • Updated the guest additions too
  • Started Windows 7 x64 virtual machine (was running fine before)
  • The machine crashed with error STOP: 0x000000C4 upon startup

After that, I tried the following:

  • the solution suggested in https://www.virtualbox.org/ticket/11841 (VBoxManage setextradata [vmname] VBoxInternal/CPUM/CMPXCHG16B 1)
  • Downgrading guest additions to 4.3.6-91406
  • Removing guest aditions altogether
  • Turning off hardware acceleration (graphics, CPU)

None of this works. My virtual machine crashes everytime, so I cannot use it anymore.

Please find a capture of the error message and Vbox.log attached.

Attachments

Win_7_error_0x000000c4.png Download (30.2 KB) - added by uchuujin 13 months ago.
Screenshot of BSOD in guest OS (Win 7 x64)
VBox.log Download (79.1 KB) - added by uchuujin 13 months ago.
Virtual Box log file
VBox (noch eine Kopie).log Download (87.4 KB) - added by GGos 13 months ago.
Logfile starting Win8 64 bit Guest
VBox_4.3.8_20140228_bad.log Download (77.8 KB) - added by uchuujin 13 months ago.
Starting Windows 7 x64 guest on Virtualbox 4.3.8 -> BSOD upon boot
VBox_4.2.22_20140228_good.log Download (82.5 KB) - added by uchuujin 13 months ago.
Starting Windows 7 x64 guest on Virtualbox 4.3.8 -> Starts without problems
VBox 4.3.12 r93733.log Download (203.0 KB) - added by sunnnn 6 months ago.
VBox 4.3.12 r93733.png Download (11.3 KB) - added by sunnnn 6 months ago.
VBox.2.log Download (205.7 KB) - added by SP007 5 months ago.

Change History

Changed 13 months ago by uchuujin

Screenshot of BSOD in guest OS (Win 7 x64)

Changed 13 months ago by uchuujin

Virtual Box log file

Changed 13 months ago by GGos

Logfile starting Win8 64 bit Guest

comment:1 Changed 13 months ago by GGos

I have the same problem with a Windows 8 64 bit guest on Ubuntu 12.04 64bit afer updating from 4.3.6 to 4.3.8.

Only downgrading to 4.2.22 helped to start the machine again.

In the logfile, there is an Error at 00:00:02.187981 ERROR [COM]: aRC=VBOX_E_IPRT_ERROR ... but the machine still keeps running a little bit until 00:00:19.753946 IEM: wrmsr(0xc0000080,0x0`00004d01) -> GP(0). That is the point when the 0x000000C4 - Error-Message appears on the Guest. (detailed Log see attachment "VBox (noch eine Kopie).log")

The error appears very early in the Windows Startup procedure, it is not possible to enter into repair mode.

Any ideas, anyone?

comment:2 Changed 13 months ago by uchuujin

Hello GGos, thank you for confirming!

Same here: After downgrading to Virtualbox 4.2.22 my virtual machine started without problems.

I'll attach two more log files.

Changed 13 months ago by uchuujin

Starting Windows 7 x64 guest on Virtualbox 4.3.8 -> BSOD upon boot

Changed 13 months ago by uchuujin

Starting Windows 7 x64 guest on Virtualbox 4.3.8 -> Starts without problems

comment:3 Changed 13 months ago by bird

  • Status changed from new to closed
  • Resolution set to fixed
  • Summary changed from Error 0x000000C4 when booting Windows 7 x64 (Ubuntu 12.04 x64 host) after update to 4.3.8-92456 to Error 0x000000C4 when booting Windows 7 x64 (Ubuntu 12.04 x64 host) after update to 4.3.8-92456 [FIXED in SVN]

Thanks for the report. We've figured out the problem and a fix will be included in the next VirtualBox release.

In the mean time you can work around the issue by clearing the FFXSR feature bit in CPUID leaf 0x80000001, edx[25]. In your case edx=0xeb93fb7f, so the modified edx value is 0xe993fb7f. This can be communicated to the VMM like this:

VBoxManage setextradata <vmname> VBoxInternal/CPUM/HostCPUID/0x80000001/edx 0xe993fb7f

comment:4 Changed 13 months ago by amelsens

I have the same problem with starting Windows 8 and Windows Server 2008 R2 and Windows Server 2012 as guest on Virtualbox 4.3.8. The error is a STOP: 0x000000C4 error of a "Pc must shuting down, press the power off button". Before with Virtualbox 4.3.6 there where no problems, so I have downgrade Virtualbox to 4.3.6 and it's working again. I use Virtualbox on an Dell Inspiron 531 with Windows 8.1 64-bit with 6 GB Ram.

comment:5 Changed 13 months ago by frank

Here is a test build containing the fix. Could you confirm the fix?

comment:6 Changed 13 months ago by uchuujin

Yes, my virtual machine starts without problems with the test build that you provided. Apologies for the delay in confirming! Thank you very much for fixing this issue so quickly.

Changed 6 months ago by sunnnn

Changed 6 months ago by sunnnn

comment:7 Changed 6 months ago by sunnnn

The problem is still exists while trying to install Win7 x64. Host OS is Win8.1 x64. Version 4.3.12 r93733 What should I do? Attached log-file and screen.

Changed 5 months ago by SP007

comment:8 Changed 5 months ago by SP007

I have the same issue in Ubuntu. attached is the log. Using 4.3.18 r96516

Last edited 5 months ago by SP007 (previous) (diff)

comment:9 Changed 5 months ago by frank

SP007, which exact version of Windows are you trying to run/install? Is that really Windows 8 or is that Windows 8.1?

comment:10 Changed 5 months ago by SP007

Update: Windows 8.1.. the install didnt work in Ubuntu. So I rebooted (on the same host) into Win 7, used setextradata command and the install worked. Now back in Ubuntu, I still cannot boot this VM. I get the same error 0x000000c4.

Last edited 5 months ago by SP007 (previous) (diff)

comment:11 Changed 5 months ago by frank

You used the wrong guest OS type: Please use "Windows 8.1 (64-bit)", not "Windows 8 (64-bit)". That should fix your problem.

comment:12 Changed 5 months ago by SP007

Thank you!! that worked. One of those days...

Note: See TracTickets for help on using tickets.

www.oracle.com
ContactPrivacy policyTerms of Use