VirtualBox

Ticket #12421 (closed defect: worksforme)

Opened 17 months ago

Last modified 5 months ago

Guru Meditation 1155 (VINF_EM_TRIPLE_FAULT, OpenBSD 5.4 on Intel)

Reported by: quagaar Owned by:
Priority: major Component: other
Version: VirtualBox 4.3.4 Keywords:
Cc: Guest type: Linux
Host type: Windows

Description

I'm getting a guru meditation 1155 (VINF_EM_TRIPLE_FAULT) error on starting a Debian guest on a Windows 8.1 host.

  • VirtualBox version: 4.3.4r91027
  • Extension pack version: 4.3.4r91027
  • Host OS: Windows 8.1 (64bit)
  • Guest OS: Debian 7 (64bit)
  • Host hardware: HP Pavilion g6-2395sa ( Spec)

Problem also occurs in VirtualBox versions 4.3.0 and 4.3.2. The problem did not occur in version 4.2.18, also does not occur after downgrading to version 4.2.18.

Attachments

VBox.log.zip Download (32.5 KB) - added by quagaar 17 months ago.
VBox.png Download (1.2 KB) - added by quagaar 17 months ago.
MacOS-OpenBSD5.4.zip Download (35.1 KB) - added by Justin.L.Heuser 17 months ago.
Triple fault booting OpenBSD 5.4 i386 installer. Expands to OpenBSD5.4.log in same directory
OpenBSD54-VB-4.3.6.zip Download (30.1 KB) - added by Justin.L.Heuser 16 months ago.
OpenBSD 5.4 crash; VB 4,3,6, Mac OS X 10.9.1.
openbsd_osx_vbox436.log Download (184.5 KB) - added by corrosion 15 months ago.
Logs.zip Download (51.8 KB) - added by rindi1 14 months ago.
VBOX-ISO-Boot-2014-03-05-09-34-57.log Download (186.0 KB) - added by ppl 14 months ago.
VBox.log Download (199.2 KB) - added by coolnodje 14 months ago.
OpenBSD 5.3 64bit on Windows 7 32bit
vbox-win2012r2_x64.log Download (86.8 KB) - added by ahierony 11 months ago.

Change History

Changed 17 months ago by quagaar

Changed 17 months ago by quagaar

Changed 17 months ago by Justin.L.Heuser

Triple fault booting OpenBSD 5.4 i386 installer. Expands to OpenBSD5.4.log in same directory

comment:1 Changed 17 months ago by Justin.L.Heuser

Similar symptoms with Mac OS 10.9 Maverics host, but only with OpenBSD guest; Fedora, FreeBSD, and Ubuntu guests work fine. OpenBSD works fine with same host OS but different host machine. No problems under 4.2.18, which I was running prior to updating to 4.3.4.

Deleting and recreating the guest machine did not help. Neither did deleting VirtualBox using the Oracle-supplied remover script, rebooting the host machine, re-installing VirtualBox, and re-creating the guest. Both i386 and amd64 versions of OpenBSD fail.

I have attached a zipped log file from attempting to boot the OpenBSD 5.4 i386 installer.

comment:2 Changed 17 months ago by frank

  • Summary changed from Guru Meditation 1155 (VINF_EM_TRIPLE_FAULT) to Guru Meditation 1155 (VINF_EM_TRIPLE_FAULT, OpenBSD 5.4 on Intel)

To make it clear, quagaar, your problem is a duplicate of #12451. Justin, your problem is different as #12451 is only for AMD CPUs. Therefore I will leave this ticket open.

comment:3 Changed 16 months ago by frank

Is this problem still reproducible with VBox 4.3.6?

comment:4 Changed 16 months ago by quagaar

VBox 4.3.6 has fixed the problem I was having, but that seems to be covered by #12451.

comment:5 Changed 16 months ago by frank

  • Status changed from new to closed
  • Resolution set to fixed

Thank you for the feedback! Actually your problem was a bit different as #12451 was only for AMD CPUs.

Changed 16 months ago by Justin.L.Heuser

OpenBSD 5.4 crash; VB 4,3,6, Mac OS X 10.9.1.

comment:6 Changed 16 months ago by Justin.L.Heuser

Not fixed for me. Still crashes under 4.3.6.

Host Mac OS 10.9.1 Maverics, VirtualBox 4.3.6r91406, OpenBSD 5.4 32-bit. Machine is what MacTracker calls 'iMac (20-inch mid-2007)'. FreeBSD boots no problem. Have not tried anything else yet. Log (up to guru meditation) is OpenBSD54-VB-4.3.6.zip

Last edited 16 months ago by Justin.L.Heuser (previous) (diff)

comment:7 Changed 16 months ago by Justin.L.Heuser

  • Status changed from closed to reopened
  • Resolution fixed deleted

Update: on the machine MacTracker calls 'iMac (20-inch mid-2007)', the following systems work without problems under Virtualbox 4.3.6: Fedora 19 (64-bit), FreeBSD 9.2 (32-bit), Ubuntu 12.04 (32-bit) and Ubuntu 13.10 (64-bit).

On a separate machine, which MacTracker calls 'MacBook Pro (13-inch, mid-2012)' the very same version of OpenBSD which failed on the mid-2007 machine works without problem. And I mean 'the very same' literally -- I rsync'ed the virtual machine over.

comment:8 Changed 16 months ago by frank

Justin, could you test if this test build fixed the OpenBSD problem for you on your MacBook Pro? Thank you!

comment:9 Changed 15 months ago by Justin.L.Heuser

Working on it now. Sorry for the delay -- I need to figure out how to set up my account to get notified when the ticket changes.

At the moment the status is:

OS                Computer                       VirtualBox 4.3.6  VirtualBox 4.3.7 r91542
----------------  -----------------------------  ----------------  -----------------------
OpenBSD 5.4 i386  iMac (20-inch mid-2007)        Failed to boot    Works so far
     ditto        MacBook Pro (13-inch mid-2012) Worked            Worked
Fedora 20 64-bit  iMac (20-inch mid-2007)        Worked            Not tried
     ditto        MacBook Pro (13-inch mid-2012) Not tried         Worked

Rather than rsync the OpenBSD VM back from the MacBook, I decided a better test would be to configure it from scratch. I am early in the last and largest step (building, testing, and configuring a custom Perl), and so far things have gone without a hitch.

I will update today or tomorrow with the final results for OpenBSD, and the results for FreeBSD and a couple Ubuntu versions, but so far things are looking pretty good. Thank you very much for your work on my behalf.

Changed 15 months ago by corrosion

comment:10 Changed 15 months ago by corrosion

OpenBSD also does not boot on my Macbook with OS X 10.9.1 on Virtualbox 4.3.6. Attached log. Also AMD64 OpenBSD versions shows a kernel panic.

comment:11 Changed 15 months ago by Justin.L.Heuser

Corrosion -

I too had failure of both 32- and 64-bit OpenBSD, but only on the older of the two Macs I own. No other OS (Fedora 20 64-bit, FreeBSD 32-bit, Ubuntu 12.04 32-bit, and Ubuntu 13.10 64-bit) failed on either machine.

Frank posted a link to VirtualBox 4.3.7 r91542 about three comments ago. This appears to fix the problem for me, though I have yet to try OpenBSD 64-bit. It also appears not to break any of the other OSes I use, on either machine. Once I give OpenBSD 64-bit a try I personally will be ready to call this one fixed.

Now, as I understand it the odd subversion number makes this a development release, but if you are not nervous about that (and given that a very small sample of users says it works) you might want to give it a try.

comment:12 Changed 15 months ago by Justin.L.Heuser

fred -

As far as I can tell VirtualBox 4.3.7 r91542 fixes my problem. The final matrix is

OS           Bits Host     4.3.6           4.3.7 r91542
-----------  ---- -------  --------------  -------------
Fedora 20     64  iMac     Worked fine
                  MacBook  Worked fine     Worked fine
FreeBSD 9.2   32  iMac     Worked fine     Worked fine
OpenBSD 5.4   32  iMac     Failed to boot  Worked fine
                  MacBook  Worked fine     Worked fine
OpenBSD 5.4   64  iMac     Failed to boot  Installed
                  MacBook                  Installed
Ubuntu 12.04  32  iMac     Worked fine     Worked fine
Ubuntu 13.10  64  iMac     Worked fine     Worked fine

In the above:

  • "iMac" is a machine identified by MacTracker as "iMac (20-inch mid-2007)".
  • "MacBook" is a machine identified by MacTracker as "MacBook Pro (13-inch mid-2012)".
  • "Worked fine" means that I have at least taken a stab at all the normal things I do, and had no trouble.
  • "Installed" means I installed the OS and my usual packages, but custom-built nothing and did not actually try to use the machine for anything.
  • "Failed to boot" means pretty much what it says.
  • No entry means the combination was not tried.

Changed 14 months ago by rindi1

comment:13 Changed 14 months ago by rindi1

Hi,

I also get this error:

Guru Meditation 1155 (VINF_EM_TRIPLE_FAULT)

I have this strange problem on a PC with intel p965/g965 chipset, e5400 Dual Core CPU and 4GB RAM (Virtualization is enabled in the BIOS). I've tried it with both, Windows 7 Ultimate (64bit), and Windows 8.1 Pro (64bit), as hosts, both of those OS's run fine. VirtualBox Version 4.3.6 r91406 is installed under both of those OS (I can't use the newer version as that has a bug when running 64 bit Windows OS's).

When trying to run a Windows 8.1 Pro 64 bit guest which runs fine on 2 other PC's one with an AMD X2 Processor, and the other a e6400 cpu and 945p chipset, but the same OS's as hosts, I get an error like this:

Your PC needs to restart..... Error Code xC4 91 0f 0xfffff8021f354a80 0

The same thing happens when installing a fresh 8.1 guest, and it happens under both hosts.

But if I install OpenSUSE (the newest version, along with the VirtualBox version that comes with the OpenSUSE repositories, something around version 4.2) on this PC, those Guests run fine.

Is there an issue with VirtualBox running within Windows hosts on an intel 965 chipset?

comment:14 Changed 14 months ago by coolnodje

I still get the same error with latest VB 4.3.8 on Windows 7 32-bit host with OpenBSD 5.3 64-bit guest.

I boot the machine Headless with Vagrant, but when I open VirtualBox and check the settings I can see in the General Tab version greyed 'FreeBSD (32 bit)'

The same Vagrant config works well on OS X Maverick Host

Last edited 14 months ago by coolnodje (previous) (diff)

comment:15 Changed 14 months ago by frank

coolnodje, please attach a VBox.log file of such a VM session.

Changed 14 months ago by ppl

comment:16 Changed 14 months ago by ppl

OK I got a similar error. Socratis told me the log I attached on my original thread should be in here because there was the following line: Guru Meditation 1155 (VINF_EM_TRIPLE_FAULT). There were 2 other threads with this search result but both were closed.

Mine is slightly different than the title here because it's an Ubuntu vdi from a Windows7 64bit host with an Intel processor. (Intel(R) Core (TM)2 Quad CPU Q8300 @ 2.50GHz.

I attached the file. (VBOX-ISO-Boot-2014-03-05-09-34-57.log)

Changed 14 months ago by coolnodje

OpenBSD 5.3 64bit on Windows 7 32bit

comment:17 Changed 11 months ago by ahierony

Similar error when attempting boot of Win2012 R2 x64 ISO inside guest, using a Debian 7 x64 host. Attached log vbox-win2012r2_x64.log

Changed 11 months ago by ahierony

comment:18 Changed 5 months ago by frank

ahierony, your attached file is not complete but I strongly assume that your guest OS type is wrong. Please set it to "Windows 2012"!

comment:19 Changed 5 months ago by frank

  • Status changed from reopened to closed
  • Resolution set to worksforme
Note: See TracTickets for help on using tickets.

www.oracle.com
ContactPrivacy policyTerms of Use