VirtualBox

Ticket #12373 (closed enhancement: obsolete)

Opened 8 years ago

Last modified 23 months ago

Windows 8(.1) guests don't run on hosts that don't support hw assisted virtualization

Reported by: Arend99 Owned by:
Component: VMM Version: VirtualBox 4.3.2
Keywords: Cc:
Guest type: Windows Host type: all

Description

I tried to install 32-bit Windows 8.1 on my laptop running VirtualBox 4.3.0. The installation aborted early on with the message:

Your PC needs to restart. Please hold down the power button. Error code: 0x0000000A Parameters: 0xFFFFFFE6 0x0000001F 0x00000000

0x8138AFAB

According to  https://forums.virtualbox.org/viewtopic.php?f=7&t=56465 this message indicates that hardware assisted virtualization needs to be enabled to run Windows 8(.1) (32-bit and 64-bit) in VirtualBox.

Given that VirtualBox strives to support a wide range of host hardware and OS' it would be great if VirtualBox could support the execution of 32-bit versions of Windows 8/8.1 on systems without hardware virtualization support.

While all current AMD processors support AMD-V there is a number of current (and older) Intel processors that don't. Right now Intel's Pentium Processors B940, B950, 957, 967, B970, 977, 987, B980 do not support VT-X. A quick google search showed that these processors are used in a variety of laptops from mainstream vendors like Acer, ASUS, Toshiba, Sony.

Even though I lack the detailed knowledge about runtime code patching I think the problem can be solved in software. With VMware Player 6 Windows 8.1 32-bit installs just fine on my system that lacks HAV support

Change History

comment:1 Changed 23 months ago by aeichner

  • Status changed from new to closed
  • Resolution set to obsolete
Note: See TracTickets for help on using tickets.

www.oracle.com
ContactPrivacy policyTerms of Use