VirtualBox

Ticket #12310 (closed defect: fixed)

Opened 4 years ago

Last modified 3 years ago

VB 4.3 breaks encrypted DVD playing and image writing

Reported by: ehagberg Owned by:
Priority: major Component: DVD
Version: VirtualBox 4.3.2 Keywords:
Cc: Guest type: Windows
Host type: Linux

Description

After upgrading to 4.3, I notice that I can no longer play encrypted DVDs in a VM (in this case windows xp) any longer, while downgrading back to 4.2.18 allows this to work again. I'm using passthrough mode.

Here are the errors I see in the host's messages logfile:

Oct 27 10:42:14 taltos kernel: [12451.530106] ata5.01: exception Emask 0x0 SAct 0x0 SErr 0x0 action 0x6 frozen
Oct 27 10:42:14 taltos kernel: [12451.530115] sr 5:0:1:0: [sr1] CDB:
Oct 27 10:42:14 taltos kernel: [12451.530118] cdb[0]=0xa3, sa=0x0: a3 00 00 00 00 00 00 00 00 10 01 00
Oct 27 10:42:14 taltos kernel: [12451.530130] ata5.01: cmd a0/00:00:00:00:00/00:00:00:00:00/b0 tag 0
Oct 27 10:42:14 taltos kernel: [12451.530130]          res 58/00:00:10:10:00/00:00:00:00:00/b0 Emask 0x2 (HSM violation)
Oct 27 10:42:14 taltos kernel: [12451.530133] ata5.01: status: { DRDY DRQ }
Oct 27 10:42:14 taltos kernel: [12451.530154] ata5: soft resetting link
Oct 27 10:42:14 taltos kernel: [12451.687484] ata5.00: configured for UDMA/33
Oct 27 10:42:14 taltos kernel: [12451.690327] ata5.01: configured for UDMA/66
Oct 27 10:42:14 taltos kernel: [12451.690786] ata5: EH complete
Oct 27 10:42:14 taltos kernel: [12452.245068] ata5.01: exception Emask 0x0 SAct 0x0 SErr 0x0 action 0x6 frozen
Oct 27 10:42:14 taltos kernel: [12452.245076] sr 5:0:1:0: [sr1] CDB:
Oct 27 10:42:14 taltos kernel: [12452.245079] cdb[0]=0xa3, sa=0x0: a3 00 00 00 00 00 00 00 00 10 01 00
Oct 27 10:42:14 taltos kernel: [12452.245090] ata5.01: cmd a0/00:00:00:00:00/00:00:00:00:00/b0 tag 0
Oct 27 10:42:14 taltos kernel: [12452.245090]          res 58/00:00:10:10:00/00:00:00:00:00/b0 Emask 0x2 (HSM violation)
Oct 27 10:42:14 taltos kernel: [12452.245093] ata5.01: status: { DRDY DRQ }
Oct 27 10:42:14 taltos kernel: [12452.245113] ata5: soft resetting link
Oct 27 10:42:14 taltos kernel: [12452.401743] ata5.00: configured for UDMA/33
Oct 27 10:42:14 taltos kernel: [12452.407571] ata5.01: configured for UDMA/66
Oct 27 10:42:14 taltos kernel: [12452.407962] ata5: EH complete

This problem/regression seems to break the ability to write DVD images in passthrough mode, which also works fine again if I revert to the previous 4.2.18 release.

However, the 4.2.18 release causes other issues (like the VM crashing at the end of certain programs that use the DVD drive)... so I hope this can be fixed in 4.3 where I don't have these crashes.

My host is running Fedora 19 with the 3.11.6-200.fc19.x86_64 kernel.

Attachments

VBox.log Download (53.5 KB) - added by dewd 4 years ago.
Same Error - Windows 7 on Mint 16 Host
VBox.log.4.2.16-dvd-writing Download (195.1 KB) - added by ehagberg 4 years ago.
VBox.log.4.3.2-dvd-writing-fail-enc-dvd-read-fail Download (115.4 KB) - added by ehagberg 4 years ago.
vbox_debug1.zip Download (84.7 KB) - added by mhanor 3 years ago.
dev_ide debug log

Change History

comment:1 Changed 4 years ago by dewd

I am having a similar issue with AnyDVD and Windows XP. I have confirmed this fails in both Linux Mint 16 RC1 and Ubuntu 13.04 (both 64bit).

Changed 4 years ago by dewd

Same Error - Windows 7 on Mint 16 Host

comment:2 Changed 4 years ago by dewd

I can confirm this is an issue with Windows 7 virtual machine running on Mint 16. As soon as AnyDVD starts to look at the DVD, the entire machine freezes. I attached a log.

00:00:53.809881 PIIX3 ATA: LUN#0: CD-ROM passthrough cmd=0x51 sense=2 ASC=0x3a ASCQ=0x1 VERR_DEV_IO_ERROR 00:00:53.866402 PIIX3 ATA: LUN#2: CD-ROM passthrough cmd=0x51 sense=2 ASC=0x3a ASCQ=0x0 VERR_DEV_IO_ERROR

comment:3 Changed 4 years ago by frank

dewd, is this a 4.3 regression for you as well, I mean, you didn't see any similar problems with VBox 4.2.18, correct? If so, could you also attach a VBox.log file for VBox 4.2.18?

comment:4 Changed 4 years ago by frank

ehagberg, I would also like to see the complete log for VBox 4.3.2 as well as a complete log for VBox 4.2.18. Please use the 'attach' function of this ticket!

comment:5 Changed 4 years ago by dewd

Yes, this is a 4.3 only issue. This was not an issue with 4.2.18.

Thank you.

comment:6 Changed 4 years ago by ehagberg

I actually need to use 4.2.16, as 4.2.18 had a problem that caused the VM to crash at the end of some DVD operations... and while that's supposed to be fixed in 4.3.x, I can't use it. Anyway, I'm attaching a 4.2.16 log and a 4.3.2 log.

Changed 4 years ago by ehagberg

Changed 4 years ago by ehagberg

comment:7 Changed 3 years ago by dewd

There have been 3 updates to VB since this bug has been reported and I see no indication that it has been fixed. I have not updated from version 4.2 since it would cause my entire machine to lock.

Is this going to be addressed? Or has it been addressed and I just missed it somehow?

Thank you.

comment:8 Changed 3 years ago by Schninckel

Just wanted to add me to the list of people affected by this bug. Also wanted to ask if this bug is still under investigation or going to be fixed.

comment:9 Changed 3 years ago by mhanor

Sometimes, the ATADevState pTrackList is null, it seems that it never gets initialized. For this reason, without doing anything else, other than starting and then shutting down the guest OS, while a blank disc is inside the optical drive, VirtualBox crashes in VBoxDD!ATAPIPassthroughTrackListClear. The official 4.3.10 Windows build crashes, and so are some custom builds (4.3.10 and a recent SVN rev). The host is Windows 7 x64, so is the guest. I'm attaching a debug log for dev_ide, maybe someone can figure it out.

While the guest is running, ImgBurn fails write to a CD-RW disc and it hangs when opening the optical device for creating an image file.

Last edited 3 years ago by mhanor (previous) (diff)

Changed 3 years ago by mhanor

dev_ide debug log

comment:10 Changed 3 years ago by aeichner

Hi,

thanks for the informtion so far. We can confirm the DVD playback issue and found the problem but have no time to fix it and verify that it doesn't introduce other regressions at the moment unfortunately. The issue with burning DVDs doesn't look related to the playback issue and still needs to be investigated.

comment:11 Changed 3 years ago by aeichner

The passthrough related crash mhanor reported (thanks a lot for the detailed information!) should be fixed in the next maintenance release. The regression wrt. DVD playback is not fixed yet but there is a possible workaround, at least for the people using Windows newer than XP as a guest. Use a virtual CD/DVD drive attached to the SATA controller instead of IDE and enable passthrough there, AnyDVD should work again.

comment:12 Changed 3 years ago by dewd

Switching the DVD to SATA fixed my issue. Thank you.

comment:13 Changed 3 years ago by frank

Here is an Ubuntu 13.04 build containing the fix. This is a Fedora 18 build and here is a Windows build.

comment:14 Changed 3 years ago by frank

  • Status changed from new to closed
  • Resolution set to fixed

Fix is part of VBox 4.3.22.

Note: See TracTickets for help on using tickets.

www.oracle.com
ContactPrivacy policyTerms of Use