VirtualBox

Ticket #12304 (closed defect: wontfix)

Opened 7 years ago

Last modified 7 years ago

keystrokes reach both the host AND the guest even when the VM is capturing keyboard

Reported by: matteosistisette Owned by:
Component: host support Version: VirtualBox 4.3.2
Keywords: Cc:
Guest type: Windows Host type: Linux

Description

When I hit the "Window" (also called "super") key or the Alt key, even if the icon on the status bar says the virtual machine _is_ capturing keyboard input, BOTH the guest AND the host react to the keystroke.

So for example, when using Internet Explorer or the File Explorer within the window guest, if I hit the Alt key in order to have the application's menu show up, it works, but it also makes the Dash searchbox show up on the ubuntu host at the same time.

This is not only annoying, this makes the guest almost unusable.

Note that the first time I ran the VM, I got an informative message that explicitely told me that keyboard input was being captured and that it would NOT get to the host.

This is a regression. I don't remember which was the last version I had used of VB but this definitely didn't use to happen (and the host was ubuntu too).

This happens whether or not mouse integration is enabled, whenever keyboard input is being captured.

Change History

comment:1 Changed 7 years ago by michael

  • Status changed from new to closed
  • Resolution set to wontfix

I'm sorry to say it, but there is not much we can do here. We do not capture the keyboard fully, because that causes problems with GNOME and Gtk+ applications, including menus and window dragging failing to work. (rdesktop works around this by only capturing the keyboard when the mouse pointer is inside the window, but we didn't like that solution.) Instead we use a weaker form of key capturing which can be overridden by other applications and by single key short-cuts, such as Ubuntu's use of the "Super" key.

Note: See TracTickets for help on using tickets.

www.oracle.com
ContactPrivacy policyTerms of Use