VirtualBox

Ticket #12264 (reopened defect)

Opened 20 months ago

Last modified 3 weeks ago

unregister_netdevice => Fixed in SVN

Reported by: artie Owned by:
Priority: critical Component: network/hostif
Version: VirtualBox 4.3.0 Keywords: unregister_netdevice
Cc: Guest type: Windows
Host type: Linux

Description

The problem I faced seems to be the same as this: https://www.virtualbox.org/ticket/10624

Ubuntu 13.10 with 3.11.0-12 generic kernel, virtualbox 4.3. Using virtualbox 4.2.18 on the same machine is perfect.

So the problem is when shutting down unregister_netdevice waiting for vboxnet0 to become free arrives as message.

Attachments

unregister_netdevice.jpg Download (181.3 KB) - added by artie 20 months ago.
Error message at shutdown
VBoxSVC.log Download (3.4 KB) - added by artie 20 months ago.
diff_unregister_netdev Download (1.6 KB) - added by frank 5 weeks ago.

Change History

Changed 20 months ago by artie

Error message at shutdown

comment:1 Changed 20 months ago by deedweird

I have the same issue.
VirtualBox 4.3.0 r89960
Ubuntu Linux 13.10 64-bit, kernel is 3.11.0-12-generic

There's also a report of this bug in an old ticket: https://www.virtualbox.org/ticket/10624#comment:12

comment:2 Changed 20 months ago by frank

To me it seems that some application is still holding references to that module. Can you check if any VirtualBox application / service is running before you shutdown, especially VBoxSVC, VBoxNetDHCP and/or VBoxNetNAT?

comment:3 Changed 20 months ago by artie

No applications runs. However interesting thing is that while running, VBoxNetDHCP is zombie. Just realized. Can this cause some issue?

comment:4 Changed 20 months ago by frank

Yes, this is at least the reason for the message you saw. The only question is why the VBoxNetDHCP application isn't properly terminated. Please attach a VBox.log file of such a VM session.

comment:5 Changed 20 months ago by artie

Well, now I have 4.3.2 installed, and with windows guest there is no problem any more - but there is one now with android as guest, the same VBoxNetDHCP. Log attached.

Changed 20 months ago by artie

comment:6 Changed 20 months ago by artie

Another interesting news, it seems when I switch network from vboxnet0 to NAT, it runs fine. Am I right when I say this option has been removed from 4.3 and problems are caused by this?

comment:7 Changed 20 months ago by frank

Which option is removed from 4.3? Host IFs are still there and should work.

comment:8 Changed 20 months ago by frank

And which problem do you see with your Android guest? The VBoxSVC.log you attached shows only a few warnings for failed ioctls for certain interfaces on the host, nothing we can blame VBox for.

comment:9 Changed 20 months ago by deedweird

I have upgraded to VirtualBox 4.3.2 r90405, still having the same issue with unregister_netdevice: count = 1 after running Windows Guest with vboxnet0

I use Ubuntu x64, kernel 3.11.3

comment:10 Changed 20 months ago by mheiber

I'm having the same issue, my specs are quite similar:

Ubuntu 13.10, x86_64, kernel 3.11.0-14-generic, Virtualbox 4.3.2. Guest OS is Ubuntu Precise 12.04.3, 4.2.x guest extensions, running in in headless mode.

Even when I just try to run service vboxdrv stop the same error appears in dmesg/syslog. This is with or without virtual machines running.

As an extra angle to consider .. I'm using  vagrant on this machine, which in turn uses virtualbox to manage its virtual machine. The network adapter on the machine is set to NAT and there's a second one set to "Host-only Adapter" with the name coming up as not selected which the gui, rightfully, complains about being an invalid configuration.

Could it be that little detail? (Update: I think this was caused by me unloading the vboxnet module while watching the gui. It didn't turn up again on subsequent tests)

I'll run a few tests.

Last edited 20 months ago by mheiber (previous) (diff)

comment:11 Changed 20 months ago by mheiber

Alright, here are my findings. I did the following things:

  1. After reaching the described VM state, run "service vboxdrv stop"
  2. See whether the error occurs
VM state Result
VM is not running, has never been run during the respected cycleScript runs fine, would not block a reboot
VM is runningScript is blocked, would block a reboot as well
VM has been run once and then stopped, so not running right nowScript is hanging, would stop a reboot
VM is running, with the Host-only Adapter removedScript is hanging, would stop a reboot
VM has been run once and then stopped, not running while running the script, with the Host-only Adapter removedScript runs without errors, would not block a reboot

What I conclude from this are two possible angles:

  1. When a VM is running it is impossible to reboot the host without running into an endless loop of "unregister_netdevice: waiting for vboxnet0 to become free. Usage count = 1". I don't know if this is intended or not, as normally you would shutdown a non-headless guest when closing down your X environment. However, for headless guests this is an issue.
  1. There seems to be an issue with the Host-only Adapter networking triggering an issue within the vboxnetadp network driver (also causing the infamous "unregister_netdevice: waiting for vboxnet0 to become free. Usage count = 1" errors), since that is where the "service vboxdrv stop" script hangs in the end.
    1. As a sidenote: this might be an artifact caused by how/when vagrant sets up its VMs. However, judging from the profile created within virtualbox itself there doesn't seem to be anything suspicious about the setup.

comment:12 Changed 20 months ago by frank

  • Summary changed from unregister_netdevice to unregister_netdevice => Fixed in SVN

The whole problem came from the fact that VBoxNetDHCP connects to VBoxSVC. Therefore VBoxSVC would not terminate, thus VBoxNetDHCP would not terminate (VBoxNetDHCP is a child of VBoxSVC). This will be fixed in the next maintenance release.

comment:13 Changed 20 months ago by mheiber

That is great news! Thank you very much!

comment:14 Changed 19 months ago by frank

  • Status changed from new to closed
  • Resolution set to fixed

Fixed in 4.3.4.

comment:15 Changed 19 months ago by dthevenin

The issue seems to occur again. I am using LXC and when I try to download data, this error occurs.

The issue occurs on VB 4.3.6-91406 for OSX. Then I downgrade to the version 4.3.4-91027, but it still present. The Linux version is: Linux ubuntu 3.5.0-17-generic #28-Ubuntu SMP Tue Oct 9 19:31:23 UTC 2012 x86_64 x86_64 x86_64 GNU/Linux

I not dont know if it's a kernel issue or a VB issue...

Version 1, edited 19 months ago by dthevenin (previous) (next) (diff)

comment:16 Changed 16 months ago by filipegiusti

+1

VirtualBox 4.3.6 r91406 (appears as 4.3.6-dfsg-2 in apt)

Linux 3.11-2-amd64 #1 SMP Debian 3.11.8-1 (2013-11-13) x86_64 GNU/Linux

I'm on Linux Mint Debian Edition.

I couldn't run "service vboxdrv stop" as advised because this service is not available.

comment:17 follow-up: ↓ 18 Changed 15 months ago by mpeters

This is still happening for me using Virtual Box 4.3.10 on Fedora 20 host running CentOS guest machines in headless mode with vboxnet networking using vagrant.

comment:18 in reply to: ↑ 17 Changed 15 months ago by univerio

Replying to mpeters:

This is still happening for me using Virtual Box 4.3.10 on Fedora 20 host running CentOS guest machines in headless mode with vboxnet networking using vagrant.

A fix that worked for me (though I'm running Ubuntu): edit /etc/default/virtualbox and change the line

SHUTDOWN_USERS=""

to

SHUTDOWN_USERS=all

comment:19 Changed 9 months ago by vboxnetadp

Issue is still there for kubuntu 14.04.1 LTS and VirtualBox:

4.3.16-95972~Ubuntu~raring amd64 Oracle VM VirtualBox

kernel version: 3.13.0-36-generic.

Every time when i try to reboot this message spammed every second: unregister_netdevice: waiting for vboxnet0 to become free. Usage count = 1

Unfortunately fix above (SHUTDOWN_USERS=all) didn't help

Last edited 9 months ago by vboxnetadp (previous) (diff)

comment:20 Changed 9 months ago by vboxnetadp

  • Status changed from closed to reopened
  • Resolution fixed deleted

comment:21 Changed 9 months ago by billsdotcom

Can verify that hang on shutdown for "unregister netdevice waiting for vboxnet0" is still an issue.

VBox version: 4.3.12

Host uname: 3.13.0-24-generic #47-Ubuntu SMP x86_64 x86_64 x86_64 GNU/Linux

Guest OS: CentOS 6.5

vboxnet0 is a host-only adapter with default settings. Other adapter is NAT with default settings.

$ tail /home/logos/.config/VirtualBox/VBoxSVC.log
00:00:00.132620 nspr-2   Successfully initialised host USB using sysfs
00:00:00.138525 nspr-2   HostDnsMonitorProxy: Host's DNS information updated:
00:00:00.138540 nspr-2   DNS server 1: 127.0.1.1
00:00:00.138548 nspr-2   DNS domain: xxxxxxxxxxxx.com
00:00:00.149443 nspr-2   NetIfAdpCtlOut: VBoxNetAdpCtl: Error while retrieving link status for vboxnet0: VBoxNetAdpCtl: ioctl failed: Operation not supported
00:00:00.150546 nspr-2   VDInit finished
00:00:00.164184 nspr-2   Loading settings file "/home/logos/VirtualBox VMs/FFN_DEV_LOCAL/FFN_DEV_LOCAL.vbox" with version "1.12-linux"
00:00:00.733709 nspr-3   NetIfAdpCtlOut: VBoxNetAdpCtl: Error while retrieving link status for vboxnet0: VBoxNetAdpCtl: ioctl failed: Operation not supported
00:18:31.404770 nspr-3   NetIfAdpCtlOut: VBoxNetAdpCtl: Error while retrieving link status for vboxnet0: VBoxNetAdpCtl: ioctl failed: Operation not supported
00:18:31.411052 nspr-3   NetIfAdpCtlOut: VBoxNetAdpCtl: Error while retrieving link status for vboxnet0: VBoxNetAdpCtl: ioctl failed: Operation not supported

comment:22 Changed 6 months ago by vushakov

  • Component changed from network/NAT to network

comment:23 Changed 5 months ago by equalitytech

Still a problem with 4.3.20 r96996 Ubuntu 14.04 host with Ubuntu 14.04 guest and using (Vagrant to manage a) MediaWiki-Vagrant guest with VirtualBox as the provider.

comment:24 Changed 3 months ago by Zephyrus

Still a problem for me with the following configuration:

~ $ dpkg -l | grep virtualbox

ii unity-scope-virtualbox 0.1+13.10.20130723-0u all VirtualBox scope for Unity

ii virtualbox-4.3 4.3.24-98716~Ubuntu~r amd64 Oracle VM VirtualBox

~ $ uname -a

Linux <edited out username>-Dell 3.16.0-33-generic #44~14.04.1-Ubuntu SMP Fri Mar 13 10:33:29 UTC 2015 x86_64 x86_64 x86_64 GNU/Linux

~ $ lsb_release -a

No LSB modules are available. Distributor ID: Ubuntu Description: Ubuntu 14.04.2 LTS Release: 14.04 Codename: trusty

~ $ dpkg -l | grep vagrant

ii vagrant 1:1.7.2 amd64 no description given

comment:25 Changed 2 months ago by trashi

same problem here, with almost the same setup:

$ dpkg -l | grep virtualbox
ii  virtualbox-4.3  4.3.26-98988~Ubuntu~raring  amd64  Oracle VM VirtualBox

$ uname -r
3.16.0-34-generic

lsb_release -a
No LSB modules are available.

vagrant = 1.6.5

comment:26 Changed 5 weeks ago by vushakov

  • Component changed from network to network/hostif

comment:27 Changed 5 weeks ago by frank

Here is a 4.3.29 test build which contains a fix which hopefully helps. The two Linux packages on our test builds package contain this fix as well.

But it's also sufficient to just apply the diff I will attach next to the host kernel modules and recompile the host kernel modules with /etc/init.d/vboxdrv setup.

Changed 5 weeks ago by frank

comment:28 Changed 5 weeks ago by frank

Please either try one of the test builds or the diff and tell us if this fixes your problems. Thank you!

comment:29 Changed 3 weeks ago by Zephyrus

Frank, you are a friggin' hero! I can confirm this solved the issue for me (using your test build). My configuration details are in my last post.

Thanks again, dude!

Last edited 3 weeks ago by Zephyrus (previous) (diff)
Note: See TracTickets for help on using tickets.

www.oracle.com
ContactPrivacy policyTerms of Use