Opened 11 years ago

Closed 11 years ago

#12242 closed defect (fixed)

virtualbox interfaces not created in OS X Mavericks

Reported by: tvs Owned by:
Component: other Version: VirtualBox 4.3.0
Keywords: Cc:
Guest type: all Host type: Mac OS X


I had running ok Virtualbox 4.2.x under Mountain Lion. After upgrading to Mavericks, I can't launch any virtual host, they gave me an error that vboxnet1 cannot be opened (I use two network interfaces in all my virtual hosts).

I've upgraded to version 4.3 and it worked but, every time I reboot the computer, I can no longer launch the virtual hosts, I have the same error with vboxnet1.

The only workaround I found is to reinstall Virtualbox, but it's insane to have to reinstall the package every time I need to use virtualbox.

Attachments (1)

VBoxSVC.log (25.0 KB ) - added by markeganfuller 11 years ago.

Download all attachments as: .zip

Change History (7)

comment:1 by markeganfuller, 11 years ago

(Using vagrant)

There was an error while executing `VBoxManage`, a CLI used by Vagrant
for controlling VirtualBox. The command and stderr is shown below.

Command: ["hostonlyif", "create"]
Stderr: 0%...
Progress state: NS_ERROR_FAILURE
VBoxManage: error: Failed to create the host-only adapter
VBoxManage: error: VBoxNetAdpCtl: Error while adding new interface: failed to open /dev/vboxnetctl: No such file or directory
VBoxManage: error: Details: code NS_ERROR_FAILURE (0x80004005), component HostNetworkInterface, interface IHostNetworkInterface
VBoxManage: error: Context: "int handleCreate(HandlerArg*, int, int*)" at line 66 of file VBoxManageHostonly.cpp
  • Virtualbox 4.3
  • Vagrant 1.3.5
  • Mac OSX 10.9 Mavericks

Reinstall fixes issue but reboot breaks it again.

Last edited 11 years ago by markeganfuller (previous) (diff)

by markeganfuller, 11 years ago

Attachment: VBoxSVC.log added


comment:2 by pocamberos, 11 years ago

Failed to open a session for the virtual machine Windows7-64.

Failed to load VMMR0.r0 (VERR_SYMBOL_NOT_FOUND).

Result Code: NS_ERROR_FAILURE (0x80004005) Component: Console Interface: IConsole {8ab7c520-2442-4b66-8d74-4ff1e195d2b6}

comment:3 by Frank Mehnert, 11 years ago

Resolution: duplicate
Status: newclosed

Duplicate of #8940. Please uninstall + re-install VBox 4.3.0 to solve your problem.

comment:4 by tvs, 11 years ago

Ok, I've followed the suggestion of the comment above (uninstall and reinstall VBox 4.3.0) and now I don't need to reinstall to make it work, but now, every time I started VirtualBox, I can't shutdown the computer ... it keeps shutting down forever, I had to hard reset the computer (holding the power button for more than 5 secs)

comment:5 by tvs, 11 years ago

Resolution: duplicate
Status: closedreopened

I've reopened this ticket because there's a new issue with the proposed workaround ... please let me know if I should post this in #8940 instead of keeping this ticket open. Thanks!

Last edited 11 years ago by tvs (previous) (diff)

comment:6 by Frank Mehnert, 11 years ago

Resolution: fixed
Status: reopenedclosed

tvs, please open another ticket for your problem. To me it looks like some application is preventing your host computer to shut down.

Note: See TracTickets for help on using tickets.

© 2023 Oracle
ContactPrivacy policyTerms of Use