VirtualBox

Ticket #12241 (closed defect: fixed)

Opened 6 months ago

Last modified 3 weeks ago

VirtualBoxVM Application can't quit => fixed in SVN

Reported by: i.maravic Owned by:
Priority: critical Component: guest control
Version: VirtualBox 4.3.0 Keywords:
Cc: Guest type: Linux
Host type: Mac OS X

Description

On the Mac Pro Retina, with the MacOSx Maverics, VirtualBoxVM Application just keeps hanging and can't quit. It worked normally on the previous Mac OSx.

This happens when I send the shutdown signal to the guest OS. Guest OS terminates cleanly, VirtualBoxVM process closes nicely, but the icon keeps hanging in the dock.

I've tried to Force Quit it, but it refuses to do that. Since it can't be closed I can't shutdown my Mac, so I need to do forced shutdown.

When I looked system.log, I only found this suspicious lines concerning the VirtualBoxVM:

Oct 23 21:59:26 Igors-MacBook-Pro.local VirtualBoxVM[840]: IOHIDDeviceRegisterInputValueCallback called with a null context

This was printed when the guest machine was started and when it was shutting down.

I've attached screen shots

Attachments

Screen Shot 2013-10-23 at 22.11.05.png Download (139.5 KB) - added by i.maravic 6 months ago.
Screen Shot 2013-10-23 at 22.10.34.png Download (101.5 KB) - added by i.maravic 6 months ago.
Screen Shot 2013-10-23 at 22.11.40.png Download (109.3 KB) - added by i.maravic 6 months ago.
Screen Shot 2013-10-23 at 22.15.17.png Download (320.7 KB) - added by i.maravic 6 months ago.
v-box.zip Download (25.4 KB) - added by Glenarvan 4 months ago.
log files
ps_out.txt Download (19.7 KB) - added by Glenarvan 4 months ago.
ps -Af output
Screen Shot 2013-12-18 at 16.34.42.png Download (230.4 KB) - added by Glenarvan 4 months ago.
after switching off the vm 2 v-box icons appear in the doc (the right one shouldn't be there)
VBox.log.1 Download (132.1 KB) - added by Skyke 3 months ago.
Skyke_vbox.log
Vbox log Download (97.2 KB) - added by Baxil 3 months ago.
VBox.log Download (86.1 KB) - added by typhoo 3 months ago.
VBox.2.log Download (89.2 KB) - added by Danois 2 months ago.
My latest log file

Change History

Changed 6 months ago by i.maravic

Changed 6 months ago by i.maravic

Changed 6 months ago by i.maravic

Changed 6 months ago by i.maravic

comment:1 Changed 6 months ago by i.maravic

If I run the uninstall script, kernel modules are unloaded, and the VirtualBoxVm icon is removed from the Dock.

comment:2 Changed 6 months ago by djf_jeff

I can confirm this bug. I has hit me three time today. Mac OS X 10.9, VirtualBox 4.3. When I quit VirtualBox, it stays open in my dock. When I try to force quit it, it stays there too.

So, I cannot restart or shutdown my laptop cleanly without holding the power key. I tried leaving it there for a while but it didn't work too.

comment:3 Changed 6 months ago by newtonick

I can confirm I'm having the same issue. This occurs after I have started a VM then shutdown the VM. The VirtualBox icon will remain in the dock (force quit does not work to remove it). VirtualBox continues to work as expected, but the icon remains and prevents os x from doing a clean shutdown.

If I unload the kernel extension by running:

sudo kextunload -m org.virtualbox.kext.VBoxNetAdp

The dock icon immediately disappears.

However, I'm not able to reload the kernel extension.

I've tried to stop and start the extensions using:

sudo "/Library/Application Support/VirtualBox/LaunchDaemons/VirtualBoxStartup.sh" stop
sudo "/Library/Application Support/VirtualBox/LaunchDaemons/VirtualBoxStartup.sh" start

but when running 'stop' I get the following error:

Unloading VBoxUSB.kext
Unloading VBoxNetFlt.kext
(kernel) Kext org.virtualbox.kext.VBoxNetFlt did not stop (return code 0x5).
(kernel) Kext org.virtualbox.kext.VBoxNetFlt can't unload - module stop returned 0xdc008017.
Failed to unload org.virtualbox.kext.VBoxNetFlt - (libkern/kext) kext (kmod) start/stop routine failed.
Error: Failed to unload VBoxNetFlt.kext
Unloading VBoxNetAdp.kext
Unloading VBoxDrv.kext
(kernel) Can't remove kext org.virtualbox.kext.VBoxDrv; services failed to terminate - 0xdc008018.
Failed to unload org.virtualbox.kext.VBoxDrv - (libkern/kext) kext is in use or retained (cannot unload).
Error: Failed to unload VBoxDrv.kext
Fatal error: VirtualBox

I've noticed that my host-only network adapter is gone after I stop the org.virtualbox.kext.VBoxNetAdp extension. This is as far as I was able to get. Would love to see this fixed soon. Hope this information helps.

-- I am running on a Macbook Air 2013 Running OS X 10.9

Last edited 6 months ago by newtonick (previous) (diff)

comment:4 Changed 6 months ago by fromagique

I have found that this problem (at least in my case) is caused by the host-only interface ("vboxnet0" on my machine). If I don't have a host-only interface active on a given VM, it will stop cleanly. If one is active, the "stuck" behavior will be exhibited, the VM will be unable to be Force Quit and will prevent shutdown or reboot from the GUI. The machine can, however, be rebooted or shut down from the command line via "sudo reboot" or "sudo shutdown -h now", although there is a significant delay before the actual reboot/shutdown occurs (up to a minute).

I have also found that removing the host-only interface via "VBoxManage hostonlyif remove vboxnet0" will clear the condition and allow the stuck VM to finish its shutdown and disappear from the Dock.

I have found these behaviors to be consistent across Debian 7.2 i386, Debian 7.2 x86-64, Ubuntu 13.10 x86-64, and Ubuntu 12.04 i386 guests.

I am running OS X 10.9 on an iMac 12,1 (mid-2011). I am also running with the Gatekeeper settings on their lowest setting--that is, in the "General" tab of the "Security & Privacy" pane of System Preferences, I have selected the "Allow apps downloaded from anywhere" option.

Last edited 6 months ago by fromagique (previous) (diff)

comment:5 Changed 6 months ago by paha77

I have the same issue. OSX Mavericks, Macbook pro mid 2012. I have host only networking too.

comment:6 follow-up: ↓ 7 Changed 6 months ago by shakmac

I can confirm same issue. OSX Mavericks, iMac late 2012 with host only network. Serious issue--can't force quit. Necessary to do a manual shutdown. On restart I get a kernel error and have to uninstall/reinstall virtual box. Anyone know a workaround until this is fixed?

comment:7 in reply to: ↑ 6 Changed 6 months ago by i.maravic

Replying to shakmac:

I can confirm same issue. OSX Mavericks, iMac late 2012 with host only network. Serious issue--can't force quit. Necessary to do a manual shutdown. On restart I get a kernel error and have to uninstall/reinstall virtual box. Anyone know a workaround until this is fixed?

My workaround is to uninstall VBox before shutting down the Mac. When I do that I can shut it down cleanly. I install VBox when I start my Mac.

comment:8 Changed 6 months ago by hughw

I confirm the workaround from fromagique ticket:12241#comment:4 works for me.

VBoxManage hostonlyif remove vboxnet0

(or whatever vboxnetX host only interface your VM uses)

Last edited 6 months ago by hughw (previous) (diff)

comment:9 Changed 6 months ago by ezrafree

I'm experiencing this issue also, ever since upgrading Mac OS to Mavericks 10.9 (was working fine for the previous year before then).

I am also able to get rid of the zombie icon using the "VBoxManage hostonlyif remove vboxnet0" command and then running "VBoxManage hostonlyif create" to recreate vboxnet0 before starting the VM again.

comment:10 Changed 6 months ago by ion

Same issue (hung icon on Dock, system shutdown does not work, "VBoxManage hostonlyif remove vboxnet0" workaround works fine) on:

  • Mavericks 10.9
  • VirtualBox 4.3 (upgraded from 4.2.18 after the OSX upgrade)
  • MacBook Pro 6,2 (Mid 2010)
  • Guests using both NAT and host-only network adapters

Noticed the same issue here:  https://discussions.apple.com/thread/5480186?tstart=0 and here:  https://forums.virtualbox.org/viewtopic.php?f=8&t=58058&sid=ea0c35e1197dfe68528f5fe8f789c25b&start=15 (where the workaround is suggested).

comment:11 Changed 6 months ago by myshell

I confirm the same issue.

If I launch my guests machines (Linux and Windows) through the VBoxHeadless command, the bug doesn't occurs. I can shutdown guest without having the hung icon on Dock

Hope it will be helpfull

comment:12 Changed 6 months ago by SiliconBeacher

I also have this exact same issue. OS X 10.9 (13A603) with Virtual Box 4.2.18 (r88780) attempting to use a guest NAT and host-only adapter. Tried clean uninstall and re-install to no avail. The only way I am able to work is to use the command-line workaround at this time.

comment:13 Changed 5 months ago by Udo

I'm having the same issue. I'm using Mavericks 10.9 and VirtualBox 4.3.2.

comment:14 Changed 5 months ago by SiliconBeacher

I tried upgrading to 4.3.2 r90405 and the problem still remains.

comment:15 Changed 5 months ago by KAZA51

Hello, I confirm I have the same problem. Macbook pro 15" rétina screen, upgraded to OS X 10.9 (mavericks) Virtualbox 4.3.2 with extensions I do not use HOST ONLY adapters and I have the same problem with BRIDGED adapters or even if I detach there adapter before closing the VM (mostly a unique WIN7 pro VM) The vb icon would stick in the dock and the mac won't power off (except by brute force holding the power button). Need a fix quickly as this happens 5 times a day ...

comment:16 Changed 5 months ago by vizz8info

virtual box 4.3.0 on windoz8.1 host with xubuntu 12 guest never shuts down

comment:17 Changed 5 months ago by JokerJ

VirtualBox 4.3.2 r90405, OSX 10.9 Mavericks on MB Pro early 2012 - using HOST ONLY-adapters. Observing exactly same problem. No way to shut down other than brute force holding powerbutton).

comment:18 Changed 5 months ago by frank

JokerJ, please look at comment 8.

comment:19 Changed 5 months ago by tvs

I confirm the same problem on my Macbook Pro. It happens in both VirtualBox 4.3.0 and 4.3.2.

This is a very important bug, when can this be expected to be fixed?

Last edited 5 months ago by tvs (previous) (diff)

comment:20 Changed 5 months ago by xdissent

I'm also getting this message in system.log when starting a VM on Mavericks:

Nov 19 13:24:18 Crow kernel[0]: VirtualBox (map: 0xffffff801a6432d0) triggered DYLD shared region unnest for map: 0xffffff801a6432d0, region 0x7fff89400000->0x7fff89600000. While not abnormal for debuggers, this increases system memory footprint until the target exits.

The message does not appear on my 10.8 machines. Not sure if it's related.

comment:21 Changed 5 months ago by bulletmark

@frank, regarding your comment 18, you are advising people that a:

VBoxManage hostonlyif remove vboxnet0

can be used to allow VB to shut down. I did this but then my guest VM's would fail to start ever again. I discovered that if you type the above command then you must later (even after a host restart) type:

VBoxManage hostonlyif create

to restore the vboxnet0 interface and allow guests using it to start again.

Last edited 5 months ago by bulletmark (previous) (diff)

comment:22 Changed 5 months ago by Alecs

I do confirm exactly the same issue on iMac upgraded to OS X 10.9 (Mavericks). it's a very important bug, absolutely no way to shut down other than force holding power button, with the risk to damage some data.

When will it be fixed?

comment:23 Changed 5 months ago by frank

bulletmark, yes, of course. It's not more than a workaround. The problem is two-fold. The first problem is that VBoxNetDHCP does not terminate automatically and prevents VBoxSVC from shutting down (4.3.0 regression). We fixed this problem and the fix will be available soon. The other problem is that the VBoxNetAdp KExt has to be disabled. This is a Mavericks regression and finding the fix is more difficult. We are working on it.

comment:24 Changed 5 months ago by frank

  • Status changed from new to closed
  • Resolution set to fixed

Fixed in 4.3.4.

comment:25 Changed 4 months ago by tvs

Thank you very much! I really needed this fix!

comment:26 Changed 4 months ago by Zzar

  • Status changed from closed to reopened
  • Resolution fixed deleted

I am still getting this issue with 4.3.4 r91027

Shutdown VM and icon remains in Dock. Cannot Force Quit and cannot shutdown Mac.

Last edited 4 months ago by Zzar (previous) (diff)

comment:27 Changed 4 months ago by onethreenine

I am also still experiencing this issue with 4.3.4 r91027 on a MacBookPro8,2 host running OS X 10.9 (13A603). The VirtualBoxVM icon is unresponsive to Force Quit and blocks system shutdown through the GUI.

comment:28 Changed 4 months ago by frank

I miss the VBox.log files of such a VM session from both of you.

comment:29 Changed 4 months ago by ion

For me, 4.3.4 fixed the issue; running OSX 10.9 (mavericks), virtual box upgrade path: 4.2.18 -> 4.3 -> 4.3.2 -> 4.3.4. Before 4.3.4, I had to use the "VBoxManage hostonlyif remove vboxnet0" workaround to shut down OSX.

comment:30 Changed 4 months ago by frank

Thanks ion, that was the plan :) Therefore I wonder what happens for the other two users :)

comment:31 Changed 4 months ago by nadi

I have similar problem with version 4.3.4 (also with previous). Sometimes after awaking from suspend my Mac OSX, VirtualBox just don't respond. It is active (icon in dock), but I can't neither show virtual machine window nor kill it by Force Quit. Also my Maverics don't wanna close (I need to do it by pressing longer power button).

I tried to use:

sudo "/Library/Application Support/VirtualBox/LaunchDaemons/VirtualBoxStartup.sh" stop

effect:

Unloading VBoxUSB.kext
Unloading VBoxNetFlt.kext
Unloading VBoxNetAdp.kext
Unloading VBoxDrv.kext

and also:

sudo kextunload -m org.virtualbox.kext.VBoxNetAdp

effect:

(kernel) Kext org.virtualbox.kext.VBoxNetAdp not found for unload request.
-bash: syntax error near unexpected token `Kext'

and VBox was still in dock.

Other trying (I've trying although I don't use host only network, I have two bridged interfaces):

VBoxManage hostonlyif remove vboxnet0
VBoxManage: error: The host network interface with the given name could not be found
VBoxManage: error: Details: code NS_ERROR_INVALID_ARG (0x80070057), component Host, interface IHost, callee nsISupports
VBoxManage: error: Context: "FindHostNetworkInterfaceByName(name.raw(), hif.asOutParam())" at line 92 of file VBoxManageHostonly.cpp

In system.log I have only these messages:

05/12/13 11:25:53,723 VirtualBoxVM[850]: XPC error messaging com.apple.IconServicesAgent: Connection interrupted
05/12/13 11:25:53,723 VirtualBoxVM[850]: XPC error messaging com.apple.IconServicesAgent: Connection invalid
05/12/13 13:04:32,153 VirtualBoxVM[850]: modalSession has been exited prematurely - check for a reentrant call to endModalSession:
05/12/13 13:10:15,237 VirtualBoxVM[850]: modalSession has been exited prematurely - check for a reentrant call to endModalSession:
05/12/13 13:11:20,534 VirtualBoxVM[850]: modalSession has been exited prematurely - check for a reentrant call to endModalSession:

:(

Last edited 4 months ago by nadi (previous) (diff)

comment:32 Changed 4 months ago by YTC1

I'm still having the issue (VM 4.3.4, OSX 10.9)

The previous options to shutdown the session

sudo kextunload -m org.virtualbox.kext.VBoxNetAdp

and

sudo "/Library/Application Support/VirtualBox/LaunchDaemons/VirtualBoxStartup.sh" stop

both fail

(kernel) Kext org.virtualbox.kext.VBoxNetAdp not found for unload request. Failed to unload org.virtualbox.kext.VBoxNetAdp - (libkern/kext) not found

comment:33 follow-up: ↓ 35 Changed 4 months ago by galitsyn

YTC1, which icon do you observe in Dock with 4.3.4? A VirtualBox Manager's one (not VM's window icon)?

comment:34 Changed 4 months ago by Glenarvan

Hi there,

I also have the same problem: vm is set to saved status, the icon of the vm's window (not the manager as this window I close usually right after starting my vm) in the doc appears as running; then using CMD+ALT+ESC I see the process of vbox and try to force shutdown it, though it does not work; even logging out a user or rebooting the system can't be enforced. This is new since the upgrade to vbox 4.3.4 (was working with previous vbox versions on OS X 10.8 and 10.9). My mac book pro is not a retina one. Please advise.

comment:35 in reply to: ↑ 33 Changed 4 months ago by Glenarvan

Replying to galitsyn:

YTC1, which icon do you observe in Dock with 4.3.4? A VirtualBox Manager's one (not VM's window icon)?

Hi galitsyn: please see my description below. Regards.

comment:36 Changed 4 months ago by Glenarvan

What worked for me last time when testing is: I kept the vm-manager window open and run "close-save state" of my vm from there; then there is no orphan vm-window anymore.

Still when vm-manager has been closed while a vm was running, the orphan window stays in the doc even if the vm is in saved state.

comment:37 Changed 4 months ago by galitsyn

Can't reproduce the issue here. Could you please attach VBox.log and VM config?

comment:38 Changed 4 months ago by Glenarvan

got mail?

comment:39 Changed 4 months ago by galitsyn

Glenarvan, have not received a mail. Could you please attach files here?

Changed 4 months ago by Glenarvan

log files

comment:40 Changed 4 months ago by EmDashMan

I'm another victim of this bug.

I'm using a very new 15" MBP running Mac OS X 10.9 (Mavericks). I tried the uninstall/proper reinstall of VirtualBox. Still broken. Every time I use a VM, I am unable to kill the zombie process and shut down properly - I have hold down the On/Off button and force a shutdown (or do shutdown -h now).

I'm using the Thunderbolt interface for networking.

comment:41 Changed 4 months ago by galitsyn

Still can't reproduce. Could you please confirm that you are not running (in parallel to VBox) any App or process like IORegistryExplorer? This App connects to all registered in system IOServices (including VBox one) and keeps connection until terminated. If you have doubts, could you please attach ps -Af output?

Changed 4 months ago by Glenarvan

ps -Af output

Changed 4 months ago by Glenarvan

after switching off the vm 2 v-box icons appear in the doc (the right one shouldn't be there)

comment:42 Changed 3 months ago by Glenarvan

Unfortunately it didn't changed with the recent update to VBox 4.3.6 r91406 - still the same behaviour on my mac.

comment:43 Changed 3 months ago by starion

Ditto everything above. I'm having same issue on a MacBook Pro and iMac i3. Both running Mavericks 10.9.1. Further, if you try to do a restart/shutdown, VirtualBox prevents it from happening and no apps (including console or terminal) can be started because the system is in shutdown. Only way to recover is to do a hard shutdown.

Last edited 3 months ago by starion (previous) (diff)

comment:44 Changed 3 months ago by frank

All users still having this problem: Please attach VBox.log files for such a VM session which are not properly terminated.

Changed 3 months ago by Skyke

Skyke_vbox.log

comment:45 Changed 3 months ago by Skyke

I have the same issue which is quite frustrating :'(
Vbox.log is attached.

comment:46 Changed 3 months ago by frank

We still cannot reproduce this problem but more VBox.log files are welcome. Also you could try to change your configuration. For instance, can you confirm that the problem goes away if your VM doesn't use host-only networking? To test this, shut down the VM, make sure the VM is really terminated (perhaps even reboot the host), then switch the VM configuration to NAT, then start the VM and shut down it.

comment:47 Changed 3 months ago by Baxil

I am also experiencing the same issue of the VB icon refusing to leave the dock on the mac even though I've quit the program. VirtualBox continues to run somewhere in the background which prohibits my macbook from shutting down unless I hold down the power button.

I am currently working on a Macbook Pro 2012 (without retina). System came installed with Mavericks. I installed VB 4.3.6 to run Windows 7 Home Premium in the virtual machine. Prior to this I never had any other version of Virtual Box installed on my machine.

Network Settings:

  • adapter 1: wifi with bridge adapter and the box checked for cable connection.
  • adapter 2: ethernet with bridge adapter and the box checked for cable connection.


I have tried rebooting the VM and changing the adapter configurations but VirtualBox continues to cause my system to hang when shutting down.

Changed 3 months ago by Baxil

comment:48 Changed 3 months ago by Baxil

I also wanted to confirm that I am not running an "App or process like IORegistryExplorer" which could interfere with Virtual Box.

If you need any further configuration details of my VM please let me know.

Last edited 3 months ago by Baxil (previous) (diff)

comment:49 Changed 3 months ago by grauerbereich

I can confirm that issue on VBox4.3.6 on OS X 9.1 host (MacBookPro9,1 and MacBookPro11,3). However, this only seems to happen while I am connected via Thunderbolt/Ethernet (equally with Adapter or Thunderbolt display).

comment:50 Changed 3 months ago by grauerbereich

OK, after a dozen host reboots later I'll have to state that my above statement related to tbolt was a bit premature and thus misleading. I did some tests with two macbookpros, one with tbolt eth adapter attached, one with builtin eth. Both hosts have a vm with a bridged interface to buitin or thunterbolt ethernet respectively:

  1. Fresh boot of host while host ethernet link down (no cable plugged in), started vm, shutdown vm -> vm icon stays in dock
  2. Fresh boot of host while host ethernet link up (cable plugged in), startet vm, shutdown vm -> vm terminates properly
  3. Subsequent vm launches (no host reboot) after scenario 2., with host ethernet link down, do terminate properly.
  4. Fresh boot of host while host ethernet link up, then host ethernet disconnected, then starting VBox gui, then starting vm, shutdown vm -> vm terminates properly

So it seems that vms connected to ethernet only terminate properly, if host ethernet link was up once during host uptime - not matter if VBox gui was running at that time or not...

Changed 3 months ago by typhoo

comment:51 Changed 3 months ago by typhoo

After upgrading from VBox 4.216 to 4.36, VBox does not shut down properly. Force quit does not work. I have to do a cold power switch reset of entire system to close down. I'm running OS X 10.9.1. vbox.log attached.

I noticed there were two VBox icons on my dock. When closing the main VBox window, one icon closes, the other doesn't. The second icon may have appeared when i launched a VM in VBox?

comment:52 follow-up: ↓ 57 Changed 3 months ago by Calalupot

Hello all,

facing the very same problem as desribed above.

Based on the comment of grauerbereich I did the following:

My actual setup of Network is
Adapter 1: Network Bridge : WLAN
Adapter 2: Network Bridge : Ethernet (IntelRPO/1000)
Causing the two VM icons, one never closing.

Turning off Adapter 2 (Ethernet) only (before VM starting!), VM was shutting down properly.
Turning off Adapter 1 (WLAN) only, VM was shutting down improperly.

Last edited 3 months ago by Calalupot (previous) (diff)

comment:53 follow-up: ↓ 54 Changed 3 months ago by typhoo

Calalupot said >> "Turning of Adapter 2 (Ethernet) . . ."

Do you mean "Turning on", or "Turning off" for each adapter?

comment:54 in reply to: ↑ 53 Changed 3 months ago by Calalupot

Replying to typhoo:

Calalupot said >> "Turning of Adapter 2 (Ethernet) . . ."

Do you mean "Turning on", or "Turning off" for each adapter?

I meant turning off

sry for the mistyping :-)

comment:55 Changed 3 months ago by IGOR

Hello All,

Any solution for this problem? I also can not turn off my computer after using VirtualBox.

Some corrective patch for this problem?

comment:56 Changed 3 months ago by Bal

Hello,

I'm facing this problem as well. I have tried most of the various suggestions in this post.

My setup:

Macbook Pro 13 late 2012 Mavericks OSX VirtualBox 4.3.6 Windows 7 VM with 2 network adapters, adapter 1 is NAT, adapter 2 is host-only.

I have noticed that my battery is draining faster, losing 10% in the space of 10 minutes. Seriously thinking of moving away from VirtualBox onto VWware or Parallels if this doesn't get sorted in the next few months.

Thanks, Bal

comment:57 in reply to: ↑ 52 Changed 3 months ago by tippytoes

Replying to Calalupot:

Hello all,

facing the very same problem as desribed above.

Based on the comment of grauerbereich I did the following:

My actual setup of Network is
Adapter 1: Network Bridge : WLAN
Adapter 2: Network Bridge : Ethernet (IntelRPO/1000)
Causing the two VM icons, one never closing.

Turning off Adapter 2 (Ethernet) only (before VM starting!), VM was shutting down properly.
Turning off Adapter 1 (WLAN) only, VM was shutting down improperly.

Thank you so much for this tip! It worked for me. I disabled Adapter 2: Network Bridge: Ethernet and only kept Adapter 1 Wi-Fi and that did the trick. Right now I'm only using Wi-Fi anyways but hopefully there will be a permanent fix so that this step isn't necessary.

comment:58 Changed 2 months ago by Glenarvan

Hi All,

not being reliant on the latest vbox 4.3.x branch, I'm finally giving up hard-resetting my mac book and downgraded to vbox 4.2.18, where this behaviour was not an issue.

Cheers.

comment:59 Changed 2 months ago by jpbochi

The only way to really force restart that worked for me was this.

sudo shutdown -h now

Will try to install virtualbox 4.2 now.

Changed 2 months ago by Danois

My latest log file

comment:60 Changed 2 months ago by Danois

Same problem here! OS X 10.9.1 VirtualBox VM 4.3.6 r91406

Some of my other applications can't open now. I see the window for a short moment then it disappears again. Haven't been successful in shutting down VB in any way.

comment:61 Changed 2 months ago by grauerbereich

Regarding the latest additions from jpbochi/danois: After doing logout/shutdown with a "dead" Virtualbox icon present in the Dock, all processes launched after that are killed immediately, no chance to start a terminal to "shutdown -h now" gracefully. What I did/do in such cases is to SWITCH USER and shutdown from that other account, which allows me to shutdown gracefully. That's why this issue is not a total showstopper to me but it requires to have at least two accounts on the Mac in question.

comment:62 Changed 2 months ago by galitsyn

Guys, could you please try this test build and check if the issue has been resolved for you?

comment:63 follow-ups: ↓ 65 ↓ 67 Changed 2 months ago by grauerbereich

Tried it and it seems to work. However, it could as well be related to the Extensions-Pack 4.3.6 which I could not run with the 4.3.53-92043 build.

I did install 4.3.53-92043, restart, run (with no Extension-Pack): Icon goes away on VBox-VM shutdown.

I did reinstall 4.3.6, restart Mac, run (without Extension-Pack): Icon goes away on VBox-VM shutdown.

Did reinstall Extension-Pack 4.3.6, restart Mac, Dead Icon titled "VirtualBoxVM" stays in Dock.

So, I do have the impression that it's rather a VBox Extension Pack issue, than a VBox issue. I also do think that it's important that tests are being done on a freshly rebooted host system (see comment no 50).

comment:64 Changed 2 months ago by grauerbereich

Which (see comment 63) raises the question: Is anyone experiencing that problem who has no "Oracle VM VirtualBox Extension Pack 4.3.6r91406" installed?

comment:65 in reply to: ↑ 63 Changed 2 months ago by frank

Replying to grauerbereich:

So, I do have the impression that it's rather a VBox Extension Pack issue, than a VBox issue. I also do think that it's important that tests are being done on a freshly rebooted host system (see comment no 50).

It is very unlikely that this problem is related to the Extension Pack. After you installed 4.3.6 without Extension Pack, make sure that you completely shut down your host (power-off) and then boot it again before you test. Because the workaround which is part of the 4.3.53 package has a permanent effect, that is, once successfully started 4.3.53 it is most likely that a 4.3.6 package will also successfully start / terminate without the icon issue.

comment:66 Changed 2 months ago by scriptrix

I am still seeing the issue under 4.3.6 without the extension pack. The test build 4.3.53-92043 seems to work. Steps below

Installed 4.3.53-92043 restarted host, started VM and shutdown - Icon no longer displayed in dock Uninstalled 4.3.53-92043 restarted host Installed 4.3.6 (without extension pack) restarted host, started VM and shutdown - Icon still in dock (Same issue encountered with extension pack installed)

comment:67 in reply to: ↑ 63 Changed 2 months ago by galitsyn

Replying to grauerbereich:

Tried it and it seems to work. However, it could as well be related to the Extensions-Pack 4.3.6 which I could not run with the 4.3.53-92043 build.

Please note that 4.3.6 ExtPack is not supposed to work with provided 4.3.53-92043 build. Could you please try this Extension Pack and confirm if the issue has gone for you?

comment:68 Changed 2 months ago by scriptrix

I have installed the extension pack provided on top of the 4.3.53-92043 build and the issue has gone for me

comment:69 Changed 2 months ago by grauerbereich

OK, it was late, I was tired, and was testing on two Macs in parallel. So maybe there was some inaccuracy in my yesterdays observations... Here's my todays findings, with and without Ext-Pack:

  1. Unininstalled VBox 4.3.6 with script (VirtualBox_Uninstall.tool)
  2. Restarted host
  3. Installed VBox 4.3.53-92043
  4. Had to disable USB2 on the VM as it threw an error since Extensions are now gone.
  5. Launched VM/shutdown VM, icon terminates properly.
  6. Installed Extension_Pack 4.3.53-92043
  7. Restarted host
  8. Launched VM/shutdown VM, icon terminates properly
  9. Enabled USB2, launched VM/shutdown VM, icon terminates properly.
  10. Restarted host
  11. Launched VM/shutdown VM, icon terminates properly

So problem solved. You shall receive the "iconoclast" award for this. Thanks a lot.

comment:70 Changed 2 months ago by galitsyn

  • Summary changed from VirtualBoxVM Application can't quit to VirtualBoxVM Application can't quit => fixed in SVN

Guys, thank you for your patience and verifying the solution. I take this issue like a fixed one. Fix will be available with the next maintenance release.

comment:71 Changed 2 months ago by PhilW

Can you provide a link to an early release of the next release? Or a a link 4.3.53 I am work for Oracle, so can you send to my Oracle email,please?

comment:72 Changed 7 weeks ago by frank

  • Status changed from reopened to closed
  • Resolution set to fixed

Fix is part of VBox 4.3.8.

comment:73 Changed 3 weeks ago by nphilly

4.3.8 Did not fix this problem either, exact same behaviour

comment:74 Changed 3 weeks ago by frank

nphilly, please could you open a new ticket and attach a VBox.log file? In fact I would appreciate if you could test VBox 4.3.10 before you open the ticket. Thank you!

Note: See TracTickets for help on using tickets.

www.oracle.com
ContactPrivacy policyTerms of Use