VirtualBox

Ticket #1224 (closed defect: fixed)

Opened 6 years ago

Last modified 5 years ago

Can't create files in share

Reported by: liquidat Owned by:
Priority: critical Component: shared folders
Version: VirtualBox 1.5.6 Keywords: permission denied share data loss
Cc: Guest type: other
Host type: other

Description

When I create a share I am able to modify and also to delete files without any problem. However, when I try to create a share it fails due to insufficient rights:

Cannot create regular file 'fsda': Permmission denied.

This even happens when I try to create a file as root. The mount options are not the problem, 'mount' says the share is mounted rw.

The problem here is that some programs save files via deletion and re-creation. While that behaviour is nuts enough it makes the program unusable and makes it likely that other users might loose data!

Change History

comment:1 Changed 6 years ago by sandervl73

Not enough information. Which host, which guest?

comment:2 Changed 6 years ago by dougb95@…

I'm not the original poster, but I'm seeing the same issue -- there seem to be a couple here ...

I'm using Virtualbox 1.5.6 on Vista Business x64. My guest OS is Fedora 8 (Linux 2.6). I created a shared folder through the Virtualbox GUI and mounted it in the guest OS using "mount -t vboxsf -ouid=500,gid=500 <sharename> /media/myshare"

I could edit existing files with emacs as user 500, but I couldn't create anything. I would get the same Permission:denied messag as above. I su'd to root, and tried to do the same, and I got the following error in /var/log/messages after executing "touch blah" in the shared folder: "setroubleshoot: SELinux is preventing touch (unlabeled_t) to "associate" to blah (unlabeled_t)" After disabling SELinux, this message went away, and root was able to create files again. I logged back in as myself -- uid 500 -- and I am still not able to create files. I just get the permission denied error.

Hope that's helpful ...

comment:3 Changed 6 years ago by frank

  • Component changed from other to shared folders

comment:4 Changed 5 years ago by sandervl73

  • Status changed from new to closed
  • Resolution set to fixed

Try again with the 2.1.2 and reopen if required. Thanks.

Note: See TracTickets for help on using tickets.

www.oracle.com
ContactPrivacy policyTerms of Use