VirtualBox

Ticket #12198 (closed defect: duplicate)

Opened 6 months ago

Last modified 3 months ago

Guru Meditation (VINF_EM_TRIPLE_FAULT) when trying to boot from the network => Fixed in SVN

Reported by: MattO Owned by:
Priority: major Component: network
Version: VirtualBox 4.3.0 Keywords: lan boot ipxe
Cc: Guest type: all
Host type: Mac OS X

Description

Booting from LAN crashes when VT-x/AMD-V is enabled on OS X. (Happen on Linux too.) Both processors are in the Core 2 Duo family. Working fine on a Core i5.

Attachments

VBox.log.zip Download (81.3 KB) - added by MattO 6 months ago.
VBox.log
VBox.png Download (44.1 KB) - added by MattO 6 months ago.
Screenshot
VBox.Ch4m3l30n.log.zip Download (33.5 KB) - added by Ch4m3l30n 5 months ago.
VBox crash on safe 20131211.log Download (195.3 KB) - added by brewmanz 4 months ago.
Win7(64) crash at F8-Bootmenu under Ubuntu 12.04(64)
VBox crash on safe 20131211.png Download (13.7 KB) - added by brewmanz 4 months ago.
Win7(64) crash under Ubuntu(64) 12.04 at F8 BootMenu
VBox crash during Win7 bootmenu.png Download (3.6 KB) - added by brewmanz 4 months ago.
FYI screenshot of crash during Win7(64) crash recovery!
VBox.log Download (224.0 KB) - added by DerEinzigeKlaus 3 months ago.

Change History

Changed 6 months ago by MattO

VBox.log

Changed 6 months ago by MattO

Screenshot

comment:1 Changed 6 months ago by frank

  • Summary changed from Guru Meditation when trying to boot from the network to Guru Meditation (VINF_EM_TRIPLE_FAULT) when trying to boot from the network

comment:2 Changed 5 months ago by mjsvmax

I am having this same problem on Windows and Solaris, booting iPXE from LAN or ISO. All was working well until upgrade to 4.3.

comment:3 follow-up: ↓ 6 Changed 5 months ago by frank

mjsvmax, do you have the extpack installed? I know it should also work without but it makes a difference: Without the extpack, VBox 4.2 used the old Etherboot code while VBox 4.3 uses the newer iPXE code. With the extpack installed, VBox 4.2 and VBox 4.3 should behave very similar.

comment:4 Changed 5 months ago by Jan Jurkus

I have the same problem, after upgrading from 4.2.16 to 4.3.2 Host is Windows XP x64, and do not have any extension packs installed.

When starting from the network on a different computer with 4.2.16 it does not show anything about etherboot. It just uses an Intel PXE boot rom.HHHH just saw this version does have the extension pack installed. I can't remember to have ever installed it, because of the PUEL license.

So for the time being, installing the extension pack fixed this. What kind of iPXE code is being used? It is called 1.0 quite a while, and it is probably better to get a newer version from the git repository:  http://git.ipxe.org/ipxe.git

comment:5 follow-up: ↓ 7 Changed 5 months ago by frank

Guys, we fixed a bug which could be related to your problem. Could you check if one of the following builds fixes the problem for you?  Here is a Windows package and  here is an OS X package. And  here is the corresponding extension pack. Thank you!

comment:6 in reply to: ↑ 3 Changed 5 months ago by mjsvmax

Replying to frank:

mjsvmax, do you have the extpack installed? I know it should also work without but it makes a difference: Without the extpack, VBox 4.2 used the old Etherboot code while VBox 4.3 uses the newer iPXE code. With the extpack installed, VBox 4.2 and VBox 4.3 should behave very similar.

I tried with and without the extpack.

comment:7 in reply to: ↑ 5 Changed 5 months ago by mjsvmax

Replying to frank:

Guys, we fixed a bug which could be related to your problem. Could you check if one of the following builds fixes the problem for you?  Here is a Windows package and  here is an OS X package. And  here is the corresponding extension pack. Thank you!

All I have available at the moment is a Solaris host (OpenIndiana), I'll give it a shot as soon as I have a Windows box with HW acceleration.

comment:8 Changed 5 months ago by JonathanWa

I am having this problem too. I ran the VM on my computer for the first time yesterday without any problems then when it tried to start it today it threw the error after the VM-bios screen but before the guest OS showed anything. In addition to the error above, I sometimes get this error in the log instead:

00:00:05.571248 emR3Debug: rc=VERR_REM_VIRTUAL_CPU_ERROR

00:00:06.577492 Changing the VM state from 'RUNNING' to 'GURU_MEDITATION'.

Some Information:

HOST: Windows 8 64bit, 6GB of ram

VM: Linux Mint 64bit, tried various amounts of ram

VirtualBox-4.3.3-90819-Win.exe did NOT fix the problem. Downgrading to v4.2.18 DID fix the problem. So I'll stick with this for a while.

Last edited 5 months ago by JonathanWa (previous) (diff)

comment:9 Changed 5 months ago by frank

  • Summary changed from Guru Meditation (VINF_EM_TRIPLE_FAULT) when trying to boot from the network to Guru Meditation (VINF_EM_TRIPLE_FAULT) when trying to boot from the network => Fixed in SVN

We think that we finally fixed the problem after we were able to reproduce the problem. Here is another test build for Windows. Here is another test build for Mac OS X. The fix is also available in the public repository (r49671).

comment:10 Changed 5 months ago by frank

  • Status changed from new to closed
  • Resolution set to fixed

Fix in 4.3.4.

comment:11 Changed 5 months ago by JonathanWa

This did not fix the problem. I tried VirtualBox-4.3.3-90930-Win.exe and also the latest version (4.3.4) on the site. They both do the same thing as before. This is in the log:

00:00:05.057392 emR3Debug: rc=VINF_EM_TRIPLE_FAULT
00:00:06.064167 Changing the VM state from 'RUNNING' to 'GURU_MEDITATION'.

I then downgraded to 4.2.18-88781 which works fine.

Changed 5 months ago by Ch4m3l30n

comment:12 Changed 5 months ago by Ch4m3l30n

I wasn't even having this problem until I upgraded from 4.2.4 to 4.3.4 on my Linux host, then I encountered the same VINF_EM_TRIPLE_FAULT errors on my Win7 SP1 x64 guest. I'm not even booting from the network!

Similar to JonathanWa, downgrading to 4.2.20 resolved that issue for me.

My log from 4.3.4 is attached as VBox.Ch4m3l30n.log.zip.

comment:13 Changed 5 months ago by frank

  • Status changed from closed to reopened
  • Resolution fixed deleted

comment:14 follow-up: ↓ 21 Changed 4 months ago by frank

What do you need to do to trigger this Guru Meditation? Just boot your 64-bit Win7 guest or execute a certain application?

comment:15 Changed 4 months ago by JonathanWa

On my computer (Acer Aspire V) running Windows 8, install VirtualBox then install a Linux Mint guest. The guest installs and runs fine. Shutdown the guest. Start the guest again- the problem will occur right after the VB bios screen and before the OS shows anything.

I've sometimes seen the OS show its loading icon and then just freeze and, from what I remember, it showed VERR_REM_VIRTUAL_CPU_ERROR in the log in this case.

comment:16 Changed 4 months ago by frank

JonathanWa, is this a 32-bit guest or a 64-bit guest?

Changed 4 months ago by brewmanz

Win7(64) crash at F8-Bootmenu under Ubuntu 12.04(64)

Changed 4 months ago by brewmanz

Win7(64) crash under Ubuntu(64) 12.04 at F8 BootMenu

comment:17 Changed 4 months ago by brewmanz

Has just happened to me with Win7(64) guest under Ubuntu 12.04(64) with VBox 4.3.4 r91027. BTW Win8(64) works okay. I did notice that before Win7 shut down, it applied about 10 WinUpdates. Then Win7 crashed on restart, even if just scrolling the F8-BootMenu. I upgraded from VBox 4.1 a few days ago which was a headache but I thought all was now well. Log & image loaded as 'VBox crash on safe 20131211' *edit1* Booting from VDI not network; also VM has 2 VDI drives. *edit2* still crash with just 1 VDI *edit3* rolled back to VB4.2.20 and all seems well. BTW the moment Win7 fired up, it started to install the WinUpdates queued up from before the crash.

Last edited 4 months ago by brewmanz (previous) (diff)

Changed 4 months ago by brewmanz

FYI screenshot of crash during Win7(64) crash recovery!

comment:18 Changed 4 months ago by frank

  • Status changed from reopened to closed
  • Resolution set to duplicate

I will close this one as duplicate of #12451 because mpack did a nice summary there. All these problems seem to happen only on newer AMD CPUs and so far we are not able to reproduce it, unfortunately. Please continue the discussion in #12451.

comment:19 Changed 4 months ago by JonathanWa

frank, To answer your question, it is a 64-bit guest.

comment:20 Changed 4 months ago by frank

Thanks JonathanWa. See #12451, in the meantime we provided test builds.

comment:21 in reply to: ↑ 14 Changed 4 months ago by Ch4m3l30n

Replying to frank:

What do you need to do to trigger this Guru Meditation? Just boot your 64-bit Win7 guest or execute a certain application?

Sorry I didn't respond earlier; I didn't receive an email notification.

Yes, merely attempting to boot the 64-bit Win7 guest is what triggers the Guru Meditation.

However, I just installed 4.3.6 and it works fine. Cheers!

comment:22 Changed 4 months ago by frank

Great, thanks for the feedback!

comment:23 Changed 4 months ago by JonathanWa

4.3.6 fixed it for me as well. Thank you!

Changed 3 months ago by DerEinzigeKlaus

comment:24 Changed 3 months ago by DerEinzigeKlaus

No - sorry for this problem is not jet solved. Tonight I tried to move a VM via OVF form VMWare to VBOX. The OVF was running correct as I could see. Then I imported to VBOX 4.3.6 and started after import finished. The result is exact that Guru Mediation. Take a look to my attachment. What to do?

O - I of course tried out all suggestions I could find. Nothing worked...

I am running VBOX on Win 7 64 prof. Using an AMD Athlon 64 X2 CPU and an AMD Radeon HD 5570. Win 7 is up to date. And I do run without any problem a new installation of OpenSUSE 13.1 64 bit, a Debian 7.3 64 bit and a Debian Raspberry Pi with this same VBOX 4.3.6.

Please tell me what to do...

comment:25 Changed 3 months ago by frank

Could you check if you still observe the problem with this test build? It looks like some MSR emulation was still not correct for your case but this was again improved after 4.3.6.

Note: See TracTickets for help on using tickets.

www.oracle.com
ContactPrivacy policyTerms of Use