VirtualBox

Ticket #13048 (closed defect: invalid)

Opened 6 years ago

Last modified 5 years ago

Network Boot pxelinux 6.02 crash

Reported by: vboxuser49 Owned by:
Component: network Version: VirtualBox 4.3.12
Keywords: pxe pxelinux Cc:
Guest type: all Host type: Windows

Description

Pxe booting the latest version of pxelinux (6.02 at this time) crashes virtualbox. Prior versions of pxelinux(4 and 5) are unaffected. I have confirmed pxelinux 6.02 is working on physical machines and vmware with the same setup.

Log:

00:00:17.026679 iPXE (PCI 00:0D.0) starting execution...ok                                      
00:00:17.026685 iPXE initialising devices...ok                                                  
00:00:17.026692                                                                                 
00:00:17.026698                                                                                 
00:00:17.026704                                                                                 
00:00:17.026711 iPXE 1.0.0+ -- Open Source Network Boot Firmware -- http://ipxe.org             
00:00:17.026717 Features: DNS TFTP PXE PXEXT Menu                                               
00:00:17.026726                                                                                 
00:00:17.026732 net0: 08:00:27:4b:81:22 using 82540em on PCI00:03.0 (open)                      
00:00:17.026737   [Link:up, TX:0 TXE:0 RX:0 RXE:0]                                              
00:00:17.026743 DHCP (net0 08:00:27:4b:81:22).............. ok                                  
00:00:17.026749 net0: 192.168.56.2/255.255.255.0 gw 192.168.56.1                                
00:00:17.026754 Next server: 192.168.56.1                                                       
00:00:17.026760 Filename: pxelinux.0                                                            
00:00:17.026766 tftp://192.168.56.1/pxelinux.0... ok                                            
00:00:17.026771                                                                                 
00:00:17.026777 PXELINUX 6.02 PXE 2013-10-13 Copyright (C) 1994-2013 H. Peter Anvin et al       
00:00:17.026783                                                                                 
00:00:17.026788                                                                                 
00:00:17.026794                                                                                 
00:00:17.026800                                                                                 
00:00:17.026805                                                                                 
00:00:17.026811                                                                                 
00:00:17.026817                                                                                 
00:00:17.026823                                                                                 
00:00:17.026828 --------------------------------------------------------------------------------
00:00:17.026834 !!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!
00:00:17.026845 emR3Debug: rc=VINF_EM_TRIPLE_FAULT
00:00:18.026847 Changing the VM state from 'RUNNING' to 'GURU_MEDITATION'.

Change History

comment:1 Changed 6 years ago by frank

Reproduced.

comment:2 follow-up: ↓ 3 Changed 5 years ago by doug_f

Reproduced. EFI support was added in PXELINUX 6.0. This may be a part of the issue.

I have seen the same behavior in PXELINUX 5.10.

00:02:06.976627 iPXE (PCI 00:0D.0) starting execution...ok                                      
00:02:06.976701 iPXE initialising devices...ok                                                  
00:02:06.976776                                                                                 
00:02:06.976850                                                                                 
00:02:06.976924                                                                                 
00:02:06.976998 iPXE 1.0.0+ -- Open Source Network Boot Firmware -- http://ipxe.org             
00:02:06.977073 Features: DNS TFTP PXE PXEXT Menu                                               
00:02:06.977147                                                                                 
00:02:06.977221 net0: 08:00:27:06:80:40 using pcnet32 on PCI00:03.0 (open)                      
00:02:06.977296   [Link:up, TX:0 TXE:0 RX:0 RXE:0]                                              
00:02:06.977370 DHCP (net0 08:00:27:06:80:40)...... ok                                          
00:02:06.977444 net0: 10.10.0.98/255.255.255.0                                                  
00:02:06.977518 Next server: 10.10.0.20                                                         
00:02:06.977593 Filename: lpxelinux.0                                                           
00:02:06.977668 tftp://10.10.0.20/lpxelinux.0... ok                                             
00:02:06.977742                                                                                 
00:02:06.977816 PXELINUX 5.10 2013-06-04  Copyright (C) 1994-2013 H. Peter Anvin et al          
00:02:06.977901                                                                                 
00:02:06.977988                                                                                 
00:02:06.978062                                                                                 
00:02:06.978137                                                                                 
00:02:06.978211                                                                                 
00:02:06.978285                                                                                 
00:02:06.978359                                                                                 
00:02:06.978434                                                                                 
00:02:06.978508 --------------------------------------------------------------------------------
00:02:06.978575 !!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!
00:02:06.978590 emR3Debug: rc=VINF_EM_TRIPLE_FAULT
Last edited 5 years ago by doug_f (previous) (diff)

comment:3 in reply to: ↑ 2 Changed 5 years ago by doug_f

Replying to doug_f:

Reproduced. EFI support was added in PXELINUX 6.0. This may be a part of the issue. I have seen the same behavior in PXELINUX 5.10.

PXELINUX 5.00 seems to work with pxelinux.0 not the lpxelinux.0

Downgrading both virtualbox and addons to version 3.4.8 fixes this issue. Also using an alternate nic adapter.

Last edited 5 years ago by doug_f (previous) (diff)

comment:4 Changed 5 years ago by frank

Actually this looks like a bug in PXELinux. I've submitted bug  54 to the syslinux bug tracker.

comment:5 Changed 5 years ago by frank

Fixed upstream in pxelinux-6.03-pre19!

comment:6 Changed 5 years ago by frank

  • Status changed from new to closed
  • Resolution set to invalid

I will close this ticket because it was really a PXELinux bug. That it worked on physical machines and VMware was pure luck.

Note: See TracTickets for help on using tickets.

www.oracle.com
ContactPrivacy policyTerms of Use