VirtualBox

Ticket #12087 (reopened defect)

Opened 6 years ago

Last modified 3 years ago

VirtualBox.exe fails to run

Reported by: yefkov Owned by:
Component: other Version: VirtualBox 4.2.18
Keywords: Cc:
Guest type: all Host type: Windows

Description

VirtualBox.exe failed with the message:
Callee RC: E_NOINTERFACE (0x80004002)

VBoxSVC.log reports:
Watcher ERROR [COM]: aRC=E_ACCESSDENIED (0x80070005) aIID={3b2f08eb-b810-4715-bee0-bb06b9880ad2} aComponent={VirtualBox} aText={The object is not ready}, preserve=false

Running as administrator -> no error

Previous version (4.2.16) does not have this issue.

Attachments

VBox.log Download (157.9 KB) - added by kpiq 6 years ago.
VBoxSVC.log Download (685 bytes) - added by kpiq 6 years ago.
MarkG1234_SystemReport.zip Download (77.1 KB) - added by MarkG1234 6 years ago.
MarkG1234 System Config Report.
Virtual Box Error.JPG Download (34.9 KB) - added by clems 5 years ago.
Hello everyone, kindly find attached the error i get whiles launching my virtual box and assist. thanks in advance

Change History

comment:1 Changed 6 years ago by frank

  • Status changed from new to closed
  • Resolution set to fixed

Duplicate of #12079.

comment:2 Changed 6 years ago by yefkov

  • Status changed from closed to reopened
  • Resolution fixed deleted

It is not an installer issue.

comment:3 Changed 6 years ago by frank

  • Status changed from reopened to closed
  • Resolution set to duplicate

I did not say so. The binary on some mirrors seems to be incorrect. It needs time to resynchronize after I removed + re-uploaded the binary.

comment:4 Changed 6 years ago by yefkov

  • Status changed from closed to reopened
  • Resolution duplicate deleted

The md5 and sha256 sums of the installer I've downloaded match the sums published on the web site. Are you still insisting that the problem in the binary?

comment:5 follow-up: ↓ 8 Changed 6 years ago by frank

What is the size of your Windows package?

comment:6 follow-up: ↓ 9 Changed 6 years ago by frank

Could you also uninstall VBox and then re-install VBox 4.2.18? Does it make any difference?

comment:7 Changed 6 years ago by frank

To be more clear, now I also assume that your problem is not caused by a partial download of the Windows package but still, what happens if you completely uninstall VBox and then re-install VBox 4.2.18?

comment:8 in reply to: ↑ 5 Changed 6 years ago by yefkov

Replying to frank:

What is the size of your Windows package?

99.619.088 Bytes

comment:9 in reply to: ↑ 6 Changed 6 years ago by yefkov

Replying to frank:

Could you also uninstall VBox and then re-install VBox 4.2.18? Does it make any difference?

I tried several times. No difference.

comment:10 Changed 6 years ago by yefkov

Additional info:
My colleague has Windows 7 64bit as host OS. He can not reproduce the issue. My configuration is Windows 7 32bit.

Last edited 6 years ago by yefkov (previous) (diff)

comment:11 follow-up: ↓ 12 Changed 6 years ago by frank

Could you try if  this build fixes the problem for you?

comment:12 in reply to: ↑ 11 Changed 6 years ago by yefkov

Replying to frank:

Could you try if  this build fixes the problem for you?

This build solves the problem.

comment:13 follow-up: ↓ 18 Changed 6 years ago by frank

Which Windows 7 version is that exactly, I assume Windows 7 Professional 32-bit?

comment:14 follow-up: ↓ 20 Changed 6 years ago by frank

Guys, we need some help here in finding the problem. We are not able to reproduce the problem. We installed Windows 7 / professional 32-bit locally and installed VBox 4.2.18 there. No problem starting the GUI and starting a VM at all. So what's different to your configuration?

comment:15 Changed 6 years ago by kpiq

Similar issue. Vboxsvc.exe service fails to start and "headless" VMs refuse to start. VMs do start while Virtualbox console is open but they crash when Virtualbox console is closed (the whole story is, if you close the console while a VM is running, vboxsvc service stops and the VM crashes).

Result Code: E_ACCESSDENIED (0x80070005) Component: Machine Interface: IMachine {22781af3-1c96-4126-9edf-67a020e0e858}

Changed 6 years ago by kpiq

Changed 6 years ago by kpiq

comment:16 Changed 6 years ago by kpiq

uninstalled and reinstalled. Vboxsvc didnt get added as a service.

comment:17 follow-up: ↓ 19 Changed 6 years ago by hoelle

Same problem here with 4.2.18 or 4.3.0 (upgrade from 4.2.16) 4.2.16 runs fine. Environment: Windows 7 64bit

00:02:30.249593 Watcher  ERROR [COM]: aRC=E_ACCESSDENIED (0x80070005) aIID={fafa4e17-1ee2-4905-a10e-fe7c18bf5554} aComponent={VirtualBox} aText={The object is not ready}, preserve=false

comment:18 in reply to: ↑ 13 Changed 6 years ago by yefkov

Replying to frank:

Which Windows 7 version is that exactly, I assume Windows 7 Professional 32-bit?

Exactly.
P.S. I miss something or there is no email notification for ticket updates?

comment:19 in reply to: ↑ 17 Changed 6 years ago by yefkov

Replying to hoelle:

Same problem here with 4.2.18 or 4.3.0 (upgrade from 4.2.16) 4.2.16 runs fine. Environment: Windows 7 64bit

00:02:30.249593 Watcher  ERROR [COM]: aRC=E_ACCESSDENIED (0x80070005) aIID={fafa4e17-1ee2-4905-a10e-fe7c18bf5554} aComponent={VirtualBox} aText={The object is not ready}, preserve=false

I have just downloaded and installed version 4.3.0. I get exactly the same message in VBoxSVC.log. My host OS is Windows 7 Professional 32bit.

comment:20 in reply to: ↑ 14 Changed 6 years ago by yefkov

Replying to frank:

Guys, we need some help here in finding the problem. We are not able to reproduce the problem. We installed Windows 7 / professional 32-bit locally and installed VBox 4.2.18 there. No problem starting the GUI and starting a VM at all. So what's different to your configuration?

I don't know what is the difference. May be third party software, antivirus software or that the pc is a member of company domain... I thought you have solved the problem, because suggested test case  http://www.virtualbox.org/download/testcase/VirtualBox-4.2.19-88838-Win.exe runs without any errors. What is happening?

Last edited 6 years ago by yefkov (previous) (diff)

comment:21 Changed 6 years ago by yefkov

The same issue with older version (4.1.6): Ticket #9880

Last edited 6 years ago by yefkov (previous) (diff)

comment:22 Changed 6 years ago by ScottG

I am having the same problem, I also have Win 7 Pro 32bit. I have tried to install both 4.2.18 and 4.3.0 and I get the same errors. Virtual box will not start.

I keep all my downloads and have an older version 4.2.4. I installed this one and it starts with no error.

Last edited 6 years ago by ScottG (previous) (diff)

comment:23 Changed 6 years ago by MarkG1234

Same problem here. HP Elitebook Windows 7 32bit in corporate environment, Kaspersky Endpoint Security 10.

What other details do you want to know?

Changed 6 years ago by MarkG1234

MarkG1234 System Config Report.

comment:24 follow-ups: ↓ 26 ↓ 40 ↓ 41 ↓ 42 Changed 6 years ago by yefkov

So, I've got it running.
I have removed the following registry keys:
HKEY_CURRENT_USER\Software\Classes\CLSID\{00020420-0000-0000-C000-000000000046}
HKEY_CURRENT_USER\Software\Classes\CLSID\{00020424-0000-0000-C000-000000000046}
I don't know what consequences for system this action may carry with. So export before deleting.
Also I've found out that the error

ERROR [COM]: aRC=E_ACCESSDENIED (0x80070005) aIID={fafa4e17-1ee2-4905-a10e-fe7c18bf5554} aComponent={VirtualBox} aText={The object is not ready}, preserve=false

is still there. Though it occurs AFTER I close VirtualBox GUI. Therefore I suspect that this error is not the root cause.

comment:25 Changed 6 years ago by MarkG1234

Thanks yeflov, this fixed things for me.

I deleted those reg keys, uninstalled VirtualBox, did a registry clean with CCleaner, rebooted, reinstalled Virtualbox 4.3 No errors at all, not even on closing.

This is the first post 4.2.17 build that's ever worked for me, besides the 4.2.19 test build that's now removed..

Guessing this gives the devs a way forward for fixing this properly.

comment:26 in reply to: ↑ 24 ; follow-up: ↓ 27 Changed 6 years ago by hoelle

Replying to yefkov:

I have removed the following registry keys:
HKEY_CURRENT_USER\Software\Classes\CLSID\{00020420-0000-0000-C000-000000000046}
HKEY_CURRENT_USER\Software\Classes\CLSID\{00020424-0000-0000-C000-000000000046}

Does not work for me as those keys do not exist in my registry under HKCU. Deleting them from HKLM didn't work.

comment:27 in reply to: ↑ 26 ; follow-up: ↓ 28 Changed 6 years ago by ScottG

Replying to hoelle:

Replying to yefkov:

I have removed the following registry keys:
HKEY_CURRENT_USER\Software\Classes\CLSID\{00020420-0000-0000-C000-000000000046}
HKEY_CURRENT_USER\Software\Classes\CLSID\{00020424-0000-0000-C000-000000000046}

Does not work for me as those keys do not exist in my registry under HKCU. Deleting them from HKLM didn't work.

I also did not find them in HKCU. What are the contents of the keys?

comment:28 in reply to: ↑ 27 ; follow-up: ↓ 29 Changed 6 years ago by yefkov

Replying to ScottG:

Replying to hoelle:

Replying to yefkov:

I have removed the following registry keys:
HKEY_CURRENT_USER\Software\Classes\CLSID\{00020420-0000-0000-C000-000000000046}
HKEY_CURRENT_USER\Software\Classes\CLSID\{00020424-0000-0000-C000-000000000046}

Does not work for me as those keys do not exist in my registry under HKCU. Deleting them from HKLM didn't work.

I also did not find them in HKCU. What are the contents of the keys?

This is a COM class registration. This might be interesting:
 http://msdn.microsoft.com/en-us/library/windows/desktop/ms724475(v=vs.85).aspx
For you guys (hoelle, ScottG) it can be other keys. As a test I would try to completely empty HKEY_CURRENT_USER\Software\Classes\CLSID key.

Last edited 6 years ago by yefkov (previous) (diff)

comment:29 in reply to: ↑ 28 Changed 6 years ago by ScottG

Replying to yefkov:

This is a COM class registration. This might be interesting:
 http://msdn.microsoft.com/en-us/library/windows/desktop/ms724475(v=vs.85).aspx
For you guys (MarkG1234, ScottG) it can be other keys. As a test I would try to completely empty HKEY_CURRENT_USER\Software\Classes\CLSID key.

Thanks @yefkov. I suspected that the key could be different on my system. I uninstalled VirtualBox, exported the entire CLSID tree, and deleted it. I also ran CCleaner and fixed any registry errors. Rebooted and installed VBox 4.3. Still received the error. I then uninstalled VBox 4.3 and installed my older version 4.2.4. Unfortunately, it now also receives the error.

I tried to import the CLSID tree I exported, but there was no change, older version still does not work. There may have been some other keys in the registry that allowed it to work. Unfortunately I did not make a back up of the reg errors found by CCleaner before fixing them. So it looks like VBox is out of commission for me.

comment:30 Changed 6 years ago by t77b

Hi Guys,

same Problem here. I think it has to do with the user rights! I have several user accounts on one machine and some work with no error.... I tried to find out if there is a difference between the accounts, but i can´t find any differences except the user names. I also find out that my installation works when i set it to Compatibility mode "Start as Administrotor", but a prompt will show. When i start it in Compatibility mode "Windows Vista (SP2)" it runs with no prompt and no errors. That works on all my user accounts on that machine. Can anybody confirm that ?

comment:31 follow-ups: ↓ 32 ↓ 36 Changed 6 years ago by hoelle

I found a solution that worked for me after comparing two ProcMon Traces of a working and a broken installation:
HKEY_CLASSES_ROOT\CLSID\{00020420-0000-0000-C000-000000000046}\InprocServer32 and
HKEY_CLASSES_ROOT\CLSID\{00020424-0000-0000-C000-000000000046}\InprocServer32

The (Default) entry said "oleauth32.dll". After changing that to "C:\Windows\system32\oleaut32.dll" in both locations it worked again!

EDIT: registry path was wrong (was HKEY_CURRENT_ROOT\Classes\CLSID)

Last edited 6 years ago by hoelle (previous) (diff)

comment:32 in reply to: ↑ 31 ; follow-up: ↓ 34 Changed 6 years ago by ScottG

Replying to hoelle:

I found a solution that worked for me after comparing two ProcMon Traces of a working and a broken installation:
HKEY_CURRENT_ROOT\Classes\CLSID\{00020420-0000-0000-C000-000000000046}\InprocServer32 and
HKEY_CURRENT_ROOT\Classes\CLSID\{00020424-0000-0000-C000-000000000046}\InprocServer32

The (Default) entry said "oleauth32.dll". After changing that to "C:\Windows\system32\oleaut32.dll" in both locations it worked again!

HKEY_CURRENT_ROOT? Did you mean HKEY_CLASSES_ROOT? I don't have an HKEY_CURRENT_ROOT. I did a search in my reg for oleaut32.dll. In all cases the full path was used. So unfortunately I still am unable to get VBox to run.

comment:33 Changed 6 years ago by ScottG

OK I tried an experiment. Since I do not have those CLSID keys in my HKCU tree I tried creating them based off HKLM. I got further now. Now the GUI manager opens. I am getting some errors, but it starts up. It looks a little like those keys are not being created on my system for some reason. I still have to test more. I will update once I have more information.

comment:34 in reply to: ↑ 32 Changed 6 years ago by hoelle

Replying to ScottG:

Replying to hoelle:

I found a solution that worked for me after comparing two ProcMon Traces of a working and a broken installation:
HKEY_CURRENT_ROOT\Classes\CLSID\{00020420-0000-0000-C000-000000000046}\InprocServer32 and
HKEY_CURRENT_ROOT\Classes\CLSID\{00020424-0000-0000-C000-000000000046}\InprocServer32

The (Default) entry said "oleauth32.dll". After changing that to "C:\Windows\system32\oleaut32.dll" in both locations it worked again!

HKEY_CURRENT_ROOT? Did you mean HKEY_CLASSES_ROOT? I don't have an HKEY_CURRENT_ROOT. I did a search in my reg for oleaut32.dll. In all cases the full path was used. So unfortunately I still am unable to get VBox to run.

Thank you for pointing out. Fixed original post.

comment:35 Changed 6 years ago by ScottG

Thanks @hoelle. I have tested a bit more. I cannot get VBox 4.3 to work even with those keys added to HKCU. I can get an older version to start up the GUI, however I get abort errors on VBoxTestOGL.exe. Windows reports that the .exe has stopped working. I receive about 3 error on start up. I also cannot start up a VM that has 3D acceleration enabled. The error indicates errors with the host graphics drivers, which makes some sense as the earlier error was a display error. I am going to try reinstalling/updating my display drivers and see if this fixes anything.

UPDATE: Updating my video driver has fixed the abort errors. I can now start VBox 4.2.4 GUI with no problem and I can also start VMs with 3D acceleration enabled. I tried to uninstall 4.2.4 and install 4.3.0, however I still receive the original error. At least 4.2.4 is back and working again. For the devs, my graphics card is a Radeon HD 3450, driver is ATI Tech version 8.640.0.0 if that helps out any. Let me know if any additional info can be provided that may help.

Last edited 6 years ago by ScottG (previous) (diff)

comment:36 in reply to: ↑ 31 Changed 6 years ago by ericcire

I was stuck with this problem for over a month, since 4.2.18. After changing these 2 keys by adding full path to oleaut32.dll. Virtualbox 4.3.2 started normally.

Before this, I was unable to run VirtualBox whether as administrator or not.

Thanks @hoelle.

Replying to hoelle:

I found a solution that worked for me after comparing two ProcMon Traces of a working and a broken installation:
HKEY_CLASSES_ROOT\CLSID\{00020420-0000-0000-C000-000000000046}\InprocServer32 and
HKEY_CLASSES_ROOT\CLSID\{00020424-0000-0000-C000-000000000046}\InprocServer32

The (Default) entry said "oleauth32.dll". After changing that to "C:\Windows\system32\oleaut32.dll" in both locations it worked again!

EDIT: registry path was wrong (was HKEY_CURRENT_ROOT\Classes\CLSID)

Last edited 6 years ago by ericcire (previous) (diff)

comment:37 follow-up: ↓ 39 Changed 6 years ago by xvitus

Got this same problem on Win7/32bit host since VB 4.2.18. The 4.2.19 build worked for me too. The registry correction did not work for me. Now solved using Compatibility mode: any compatibility mode lower than Windows 7 solves the issue (now I'm using Vista SP2 compatibility mode and all seems working correctly).

Hope this helps.

Last edited 6 years ago by xvitus (previous) (diff)

comment:38 Changed 6 years ago by Giangi

I was going to open a ticket for this same problem, well documented here:  https://forums.virtualbox.org/viewtopic.php?f=6&t=57646#p269723 and  https://forums.virtualbox.org/viewtopic.php?f=6&t=58222 Me too I have temporary solved by executing VB in compatibility mode "Vista"! Me too I believe is a permissions related problem! I have this problem starting with 4.2.18

comment:39 in reply to: ↑ 37 Changed 6 years ago by Pete

Replying to xvitus:

Now solved using Compatibility mode: any compatibility mode lower than Windows 7 solves the issue (now I'm using Vista SP2 compatibility mode and all seems working correctly).

This helps hugely - I was having a mild panic that perhaps an AV or firewall setting was causing the issue. This has happened since my last set of Windows Updates. Unfortunately, I can't see what they are because of group policy restrictions!!

comment:40 in reply to: ↑ 24 Changed 6 years ago by remytan

Thanks yefkov!!! After I deleted the to directories,

HKEY_CURRENT_USER\Software\Classes\CLSID\{00020420-0000-0000-C000-000000000046}
HKEY_CURRENT_USER\Software\Classes\CLSID\{00020424-0000-0000-C000-000000000046}

uninstall and reinstall VirtualBox-4.3.2-90405-Win and the application can be executed.

Replying to yefkov:

So, I've got it running.
I have removed the following registry keys:
HKEY_CURRENT_USER\Software\Classes\CLSID\{00020420-0000-0000-C000-000000000046}
HKEY_CURRENT_USER\Software\Classes\CLSID\{00020424-0000-0000-C000-000000000046}
I don't know what consequences for system this action may carry with. So export before deleting.
Also I've found out that the error

ERROR [COM]: aRC=E_ACCESSDENIED (0x80070005) aIID={fafa4e17-1ee2-4905-a10e-fe7c18bf5554} aComponent={VirtualBox} aText={The object is not ready}, preserve=false

is still there. Though it occurs AFTER I close VirtualBox GUI. Therefore I suspect that this error is not the root cause.

comment:41 in reply to: ↑ 24 Changed 6 years ago by Giangi

Replying to yefkov:

So, I've got it running.
I have removed the following registry keys:
HKEY_CURRENT_USER\Software\Classes\CLSID\{00020420-0000-0000-C000-000000000046}
HKEY_CURRENT_USER\Software\Classes\CLSID\{00020424-0000-0000-C000-000000000046}

YES! I have compared my two HP laptop: the one where VB is running fine doesn't have any of these xyz2042* clsid! There are 6 of them:
from [HKEY_CURRENT_USER\Software\Classes\CLSID\{00020420-0000-0000-C000-000000000046}]
to [HKEY_CURRENT_USER\Software\Classes\CLSID\{00020425-0000-0000-C000-000000000046}]

I have googled the first of them and found references only to the classic location HKEY_CLASSES_ROOT\CLSID\ (so not inside the account's registry!) and indeed both the laptops have them in the correct location.

I have exported all the 6 from HKEY_CURRENT_USER\Software\Classes\CLSID\ location (just in case), from the laptop where VB wasn't running and then I have deleted them.

VB is now running fine even without reinstalling it! I have only removed the execute in copatibility mode setting! I'm really happy now!!!

comment:42 in reply to: ↑ 24 Changed 6 years ago by VirtualVM

Replying and thanking to yefkov:

So, I've got it running.
I have removed the following registry keys:
HKEY_CURRENT_USER\Software\Classes\CLSID\{00020420-0000-0000-C000-000000000046}
HKEY_CURRENT_USER\Software\Classes\CLSID\{00020424-0000-0000-C000-000000000046}

It has also solved the problem for me !! Without rebooting of Win 7 Pro SP1 (32 bits) or reinstalling of Virtual Box v.4.3.2

Last edited 6 years ago by VirtualVM (previous) (diff)

comment:43 Changed 6 years ago by frank

Can anybody of you tell me how you found that removing some registry keys fixes the problem for you? Are these keys documented?

comment:44 follow-up: ↓ 45 Changed 6 years ago by jeremy.bass

ok few things to note on this, looked to one system for these sets of keys and first they are on both, second they have data like PSDispatch and PSTypeComp .. this leads me to believe that these keys you are deleting would be for photoshop or powershell but not for this. Take note BOTH SYSTEMS HAVE THESE KEYS in the reg, both working and nonworking system. Can some one confirm that this is an effective course here. I really need to get working now and this is holding me back.

Side note here, this seems to have be after the last update of windows, not last update of the virtualbox. With that I'm thinking that the best course here is not hack up the reg but look to what changes beside just this app? I'm looking at updates like

KB2862152  http://support.microsoft.com/kb/2862152

or something. Anyone run down this route?

comment:45 in reply to: ↑ 44 Changed 6 years ago by yefkov

Replying to jeremy.bass:

second they have data like PSDispatch and PSTypeComp .. this leads me to believe that these keys you are deleting would be for photoshop or powershell but not for this.

PS means Proxy/Stub and has nothing to do with Photoshop or PowerShell. It's a part of COM-mechanism. PSDispatch is a Proxy/Stub class for IDispatch interface. PSTypeComp is for ITypeComp interface.

I'm looking at updates like
KB2862152  http://support.microsoft.com/kb/2862152
or something. Anyone run down this route?

You are definitely on the wrong way.

Last edited 6 years ago by yefkov (previous) (diff)

comment:46 Changed 6 years ago by ldurand

Using VirtualBox 4.3.4 x86 on quad core AMD with Windows7 32 bit. I get the error: Callee RC: E_NOINTERFACE (0x80004002). Any ideas? This is happening since version 4.3.0

comment:47 Changed 6 years ago by ldurand

VirtualBox v4.2.16 work perfectly but any version after that one fails miserably with the E-NOINTERFACE message. Using Win7-32 bits, 4 GB ram, AMD quad core.

comment:48 Changed 6 years ago by frank

Could you also test VBox 4.3.6? Thanks!

comment:49 Changed 6 years ago by Numa

Same error with 4.3.6: Callee RC: E_NOINTERFACE (0x8004002)

Windows 7: 32 bits, 4 GB ram, Intel i7-2640M

comment:50 Changed 6 years ago by Obiwan

Fehler: Cannot create Com Object

Fehler: Callee RC: E_NOINTERFACE (0x8004002)

  1. Ursache: defekte CLSID {Anwenderfehler}
  2. Ursache: Programmiererfehler {schlampigkeit}

Zu 1: Aufbau CLSID:

Key{SID}, SubKey {z.B. InprocServer32},

Value{Standard=REG_SZ: Pfad und Name zu einer .exe oder .dll}

Beispiel: C:\Program Files\Java\jre7\bin\jp2iexp.dll

Wenn hier als Wert kein gültiger Pfad vorhanden ist, führt der Aufruf zum Fehler

{Bei registrierten .exe oder .dll reicht auch der Dateinamne, ein Pfad ist dann nicht nötig}

Besipiel eines fehlerhaften Value:

rEGu-WdtJ=mq=M,JfU4SPackager>M5KDYSUnf(HA*L[xeX)y

Typische Ursache:

beim Installieren von Virtual Box, VM-Ware oder VPN-Software wird eine virtuelle Netzwerkkarte angelegt. Dies schlägt fehl, wenn das Netzwerk abgeschaltet ist

Dafür Ursache: Ein Computer {Notebook} ohne Netzwerkverbindung

  • kein Kabel angeschlossen, mit W-Lan nicht verbunden

Dann schaltet Windows das Netzwerk ab {Stromsparfunktion}

Zu 2. Deinstallieren / Update

Beim Deinstallieren werden die CLSID nicht gelöscht. Sie verbleiben und werden weiter verwendet Eine neue Installation legt eventuell richtige CLSID an, diese sind aber in der Reihenfolge in der Registry später, als die defekten CLSID und werden nicht verwendet.

Lösung:

Alle HKCU CLSID löschen, die keinen gültigen Eintrag haben {Pfad, Dateiname} Ein Risiko oder Folgefehler entsteht dadurch nicht, da diese Einträge ohnehin nicht funktionieren.

comment:51 Changed 6 years ago by frank

Thank you for this information!

Changed 5 years ago by clems

Hello everyone, kindly find attached the error i get whiles launching my virtual box and assist. thanks in advance

comment:52 Changed 5 years ago by Paradox

I have been having this problem with any version I tried to install recently (4.3.24, along with several older versions).

I tried removing the registry entries given above but this didn’t work for me.

I did find a solution that may help someone else in the future though.

In the registry keys:

HKEY_CLASSES_ROOT\CLSID\{00020420-0000-0000-C000-000000000046}\InprocServer32

through to:

HKEY_CLASSES_ROOT\CLSID\{00020425-0000-0000-C000-000000000046}\InprocServer32

I had 3 values:

(Default) = “C:\Windows\system32\oleaut32.dll”
ThreadingModel = “Both”
InprocServer32 = [lots of random characters]

I tried deleting the InprocServer32 value from each sub key and this fixed the problem for me.

comment:53 follow-up: ↓ 56 Changed 3 years ago by bird

We've had a look at a similar problem recently. What it looks like is that some program installed a OLEAUT32.DLL update aimed at Windows NT 4 and Windows 95 on a newer system, slightly messing up the factory OLEAUT32.DLL installation with these HKEY_CLASSES_ROOT\CLSID\{00020420-0000-0000-C000-000000000046}\InprocServer32\InprocServer32=[random looking characters] values.

The next 5.1 build contains code to try help detect this problem and identify which program is causing it, so that you can uninstall it.

We've found two such programs so far, "Dell Resource CD" / "Dell Precision Resource CD" and "GIGABYTE VGA @BIOS". Uninstalling the Dell one certainly worked on the 32-bit Windows we tested it one. The GIGABYTE thing was observed on a 64-bit Windows 10 and wasn't actually causing any visible trouble.

Related information:

comment:54 Changed 3 years ago by bird

  • Status changed from reopened to closed
  • Resolution set to fixed

comment:55 Changed 3 years ago by Vmboxuser

  • Status changed from closed to reopened
  • Resolution fixed deleted

Hello, have tried 5.1.6 - the same problem on start:

Failed to acquire the VirtualBox COM object.

The application will now terminate.
Callee RC: E_NOINTERFACE (0x80004002)

Deleting HKCU\Software\Classes\CLSID\{00020420-0000-0000-C000-000000000046} fixes this startup error and I can start Virtualbox, but when I press Start virtual machine -

Failed to open a session for the virtual machine CentOS.
Result Code: E_FAIL (0x80004005)

So, not fixed :(

comment:56 in reply to: ↑ 53 Changed 3 years ago by Vmboxuser

Replying to bird:

We've had a look at a similar problem recently. What it looks like is that some program installed a OLEAUT32.DLL update aimed at Windows NT 4 and Windows 95 on a newer system, slightly messing up the factory OLEAUT32.DLL installation with these HKEY_CLASSES_ROOT\CLSID\{00020420-0000-0000-C000-000000000046}\InprocServer32\InprocServer32=[random looking characters] values.

The next 5.1 build contains code to try help detect this problem and identify which program is causing it, so that you can uninstall it.

We've found two such programs so far, "Dell Resource CD" / "Dell Precision Resource CD" and "GIGABYTE VGA @BIOS". Uninstalling the Dell one certainly worked on the 32-bit Windows we tested it one. The GIGABYTE thing was observed on a 64-bit Windows 10 and wasn't actually causing any visible trouble.

Related information:

I my case I don't have any of these apps installed...

comment:57 follow-up: ↓ 58 Changed 3 years ago by Vmboxuser

Found a solution that worked for me (tested on W7SP1, x86, VB 5.1.6):

Fix for:

Callee RC: E_NOINTERFACE (0x80004002)

Import reg to the registry

Windows Registry Editor Version 5.00

[HKEY_CURRENT_USER\Software\Classes\CLSID\{00020420-0000-0000-C000-000000000046}]
@="PSDispatch"

[HKEY_CURRENT_USER\Software\Classes\CLSID\{00020420-0000-0000-C000-000000000046}\InprocServer]
@="C:\\Windows\\system32\\ole2disp.dll"

[HKEY_CURRENT_USER\Software\Classes\CLSID\{00020420-0000-0000-C000-000000000046}\InprocServer32]
@="C:\\Windows\\system32\\oleaut32.dll"
"ThreadingModel"="Both"

[HKEY_CURRENT_USER\Software\Classes\CLSID\{00020421-0000-0000-C000-000000000046}]
@="PSEnumVariant"

[HKEY_CURRENT_USER\Software\Classes\CLSID\{00020421-0000-0000-C000-000000000046}\InprocServer]
@="C:\\Windows\\system32\\ole2disp.dll"

[HKEY_CURRENT_USER\Software\Classes\CLSID\{00020421-0000-0000-C000-000000000046}\InprocServer32]
@="C:\\Windows\\system32\\oleaut32.dll"
"ThreadingModel"="Both"

[HKEY_CURRENT_USER\Software\Classes\CLSID\{00020422-0000-0000-C000-000000000046}]
@="PSTypeInfo"

[HKEY_CURRENT_USER\Software\Classes\CLSID\{00020422-0000-0000-C000-000000000046}\InprocServer]
@="C:\\Windows\\system32\\ole2disp.dll"

[HKEY_CURRENT_USER\Software\Classes\CLSID\{00020422-0000-0000-C000-000000000046}\InprocServer32]
@="C:\\Windows\\system32\\oleaut32.dll"
"ThreadingModel"="Both"

[HKEY_CURRENT_USER\Software\Classes\CLSID\{00020423-0000-0000-C000-000000000046}]
@="PSTypeLib"

[HKEY_CURRENT_USER\Software\Classes\CLSID\{00020423-0000-0000-C000-000000000046}\InprocServer]
@="C:\\Windows\\system32\\ole2disp.dll"

[HKEY_CURRENT_USER\Software\Classes\CLSID\{00020423-0000-0000-C000-000000000046}\InprocServer32]
@="C:\\Windows\\system32\\oleaut32.dll"
"ThreadingModel"="Both"

[HKEY_CURRENT_USER\Software\Classes\CLSID\{00020424-0000-0000-C000-000000000046}]
@="PSOAInterface"

[HKEY_CURRENT_USER\Software\Classes\CLSID\{00020424-0000-0000-C000-000000000046}\InprocServer]
@="C:\\Windows\\system32\\ole2disp.dll"

[HKEY_CURRENT_USER\Software\Classes\CLSID\{00020424-0000-0000-C000-000000000046}\InprocServer32]
@="C:\\Windows\\system32\\oleaut32.dll"
"ThreadingModel"="Both"

[HKEY_CURRENT_USER\Software\Classes\CLSID\{00020425-0000-0000-C000-000000000046}]
@="PSTypeComp"

[HKEY_CURRENT_USER\Software\Classes\CLSID\{00020425-0000-0000-C000-000000000046}\InprocServer]
@="C:\\Windows\\system32\\ole2disp.dll"

[HKEY_CURRENT_USER\Software\Classes\CLSID\{00020425-0000-0000-C000-000000000046}\InprocServer32]
@="C:\\Windows\\system32\\oleaut32.dll"
"ThreadingModel"="Both"

Fix for:

Result Code: E_FAIL (0x80004005)

Uninstall Avira Professional Security, reboot, install it again -> and everything works: Virtualbox starts and VM loads without any errors.

Last edited 3 years ago by Vmboxuser (previous) (diff)

comment:58 in reply to: ↑ 57 Changed 3 years ago by Kitch

Can confirm, this resolves E_NOINTERFACE (0x80004002). W7SP, x64, 5.1.7 r110927.

Replying to Vmboxuser:

Found a solution that worked for me (tested on W7SP1, x86, VB 5.1.6):

Fix for:

Callee RC: E_NOINTERFACE (0x80004002)

Import reg to the registry

Windows Registry Editor Version 5.00

[HKEY_CURRENT_USER\Software\Classes\CLSID\{00020420-0000-0000-C000-000000000046}]
@="PSDispatch"

[HKEY_CURRENT_USER\Software\Classes\CLSID\{00020420-0000-0000-C000-000000000046}\InprocServer]
@="C:\\Windows\\system32\\ole2disp.dll"

[HKEY_CURRENT_USER\Software\Classes\CLSID\{00020420-0000-0000-C000-000000000046}\InprocServer32]
@="C:\\Windows\\system32\\oleaut32.dll"
"ThreadingModel"="Both"

[HKEY_CURRENT_USER\Software\Classes\CLSID\{00020421-0000-0000-C000-000000000046}]
@="PSEnumVariant"

[HKEY_CURRENT_USER\Software\Classes\CLSID\{00020421-0000-0000-C000-000000000046}\InprocServer]
@="C:\\Windows\\system32\\ole2disp.dll"

[HKEY_CURRENT_USER\Software\Classes\CLSID\{00020421-0000-0000-C000-000000000046}\InprocServer32]
@="C:\\Windows\\system32\\oleaut32.dll"
"ThreadingModel"="Both"

[HKEY_CURRENT_USER\Software\Classes\CLSID\{00020422-0000-0000-C000-000000000046}]
@="PSTypeInfo"

[HKEY_CURRENT_USER\Software\Classes\CLSID\{00020422-0000-0000-C000-000000000046}\InprocServer]
@="C:\\Windows\\system32\\ole2disp.dll"

[HKEY_CURRENT_USER\Software\Classes\CLSID\{00020422-0000-0000-C000-000000000046}\InprocServer32]
@="C:\\Windows\\system32\\oleaut32.dll"
"ThreadingModel"="Both"

[HKEY_CURRENT_USER\Software\Classes\CLSID\{00020423-0000-0000-C000-000000000046}]
@="PSTypeLib"

[HKEY_CURRENT_USER\Software\Classes\CLSID\{00020423-0000-0000-C000-000000000046}\InprocServer]
@="C:\\Windows\\system32\\ole2disp.dll"

[HKEY_CURRENT_USER\Software\Classes\CLSID\{00020423-0000-0000-C000-000000000046}\InprocServer32]
@="C:\\Windows\\system32\\oleaut32.dll"
"ThreadingModel"="Both"

[HKEY_CURRENT_USER\Software\Classes\CLSID\{00020424-0000-0000-C000-000000000046}]
@="PSOAInterface"

[HKEY_CURRENT_USER\Software\Classes\CLSID\{00020424-0000-0000-C000-000000000046}\InprocServer]
@="C:\\Windows\\system32\\ole2disp.dll"

[HKEY_CURRENT_USER\Software\Classes\CLSID\{00020424-0000-0000-C000-000000000046}\InprocServer32]
@="C:\\Windows\\system32\\oleaut32.dll"
"ThreadingModel"="Both"

[HKEY_CURRENT_USER\Software\Classes\CLSID\{00020425-0000-0000-C000-000000000046}]
@="PSTypeComp"

[HKEY_CURRENT_USER\Software\Classes\CLSID\{00020425-0000-0000-C000-000000000046}\InprocServer]
@="C:\\Windows\\system32\\ole2disp.dll"

[HKEY_CURRENT_USER\Software\Classes\CLSID\{00020425-0000-0000-C000-000000000046}\InprocServer32]
@="C:\\Windows\\system32\\oleaut32.dll"
"ThreadingModel"="Both"

Fix for:

Result Code: E_FAIL (0x80004005)

Uninstall Avira Professional Security, reboot, install it again -> and everything works: Virtualbox starts and VM loads without any errors.

Note: See TracTickets for help on using tickets.

www.oracle.com
ContactPrivacy policyTerms of Use