VirtualBox

Ticket #12066 (closed defect: fixed)

Opened 4 years ago

Last modified 3 years ago

rdesktop-vrdp fails to load german keyboard

Reported by: deller Owned by:
Priority: major Component: RDP
Version: VirtualBox 4.2.16 Keywords: rdesktop-vrdp
Cc: Guest type: Windows
Host type: Linux

Description

This bug is reproduceable on the pre-packaged official RPM package of Virtualbox-4.2.16. Maybe it affects other pre-packaged versions for other distros too?

The problem is, that if you run rdesktop-vrp somehost:<someport> -k de to tell rdesktop that it should use the german keymap, rdesktop-vrdp will try to look up the file in various places, including /opt/VirtualBox/rdesktop-vrdp-keymaps, but NOT in /usr/share/virtualbox/rdesktop-vrdp-keymaps/ where the keymaps are being installed by the RPM package. Thus loading the keymap fails.

To temporarily fix it, I added a symlink /opt/VirtualBox which points to /usr/share/virtualbox. But of course it would be nice if this can be fixed correctly, for example by adding this path (/usr/share/virtualbox) to the rdesktop-vrdp source.

Change History

comment:1 Changed 3 years ago by frank

  • Status changed from new to closed
  • Resolution set to fixed

Please reopen if still relevant with VBox 4.3.26.

comment:2 Changed 3 years ago by deller

  • Status changed from closed to reopened
  • Resolution fixed deleted

It still isn't fixed with 4.3.26.

[deller@ls3530 ~]$ strings /usr/bin/rdesktop-vrdp | grep -i virtualbox /usr/lib/virtualbox /opt/VirtualBox/rdesktop-vrdp-keymaps

It still doesn't search in /usr/share/virtualbox which is where the rdesktop-vrdp-keymaps directory is located.

I checked with strace as well.

comment:3 Changed 3 years ago by frank

Which rpm package are you using (exact package name please)?

comment:4 Changed 3 years ago by deller

RPM Package is:
VirtualBox-4.3-4.3.26_98988_fedora18-1.x86_64

rpm -qi VirtualBox-4.3-4.3.26_98988_fedora18-1.x86_64

Name        : VirtualBox-4.3
Version     : 4.3.26_98988_fedora18
Release     : 1
Architecture: x86_64
Install Date: Di 17 Mär 2015 08:52:29 CET
Group       : Applications/System
Size        : 152497274
License     : GPLv2
Signature   : DSA/SHA1, Mo 16 Mär 2015 19:32:53 CET, Key ID 54422a4b98ab5139
Source RPM  : VirtualBox-4.3-4.3.26_98988_fedora18-1.src.rpm
Build Date  : Mo 16 Mär 2015 18:59:18 CET
Build Host  : tinderlin4.de.oracle.com
Relocations : (not relocatable)
Vendor      : Oracle Corporation
URL         : http://www.virtualbox.org/
Summary     : Oracle VM VirtualBox
Description :
VirtualBox is a powerful PC virtualization solution allowing
you to run a wide range of PC operating systems on your Linux
system. This includes Windows, Linux, FreeBSD, DOS, OpenBSD
and others. VirtualBox comes with a broad feature set and
excellent performance, making it the premier virtualization
software solution on the market.

comment:5 Changed 3 years ago by frank

You are right. We have fixed this (see r54856) and here is a test build which contains the fix. But I guess you already saw the workaround, creating a link from ~/.rdesktop/keymaps to /usr/share/virtualbox/rdesktop-vrdp-keymaps :-)

comment:6 Changed 3 years ago by deller

Hi Frank,

You are right. We have fixed this (see r54856) and here is a test build which contains the fix.

Great, thanks! Seems to be correct now.

But I guess you already saw the workaround, creating a link from ~/.rdesktop/keymaps to /usr/share/virtualbox/rdesktop-vrdp-keymaps :-)

It's a bad workaround. You need to create the symlink for every user on a system, and the .rdesktop/ directory is not there by default either.

What makes me wonder though is, if I'm the only person worldwide who is using rdesktop-vrdp (on a RPM-based distribution) and who is running rdesktop-vrpd with a non-US keyboard mapping? Otherwise this bug should have affected more users in the last 1,5 years...

Anyway, thanks for fixing this bug/annoyance! Helge

comment:7 Changed 3 years ago by frank

Yes, actually I'm wondering as well. I guess most people affected by this bug are too lazy to open a ticket. And as far as I saw, users with the standard US keyboard are affected as well because to make some special keys work it's required to load the EN/US keymap file.

comment:8 Changed 3 years ago by frank

  • Status changed from reopened to closed
  • Resolution set to fixed

Fix is part of VBox 4.3.28.

Note: See TracTickets for help on using tickets.

www.oracle.com
ContactPrivacy policyTerms of Use