Opened 11 years ago

Closed 8 years ago

#12065 closed defect (obsolete)

Suddenly no VM's will start - all give a RPC_S_SERVER_UNAVAILABLE error at 0%

Reported by: Bryan Bentz Owned by:
Component: other Version: VirtualBox 4.2.16
Keywords: RPC_S_SERVER_UNAVAILABLE 0% "won't start" Cc:
Guest type: all Host type: Windows


I was in the process of creating a new machine, and it wouldn't start (more in a bit) - I then tried to start up a few old, reliable machines, and got the same behavior. The only change was that on startup a new version was mentioned; I installed it and saw this behavior. After some web research I went back to version 4.2.12, and still see the same problem - but this may have to do with having installed the 4.2.16 version and then, perhaps, and incomplete removal. I suppose technically this applies to both versions, as the problem shows up in both.

When I try to start any machine, I see a small popup, "Starting virtual machine..." and "0%" - that never changes. My host OS is Windows 7 Ultimate; I have to kill the process for that machine manually. When I do, I get a popup from Virtualbox; the detailed error message is: Result Code:

RPC_S_SERVER_UNAVAILABLE 0x800706BA (0x800706BA) Component: ProgressProxy Interface: IProgress {c20238e4-3221-4d3f-8891-81ce92d9f913}

Web searching shows this, or something like it, was a problem years ago, but apparently fixed. I found current ticket #10747 that looks similar.

The VM I was trying to start as the main test case is a Windows 98 machine, fairly vanilla. I certainly haven't changed any of its attributes (e.g., hardware acceleration options) since it last ran.

I have 17 VM's, all of some level of importance; it would not be a minor effort to recreate them, even if that helped. I tried to create a new Windows 2000 machine from scratch and had the same problem, that is the exact same hang and detailed error message.

I'm willing to invest some time to help fix it, if any testing I can do on this end might help.

Attachments (1)

VBox.log (27.7 KB ) - added by Bryan Bentz 11 years ago.
Win2K failing startup log - most recent test of formerly working machine

Download all attachments as: .zip

Change History (3)

by Bryan Bentz, 11 years ago

Attachment: VBox.log added

Win2K failing startup log - most recent test of formerly working machine

comment:1 by Bryan Bentz, 11 years ago

One page I found earlier today had suggestions about various security policy settings; I tried those, they didn't seem to make any difference. After a reboot the problem has disappeared - I'm in the embarrassing position of not knowing which step made the difference.

As I recall, aside from the reboot itself, the main change I made was a local policy change to allow remote services to run without high security - my memory is vague on the point, and my browser history is of no help (I expect because this was a drill-down in a microsoft site page, possibly within a frame).

In any event, for the time being at least I would like to withdraw the ticket.

comment:2 by aeichner, 8 years ago

Resolution: obsolete
Status: newclosed

Please reopen if still relevant with a recent VirtualBox release.

Note: See TracTickets for help on using tickets.

© 2023 Oracle
ContactPrivacy policyTerms of Use