VirtualBox

Ticket #1197 (closed defect: fixed)

Opened 6 years ago

Last modified 6 years ago

BSOD on Vista host (VT-x init failure -> vmxon #GP -> fixed in SVN)

Reported by: wraithdu Owned by:
Priority: critical Component: other
Version: VirtualBox 1.5.4 Keywords:
Cc: Guest type: other
Host type: other

Description

I got a BSOD a few seconds after starting my VM (not after starting VirtualBox). I don't really have any other info besides that. The stop error was all zeroes, and no driver was listed.

This usually only happens the first time I try running the VM after a reboot. If I'm successful in starting the VM, then I can usually do whatever for the rest of my Windows session without any problems.

Here's 2 minidumps (also attached) -

 http://mihd.net/mupflh  http://mihd.net/awmb83

Attachments

Mini021408-01.dmp Download (134.7 KB) - added by wraithdu 6 years ago.
Minidump from 2/14
Mini021508-01.dmp Download (134.7 KB) - added by wraithdu 6 years ago.
Minidump from 2/15
VBox.log Download (40.7 KB) - added by wraithdu 6 years ago.
2/27/08 VBox Log

Change History

Changed 6 years ago by wraithdu

Minidump from 2/14

Changed 6 years ago by wraithdu

Minidump from 2/15

comment:1 Changed 6 years ago by Technologov

This bug looks like a duplicate of bug #595

-Technologov

comment:2 Changed 6 years ago by sandervl73

This seems to be a VT-x issue on your machine. Can you attach the VBox log of a successful session? Or start a VM and close it immediately.

comment:3 Changed 6 years ago by sandervl73

Both of the mini dumps show exactly the same problem. Does your BIOS have a setting to enable VT-x?

comment:4 Changed 6 years ago by wraithdu

I'll have to check my BIOS - I have a HP Pavillion dv8000t laptop, Core 2 Duo.

I think someone suggested turning off the hardware virtualization, and I did. I haven't used VBox enough since then to say that the problems are gone, but my next session did not crash. I had figured that VBox would not try to use (and crash) VT-x if it was not supported on my machine. I had left the option enabled because I wasn't sure.

I'll check my BIOS and try to submit a successful log later tonight when I get back to my laptop.

Changed 6 years ago by wraithdu

2/27/08 VBox Log

comment:5 Changed 6 years ago by wraithdu

So it seems I was a little ignorant about VT-x. It was not enabled in my BIOS. So tonight I enabled it in the BIOS and in VBox 1.5.6 (just updated) and ran several sessions, with host reboots in between. No crashes.

I attached the log from one of my successful runs as requested.

I'm guessing the crash occurs on a system that supports VT-x, but has it DISabled in the BIOS and ENabled in VBox. So is VBox not seeing that VT-x is disabled and trying to initialize it anyway? The option seems to state that VBox will use VT-x if it is supported, and not use it if it isn't supported. Maybe supported and enabled are being confused.

comment:6 Changed 6 years ago by sandervl73

  • Priority changed from major to critical
  • Summary changed from BSOD on Vista host to BSOD on Vista host (VT-x init failure -> vmxon #GP)

It's definitely an issue with VT-x initialization. Is there a newer BIOS for your laptop?

comment:7 Changed 6 years ago by sandervl73

  • Summary changed from BSOD on Vista host (VT-x init failure -> vmxon #GP) to BSOD on Vista host (VT-x init failure -> vmxon #GP -> fixed in SVN)

I've changed VT-x initialization in our development branch. Presumably the BIOS didn't really disable it, but just didn't enable it. Our previous init code didn't enable VT-x on all cores.

comment:8 Changed 6 years ago by sandervl73

  • Status changed from new to closed
  • Resolution set to fixed
Note: See TracTickets for help on using tickets.

www.oracle.com
ContactPrivacy policyTerms of Use