VirtualBox

Ticket #595 (closed defect: fixed)

Opened 7 years ago

Last modified 4 years ago

Windows Vista host crashes

Reported by: Technologov Owned by:
Priority: blocker Component: other
Version: VirtualBox 1.5.0 Keywords:
Cc: Guest type: other
Host type: other

Description

Under certain conditions, Windows Vista host kernel crashes, dumps, and after a blue screen, reboots !

Host: Windows Vista Ultimate, 32-bit, AMD Athlon XP, Aero Glass enabled, VirtualBox 1.5.0.

Guests: Windows XP and Mandrake Linux 9.2.

This is something that not always occur. (unreproduceble)

-Technologov. 31.08.2007.

Attachments

Vista-minidumps.zip Download (70.6 KB) - added by Technologov 7 years ago.
4 last Vista-minidumps, 4 crashes of Vista Host.
VBox-logs-Mandrake92-guest.zip Download (15.1 KB) - added by Technologov 7 years ago.
VirtualBox logs for Mandrake 9.2 guest. Some logs lead to Vista host Crash. Some logs maybe normal.
Mini091307-01.zip Download (34.9 KB) - added by cooperaj 7 years ago.
2 Minidumps of Vista 32bit bluescreen crashes

Change History

comment:1 Changed 7 years ago by sandervl73

  • Summary changed from Windows host crashes to Windows Vista host crashes

Please include a minidump here.

Changed 7 years ago by Technologov

4 last Vista-minidumps, 4 crashes of Vista Host.

comment:2 Changed 7 years ago by Technologov

I have a 85 MB kernel dump as well, if you want...

Changed 7 years ago by Technologov

VirtualBox logs for Mandrake 9.2 guest. Some logs lead to Vista host Crash. Some logs maybe normal.

comment:3 Changed 7 years ago by Technologov

OK, I have used yousendit.com webservice so you can download Vista kernel dump.

Link valid for 14 days, so be quick:  http://www.yousendit.com/download/www/bXBhNU1FMVg5RlkwTVE9PQ

comment:4 Changed 7 years ago by sandervl73

Got it. Thanks.

comment:5 Changed 7 years ago by Technologov

Today VBox crashed my Vista host again ! This time with openSUSE 10.3 beta guest.

comment:6 Changed 7 years ago by sandervl73

  • Version set to VirtualBox 1.5.0

Changed 7 years ago by cooperaj

2 Minidumps of Vista 32bit bluescreen crashes

comment:7 Changed 7 years ago by cooperaj

I've been experiencing BSOD on my vista host.

I got the two minidumps above whilst trying to compile Linux from scratch using the LFS live CD. Both occured during high CPU usage.

Vista Business 32bit, Aero Glass enabled, Intel Core 2 + 2Gig of Ram

comment:8 Changed 7 years ago by sandervl73

With hardware virtualization turned on or off? There's a known problem with vt-x or svm on windows hosts. (already fixed)

comment:9 Changed 7 years ago by cooperaj

Yes, this was with VT on. I will try it without and see what happens.

comment:10 Changed 7 years ago by cooperaj

I've not had a crash yet. VT may have been my issue.

Thanks

comment:11 Changed 7 years ago by Technologov

what hardware virtualization? I have Athlon XP as my main system.

comment:12 Changed 6 years ago by tholag

I have the same problem and it is related to USB. I use virtualbox 1.5.2.

I use it with two similar configurations, but in different computers, and it happens ALWAYS when I use the USB Controller enabled.

Config 1: AsRock 969-dual SATA Athlon X2 64 3800+ Windows vista 64 - Ultimate 1 gb ram XP Pro Guest system

Config 2: Asus MB AM2 Athlon X2 64 5000+ Windows Vista 64 - Business

Again, it is surely related to USB support, since when I disable the USB controller I got no problems. Could that be a problem with the Virtualbox driver? At 90% it crashes during windows guest startup.

Thank you

comment:13 Changed 6 years ago by Quasaur

My Vista VM won't complete the boot process. I'm running the following:

*Platform (Laptop): Dell Inspiron E1505 (Model MM061)
*Platform BIOS: A13
*Processor: Intel Core 2 Duo T5600
*Ethernet Controller Broadcom BCM4401-B0 with wireless
*Video Adapter: ATI Mobility Radeon X1300
*Video BIOS: BK-ATI VER009.012.001.009.020855
*Video Memory: 64MB
*Video Driver(xorg-driver-fglrx): Version 8.37.6 (X.org 7.1.0)
*Sound Card: SigmaTel STAC9200
*Sound Driver: Alsa 1.0.14-1ubuntu2
*Distro: Kubuntu Gutsy Gibbon (7.10)
*Linux Kernel: 2.6.22-14-generic
*xserver-xorg: 7.2-5ubuntu13
*xserver-xorg-core: 1.3.0.0.dsfg-12ubuntu8
*Kubuntu-Desktop:  1.59
*KDE: 3.5.8
*KNetworkManager: 0.2
*VirtualBox: 1.5.2-25433-Ubuntu_gutsy[/code]

My log says this:

00:00:01.330 Console: VM runtime error: fatal=false, errorID=HostAudioNotResponding message="Some audio devices (PCM_in, PCM_mic) could not be opened. Guest applications generating audio output or depending on audio input may hang. Make sure your host audio device is working properly. Check the logfile for error messages of the audio subsystem."
00:00:01.406 HWACCM: Host CR4=00002690
00:00:01.406 HWACCM: MSR_IA32_FEATURE_CONTROL      = 5
00:00:01.406 HWACCM: MSR_IA32_VMX_BASIC_INFO       = 1a040000000007
00:00:01.406 HWACCM: VMCS id                       = 7
00:00:01.406 HWACCM: VMCS size                     = 800
00:00:01.406 HWACCM: VMCS physical address limit   = None
00:00:01.406 HWACCM: VMCS memory type              = 6
00:00:01.406 HWACCM: Dual monitor treatment        = 1
00:00:01.406 HWACCM: MSR_IA32_VMX_PINBASED_CTLS    = 1f00000016
00:00:01.406 HWACCM:    VMX_VMCS_CTRL_PIN_EXEC_CONTROLS_EXT_INT_EXIT
00:00:01.406 HWACCM:    VMX_VMCS_CTRL_PIN_EXEC_CONTROLS_NMI_EXIT
00:00:01.406 HWACCM: MSR_IA32_VMX_PROCBASED_CTLS   = 77b9fffe0401e172
00:00:01.406 HWACCM:    VMX_VMCS_CTRL_PROC_EXEC_CONTROLS_IRQ_WINDOW_EXIT
00:00:01.406 HWACCM:    VMX_VMCS_CTRL_PROC_EXEC_CONTROLS_TSC_OFFSET
00:00:01.406 HWACCM:    VMX_VMCS_CTRL_PROC_EXEC_CONTROLS_HLT_EXIT
00:00:01.406 HWACCM:    VMX_VMCS_CTRL_PROC_EXEC_CONTROLS_INVLPG_EXIT
00:00:01.406 HWACCM:    VMX_VMCS_CTRL_PROC_EXEC_CONTROLS_MWAIT_EXIT
00:00:01.406 HWACCM:    VMX_VMCS_CTRL_PROC_EXEC_CONTROLS_RDPMC_EXIT
00:00:01.406 HWACCM:    VMX_VMCS_CTRL_PROC_EXEC_CONTROLS_RDTSC_EXIT
00:00:01.406 HWACCM:    VMX_VMCS_CTRL_PROC_EXEC_CONTROLS_CR8_LOAD_EXIT
00:00:01.406 HWACCM:    VMX_VMCS_CTRL_PROC_EXEC_CONTROLS_CR8_STORE_EXIT
00:00:01.406 HWACCM:    VMX_VMCS_CTRL_PROC_EXEC_CONTROLS_USE_TPR_SHADOW
00:00:01.406 HWACCM:    VMX_VMCS_CTRL_PROC_EXEC_CONTROLS_MOV_DR_EXIT
00:00:01.406 HWACCM:    VMX_VMCS_CTRL_PROC_EXEC_CONTROLS_UNCOND_IO_EXIT
00:00:01.406 HWACCM:    VMX_VMCS_CTRL_PROC_EXEC_CONTROLS_USE_IO_BITMAPS
00:00:01.406 HWACCM:    VMX_VMCS_CTRL_PROC_EXEC_CONTROLS_USE_MSR_BITMAPS
00:00:01.406 HWACCM:    VMX_VMCS_CTRL_PROC_EXEC_CONTROLS_MONITOR_EXIT
00:00:01.406 HWACCM:    VMX_VMCS_CTRL_PROC_EXEC_CONTROLS_PAUSE_EXIT
00:00:01.406 HWACCM: MSR_IA32_VMX_ENTRY_CTLS       = 1fff000011ff
00:00:01.406 HWACCM:    VMX_VMCS_CTRL_ENTRY_CONTROLS_IA64_MODE
00:00:01.406 HWACCM:    VMX_VMCS_CTRL_ENTRY_CONTROLS_ENTRY_SMM
00:00:01.406 HWACCM:    VMX_VMCS_CTRL_ENTRY_CONTROLS_DEACTIVATE_DUALMON
00:00:01.406 HWACCM: MSR_IA32_VMX_EXIT_CTLS        = 3efff00036dff
00:00:01.406 HWACCM:    VMX_VMCS_CTRL_EXIT_CONTROLS_HOST_AMD64
00:00:01.406 HWACCM:    VMX_VMCS_CTRL_EXIT_CONTROLS_ACK_EXTERNAL_IRQ
00:00:01.406 HWACCM: MSR_IA32_VMX_MISC             = 403c0
00:00:01.406 HWACCM:    MSR_IA32_VMX_MISC_ACTIVITY_STATES 7
00:00:01.406 HWACCM:    MSR_IA32_VMX_MISC_CR3_TARGET      4
00:00:01.406 HWACCM:    MSR_IA32_VMX_MISC_MAX_MSR         200
00:00:01.406 HWACCM:    MSR_IA32_VMX_MISC_MSEG_ID         0
00:00:01.406 HWACCM: MSR_IA32_VMX_CR0_FIXED0       = 80000021
00:00:01.406 HWACCM: MSR_IA32_VMX_CR0_FIXED1       = ffffffff
00:00:01.406 HWACCM: MSR_IA32_VMX_CR4_FIXED0       = 2000
00:00:01.406 HWACCM: MSR_IA32_VMX_CR4_FIXED1       = 27ff
00:00:01.406 HWACCM: MSR_IA32_VMX_VMCS_ENUM        = 2c
00:00:01.406 HWACCM: VMX setup failed with rc=VERR_VMX_VMXON_FAILED!
00:00:01.407 HWACCM: Last instruction error f

comment:14 Changed 6 years ago by frank

Quasaur, your problem is independent from the original one. Please would you open a separate bug report and please attach the complete VBox.log file to that report. And regarding your problem: VERR_VMX_VMXON_FAILED should not prevent the VM from booting. But you should try to boot the VM without VMX enabled.

comment:15 Changed 6 years ago by fourstone

Hi,

I have a similar problem on my machine, running both Debian SID 64 and Windows Vista Ultimate 64bit Edition natively as host. Virtualbox Version used is 1.5.4.

Under Debian everything works just fine, even Windows XP inside the VM. Under Vista however the same Windows XP 32bit virtual machine results in a host-system bluescreen. I have a Supermicro Dual Opteron Mainboard running, so it may fit your description of the AMD/Gigabyte problem, however there are no later Bioses than I use, also I do currently not see why Linux should work fine and windows does not.

please provide any insights.

kind regards, Martin

comment:16 Changed 6 years ago by sandervl73

  • Status changed from new to closed
  • Resolution set to fixed

Try again with 1.6.0 and report back if it's still relevant. Thanks.

Note: See TracTickets for help on using tickets.

www.oracle.com
ContactPrivacy policyTerms of Use