VirtualBox

Ticket #11814 (closed defect: fixed)

Opened 11 months ago

Last modified 10 months ago

Virtual machine name exceeding 87 characters corrupts OVA file ... => Fixed in SVN

Reported by: Hans Vledder Owned by:
Priority: minor Component: other
Version: VirtualBox 4.2.12 Keywords:
Cc: Guest type: Windows
Host type: Windows

Description

Gents,

Today I ran into an issue importing one of my virtual machines into the VirtualBox Manager. After some investigation I found the length of the virtual machine name to be the root cause of all this. These are the steps to reproduce the problem:

Scenario #1


  1. Create a new virtual machine with a 87 character long name.
  2. Export it to OVA format.
  3. Rename the OVA file to TAR and open it.
  4. The names of the files within the archive will be intact.
  5. Importing this machine again will run just fine.

Scenario #2


  1. Create a new virtual machine with a 88 character long name.
  2. Export it to OVA format.
  3. Rename the OVA file to TAR and open it.
  4. The name of the VMDK file within the archive will be truncated.
  5. Importing this machine again will fail, because the VMDK cannot be found.

Given the type of compression of the OVA file, the only option I see left to eliminate this problem, is to limit the VM name to 87 characters. Please let me know how and when this issue will be fixed.

Kind Regards, Hans Vledder

Attachments

0123456789012345678901234567890123456789012345678901234567890123456789012345678901234567.ova Download (80.5 KB) - added by Hans Vledder 11 months ago.
VM with 87 character long name - Imports just fine.
01234567890123456789012345678901234567890123456789012345678901234567890123456789012345678.ova Download (80.5 KB) - added by Hans Vledder 11 months ago.
VM with 88 character long name - Import fails.

Change History

Changed 11 months ago by Hans Vledder

VM with 87 character long name - Imports just fine.

Changed 11 months ago by Hans Vledder

VM with 88 character long name - Import fails.

comment:1 Changed 11 months ago by frank

  • Summary changed from Virtual machine name exceeding 87 characters corrupts OVA file ... to Virtual machine name exceeding 87 characters corrupts OVA file ... => Fixed in SVN

Thank you for this report. The problem is that the tar format isn't able to handle file names in its records longer than 99 characters. VBox did silently strip the filename in such cases. An additional sanity check raising an error will be added in the next maintenance release. The better solution would be probably to find an alternative filename in such cases.

comment:2 Changed 10 months ago by frank

  • Status changed from new to closed
  • Resolution set to fixed

Fix is part of VBox 4.2.14.

Note: See TracTickets for help on using tickets.

www.oracle.com
ContactPrivacy policyTerms of Use