VirtualBox

Ticket #11725 (closed defect: worksforme)

Opened 12 months ago

Last modified 5 months ago

Dual Monitor Support Failure

Reported by: ArashiDragon Owned by:
Priority: minor Component: GUI
Version: VirtualBox 4.2.12 Keywords:
Cc: Guest type: all
Host type: all

Description

After updating to VB 4.2.12 from 4.1.26, my Linux guest os (ubuntu 12.04) will not detect 2 screens. It clones desktop to both windows opened by VB (VBOX0 & VBOX1).

When in System -> Display & Monitor, clicking identify shows VBOX0 & VBOX1 on both virtual monitors (cloned). And the option to change monitors and such in the settings is disabled/grey'd out.

It does show both monitors in the settings, but they are copies of each other. disabling one, disables both.

I was able to fix this (temporarily) with the following command: xrandr --output VBOX1 --right-of VBOX0

I have to run the command every time I restart the VM.

There were no logs or anything to attach as there was no crash or error. The VM works fine, it just clones the desktop to both Virtual Monitors.

Attachments

DisplayandMonitor1.png Download (68.4 KB) - added by ArashiDragon 12 months ago.
SS1
DisplayandMonitor2.png Download (84.9 KB) - added by ArashiDragon 12 months ago.
SS2
DisplayandMonitor3.png Download (79.0 KB) - added by ArashiDragon 12 months ago.
SS3

Change History

comment:1 Changed 12 months ago by michael

This sounds more like an issue with the X.Org tools than with VirtualBox if you were able to do it from the command line with xrandr. I presume you did untick the "clone" option in the display settings.

comment:2 Changed 12 months ago by ArashiDragon

The clone option is grey'd out (unselectable). I reverted back to 4.1.26 and it works fine again.

I admit I'm not an expert with linux, I'm just getting back into using linux after not touching it for almost 13 years. So if you have a suggestion for me to look into, I'll try it.

Since I use seamless mode. I won't update back to 4.2.12, due to VB crashing whenever I open a new window (sometimes when I move a window).

So I'll have to wait till the next update after 4.2.12 to see if the problems are resolved.

Changed 12 months ago by ArashiDragon

SS1

Changed 12 months ago by ArashiDragon

SS2

Changed 12 months ago by ArashiDragon

SS3

comment:3 Changed 12 months ago by ArashiDragon

***Forgot to add***: HOST OS: Windows 7 Ultimate 64bit, GUEST OS: Ubuntu 12.04, VBOX 4.2.13-85100, Previous VBOX version where it all worked: 4.1.26)

Ok, I'm back, running 4.2.13-85100. (was having this issue at the same time which is why I reverted back to older version: https://www.virtualbox.org/ticket/11723 )

I'm still having the issue of the Guest OS not seeing dual monitors (mirroring to both monitors).

This command will fix it (temp, but I have to do this everytime I start the OS: xrandr --output VBOX1 --right-of VBOX0 )

As I said before I'm just getting back into Linux, and if there's something someone can recommend trying I will.

From what I've read though, Ubuntu 12.04 doesn't have an xorg.conf , I haven't seen an explantion of why it's no longer needed, just that it's not.

Before I updated from 4.1.26 to 4.2.x it was working just fine, 2 monitors would automtically be set to 2 screens.

What it is doing now in system settings -> Display and Monitors

SS1: DisplayandMonitor1 = 2 things to note, 1) I have already used the xrandr command to make it use 2 monitors. 2) Notice in the green box the 0 and 1 are both there on the same screen (overlaying each other).

SS2: DisplayandMonitor2 = I changed a setting so I could hit apply, which undoes the xrandr command mirroring the monitors again. The green box still shows the 0 and 1 overlaying each other. When I hit the identify button notice it says the one screen is both monitors.

SS3: DisplayandMonitor3 = xrandr command redone, hitting identify now shows VB0X# on the proper screens, but in the green box the 0 and 1 are still overlaying each other. If I were to make a change and click apply, it mirrors both monitors.

***Note*** A lot of options on that screen are disabled, I do not have the choice to change them.

Last edited 12 months ago by ArashiDragon (previous) (diff)

comment:4 Changed 12 months ago by michael

That looks more like Kubuntu than Ubuntu to me - is there anything else I should know about the guest (or can you make it or another which has the issue downloadable for me so I can take a look)? And could you please put up a screen shot of what the system settings look like before you work around the issue using xrandr from the command line?

comment:5 Changed 12 months ago by ArashiDragon

It started out as Ubuntu, but I added kde to it afterwards. I didn't know about kubuntu at the time. I was using Gentoo, but couldn't get it to install on VirtualBox, and a friend told me to try ubuntu, I just grabbed the latest 12.04, and installed it. Then hated the look of Unity, and installed KDE. I can tell you I'm not using the standard KDE, friend helped me setup a new repository to access a newer version of KDE.

System settings looks like the first screenshot before I mess with it.. xrandr doesn't change what system settings looks like.

I can get you any info you want, just give me the commands to run and I can copy to a text file or screenshot it for you. I understand enough of linux again to be dangerous, but still relearning a lot.

comment:6 Changed 12 months ago by michael

Presumably "System settings" doesn't look quite like the first screen-shot, since you said that the clone option ("Unify outputs"?) was greyed out. I do still tend to the idea that this is a graphical interface configuration issue, not a VirtualBox one.

comment:7 Changed 12 months ago by ArashiDragon

Ok I didn't know the unify outputs, was the clone option. That is always checked and available, but still only sees the one monitor.

I was looking at the selections under each monitor, the box that says "Position" one of them (grey'd out) says "clone of".

Unify outputs has always been checked and doesn't change. From what little I've been able to search for and read about, ubuntu has the graphics information sent to it and uses that to determine # of monitors, which is why a xorg.conf isn't needed anymore. This used to work in 4.1.26 (and did work again when I reverted.) So this tells me that something between 4.1.26 and 4.2.12 (& .13 I'm using now) is different in that regard.

I can uncheck unify outputs, save it and then recheck it and save the setting and it has no effect (other than push both monitors output back to a single monitor (undoes the xrandr command).

If you want me to get you a fresh screenshot from a restart, I can, but nothing in the screenshot will look any different than the 3 I already uploaded.

Long story short, if I revert to 4.1.26 it works (without changing any settings, it just boots up and has 2 monitors). Updating to 4.2.x and it stops working and I have to use xrandr to make it use both monitors.

Again, if you need any info, just give me the commands to run so I can copy paste or Screenshot them for you.

comment:8 Changed 12 months ago by michael

I'm afraid that we are probably not going to get very far like this, as no one else seems to be reporting this and I don't really have enough information to reproduce your issue. If you are interested in investigating this you could try to reproduce it with a clean Kubuntu installation (I suspect that 13.04 will be about as new as what you have) and give me precise instructions.

comment:9 Changed 5 months ago by frank

  • Status changed from new to closed
  • Resolution set to worksforme

No response, closing.

Note: See TracTickets for help on using tickets.

www.oracle.com
ContactPrivacy policyTerms of Use