VirtualBox

Ticket #11723 (closed defect: fixed)

Opened 2 years ago

Last modified 22 months ago

Seamless Mode Crashes VBoxManager => Fixed in SVN

Reported by: seancoy Owned by:
Priority: major Component: guest additions
Version: VirtualBox 4.2.12 Keywords: Seamless Mode
Cc: Guest type: Linux
Host type: Windows

Description

When moving a window (in X on guest Centos 6.2) with seamless mode enabled the VM crashes with error:

Oracle VM VirtualBox Manager Has stopped working.

Faulting application name: VirtualBox.exe, version: 4.2.12.0, time stamp: 0x5167d6dc Faulting module name: VBoxOGLhostcrutil.dll, version: 0.0.0.0, time stamp: 0x5167d68b Exception code: 0xc0000005 Fault offset: 0x0000000000016fa8 Faulting process id: 0x1a48 Faulting application start time: 0x01ce3a03b049c2db Faulting application path: C:\Program Files\Oracle\VirtualBox\VirtualBox.exe Faulting module path: C:\Program Files\Oracle\VirtualBox\VBoxOGLhostcrutil.dll Report Id: 5102ec78-a606-11e2-99c9-a02efbb717d5

This is replicable everytime. Have rebooted guest and host. Does not happen in windowed mode.

No sign of crash in logs on guest.

Guest: CentOS release 6.2 (Final) Host: Windows 7 SP1

Attachments

Appcrash-Oracle-VM-Virtualbox-Report.wer Download (14.0 KB) - added by seancoy 2 years ago.
Windows error report of application crash.
VirtualBox.exe.2948.zip Download (483.6 KB) - added by seancoy 2 years ago.
Minidump-Oracle-VM-Manager
VirtualBox.exe.1680.zip Download (484.5 KB) - added by seancoy 2 years ago.
Appcrash Oracle VM Manager with CentOS 6.4 as guest

Change History

Changed 2 years ago by seancoy

Windows error report of application crash.

comment:1 Changed 2 years ago by ArashiDragon

I get a similar problem with ubuntu 12.04.

Moving a window doesn't always crash the VM, but opening the System & Settings while in Seamless mode always crashes it for me.

Problem signature:

Problem Event Name: APPCRASH

Application Name: VirtualBox.exe

Application Version: 4.2.12.0

Application Timestamp: 5167d6dc

Fault Module Name: VBoxOGLhostcrutil.dll

Fault Module Version: 0.0.0.0

Fault Module Timestamp: 5167d68b

Exception Code: c0000005

Exception Offset: 0000000000016fa8

OS Version: 6.1.7601.2.1.0.256.1

Locale ID: 1033

Additional Information 1: 398f

Additional Information 2: 398f4ae7bd41092a0475133f77a69e35

Additional Information 3: a203

Additional Information 4: a2032564b5b7e73d8377103da26d010c

UPDATE: Opening ANY new window crashes VB instantly.

Last edited 2 years ago by ArashiDragon (previous) (diff)

comment:2 Changed 2 years ago by blahmoomoo

This is happening to me as well on VirtualBox 4.2.12, Windows 7 32-bit host, Ubuntu 10.04 guest.

However, it only seemed to happen to me when moving around windows forwarded over SSH using the -Y command line parameter (probably would happen with -X as well). Then again, it might have also happened if I tried moving around larger windows.

Also, all visual enhancements are turned off, which may explain why it crashes faster for others.

comment:3 Changed 2 years ago by misha

Could you attach a minidump here rather than a WER report? See  http://msdn.microsoft.com/en-us/library/bb787181%28VS.85%29.aspx for detail on creating crash dumps on Win Vista and later.

Changed 2 years ago by seancoy

Minidump-Oracle-VM-Manager

comment:4 Changed 2 years ago by seancoy

I upgraded my guest to CentOS 6.4 and reinstalled the 2.4.12 guest additions. The problem still persists.

Changed 2 years ago by seancoy

Appcrash Oracle VM Manager with CentOS 6.4 as guest

comment:5 Changed 2 years ago by bruce

There is an option named "Enable 3D Acceleration" in the Display settings, I got this issue before, after I uncheck it, the issue was gone.

HTH,

Bruce

comment:6 follow-up: ↓ 7 Changed 2 years ago by misha

Thanks for the dumps, we have found and fixed this issue now.
Here is a test build containing the fix. Please give it a try and let me know whether the issue is solved with it:

 http://www.virtualbox.org/download/testcase/VirtualBox-4.2.13-85147-Win.exe

Let me know if you need a build for any non-windows host.

comment:7 in reply to: ↑ 6 Changed 2 years ago by ArashiDragon

Replying to misha:

Thanks for the dumps, we have found and fixed this issue now.
Here is a test build containing the fix. Please give it a try and let me know whether the issue is solved with it:

 http://www.virtualbox.org/download/testcase/VirtualBox-4.2.13-85147-Win.exe

Let me know if you need a build for any non-windows host.

Thanks, it's nice to be able to use seamless mode again. Only been running it for about 5 minutes now, but seems to have fixed the problem completely for me. I can move windows around and open new ones, no crashing.

comment:8 Changed 2 years ago by seancoy

Thank you. After installing the 4.2.13 r85147 and guest additions, I've been able to use seamless mode with no problems.

comment:9 Changed 2 years ago by gpechorin

I am having this problem as well with . How would I gain access to 4.2.13-85147? The link is dead

comment:10 Changed 2 years ago by rzoerner

I am also having this problem (ver. 4.2.12) but I am trying to run Ubuntu 12.04 guest inside a Windows 7 Pro host (both 64-bit).

comment:11 follow-up: ↓ 12 Changed 2 years ago by frank

  • Summary changed from Seamless Mode Crashes VBoxManager to Seamless Mode Crashes VBoxManager => Fixed in SVN

 Here is another test build. Thanks for testing!

comment:12 in reply to: ↑ 11 Changed 23 months ago by Tsso2

Replying to frank:

 Here is another test build. Thanks for testing!

That link is broken now.

comment:14 Changed 22 months ago by frank

  • Status changed from new to closed
  • Resolution set to fixed

Fix is part of VBox 4.2.14.

Note: See TracTickets for help on using tickets.

www.oracle.com
ContactPrivacy policyTerms of Use