VirtualBox

Ticket #11711 (closed defect: invalid)

Opened 12 months ago

Last modified 12 months ago

iSCSI error "VD: error VERR_IO_GEN_FAILURE opening image file..."

Reported by: made Owned by:
Priority: major Component: virtual disk
Version: VirtualBox 4.2.12 Keywords: iSCSI
Cc: Guest type: Windows
Host type: Windows

Description

My system is a Win7 x64 and iSCSI targets on synology DS410. I can use this iSCSI targets on my Win7 fine.

I create a VM with GUI and add the iSCSI lun with cli with no errors on this step

VBoxManage.exe storageattach "WinXPold" --storagectl "IDE" --port 0 --device 0 --type hdd --medium iscsi --server "192.168.123.251" --target "iqn.2000-01:Nordpol:XPboot"

when i show hdd info, i get "inaccessible", why???

C:\Program Files\Oracle\VirtualBox>VBoxManage.exe list hdds
UUID:        7b7f2203-3f4b-4589-a946-630db13824ab
Parent UUID: base
Format:      iSCSI
Location:    192.168.123.251|iqn.2000-01:Nordpol:XPboot
State:       inaccessible
Type:        normal
Usage:       WinXPold (UUID: 3cc2f25b-80be-4ef1-afda-701949d97d4f)


C:\Program Files\Oracle\VirtualBox>VBoxManage.exe showhdinfo 7b7f2203-3f4b-4589-
a946-630db13824ab
UUID:                 7b7f2203-3f4b-4589-a946-630db13824ab
Accessible:           no
Access Error:         Could not open the medium '192.168.123.251|iqn.2000-01:Nordpol:XPboot'.
VD: error VERR_IO_GEN_FAILURE opening image file '192.168.123.251|iqn.2000-01:Nordpol:XPboot' (VERR_IO_GEN_FAILURE)
Logical size:         0 MBytes
Current size on disk: 0 MBytes
Type:                 normal (base)
Storage format:       iSCSI
Format variant:       dynamic default
In use by VMs:        WinXPold (UUID: 3cc2f25b-80be-4ef1-afda-701949d97d4f)
Location:             192.168.123.251|iqn.2000-01:Nordpol:XPboot

Change History

comment:1 Changed 12 months ago by aeichner

Which iSCSI target software do you use and can you provide a network packet trace?

comment:2 Changed 12 months ago by made

hello,

thanks for your tip, i trace the win7 connect and see this was my fault, not a bug... thanks.

comment:3 Changed 12 months ago by aeichner

  • Status changed from new to closed
  • Resolution set to invalid

Thanks for the information, closing

Note: See TracTickets for help on using tickets.

www.oracle.com
ContactPrivacy policyTerms of Use