VirtualBox

Ticket #11646 (closed defect: duplicate)

Opened 13 months ago

Last modified 13 months ago

"Enable PAE" CPU option always on

Reported by: chrisb Owned by:
Priority: major Component: other
Version: VirtualBox 4.1.12 Keywords:
Cc: Guest type: Linux
Host type: Linux

Description

Host: Dell Opteron 1212 running Ubuntu and virtualbox 4.1.12.

Clear the checkbox Settings>System>Processor>Enable PAE/NX. Boot Ubuntu VM. "cat /proc/cpuinfo|grep pae" shows that the pae flag is still present in the VM.

Bug: when the checkbox is clear, PAE should not be exposed to the virtual machine.

VBox.log shows that "EnablePAE = .. 0" but later "CPUMSetGuestCpuIdFeature: Enabled PAE":

00:00:01.355   EnablePAE       <integer> = 0x0000000000000000 (0)
00:00:01.366 PAE - Physical Address Extension       = 0 (1)
00:00:01.366 PAE - Physical Address Extension       = 0 (1)
00:00:01.368 Debug: HCPhysInterPD=00000000b26a2000 HCPhysInterPaePDPT=00000000a3c4d000 HCPhysInterPaePML4=00000000b05b1000
00:00:01.368 Debug: apInterPTs={00000000a3894000,0000000086f13000} apInterPaePTs={000000010a9ab000,000000010a99e000} apInterPaePDs={000000010a99f000,000000010a990000,000000010a991000,000000010a97a000} pInterPaePDPT64=00000000af3a6000
00:00:01.740 CPUMSetGuestCpuIdFeature: Enabled PAE

Attachments

VBox.log Download (45.5 KB) - added by chrisb 13 months ago.

Change History

Changed 13 months ago by chrisb

comment:1 Changed 13 months ago by chrisb

(The host system is Ubuntu 12.04.02 LTS)

comment:2 Changed 13 months ago by chrisb

I tested with VirtualBox 4.2.10 from https://www.virtualbox.org/wiki/Linux_Downloads and got exactly the same:

00:00:00.894801   EnablePAE       <integer> = 0x0000000000000000 (0)
00:00:00.898889 Debug: HCPhysInterPD=00000000af7ee000 HCPhysInterPaePDPT=000000005aa7d000 HCPhysInterPaePML4=00000000305a8000
00:00:00.898948 Debug: apInterPTs={0000000009de4000,0000000094997000} apInterPaePTs={0000000137299000,000000013729a000} apInterPaePDs={000000013729b000,000000013729c000,000000013729d000,000000013729e000} pInterPaePDPT64=00000000b138e000
00:00:01.659533 PAE - Physical Address Extension       = 0 (1)
00:00:01.659930 PAE - Physical Address Extension       = 0 (1)
00:00:01.660414 CPUMSetGuestCpuIdFeature: Enabled PAE

comment:3 Changed 13 months ago by chrisb

I don't seem to be able to modify the ticket to update the version to 4.2.10.

comment:4 Changed 13 months ago by frank

  • Status changed from new to closed
  • Resolution set to duplicate

Duplicate of #10089.

Note: See TracTickets for help on using tickets.

www.oracle.com
ContactPrivacy policyTerms of Use