VirtualBox

Ticket #1136 (closed defect: fixed)

Opened 6 years ago

Last modified 5 years ago

Ubuntu Installer missing graphics

Reported by: Graham Owned by:
Priority: minor Component: other
Version: VirtualBox 1.5.4 Keywords:
Cc: Guest type: other
Host type: other

Description

I am creating a course to install and use Kubuntu Gutsy (7.10).

For those who are interested:  link to course.

I was taking screenshots of the installer on the live CD and noticed that on "Step 2 of 6" ("Where are you?") timezone selection the graphic for the world map didn't render correctly.

You get the dots representing the city location but no actual map of the world.

In fact you get the text from the previous screen showing behind the dots and box.

If you do a "Back"->"Next" it clears the text from the previous screen, but no world map graphic.

Host 1: WinXP SP2, 1.25Gb RAM 120Gb HDD, nVidia GeForceGo (Dell Inspiron 8600 upgraded) Host 2: Kubuntu (upgraded to latest), VIA mobo, Athlon 3000XP, 2Gb RAM 250Gb HDD, nVidia 6200 TwinViewed (prop. driver) VirtualBox machine with 256Mb RAM, 10Gb disc, CDRom image: kubuntu-7.10-desktop-i386.iso, Audio: ALSA/Windows DirectShow, NAT network, no serial, no shares.

Both machines created from scratch. Both showing same problem

Problem also occurs in Qemu 0.9.1 (cirrus and std-vga drivers)

Tested in VMware 1.0.4 (spit, spit :-) graphic displays correctly.

Admittedly looks like it could be a bug in Gutsy installer, but why different on different hardware?

I will check VMware on WinXP also Ubuntu-7.10-desktop-i386.iso (Gnome edition)

Shots attached.

Attachments

Kubuntu-12.png Download (235.8 KB) - added by Graham 6 years ago.
Installer step 2 of 6 (Where are you?) in VMware (Linux host)
Kubuntu-13.png Download (64.5 KB) - added by Graham 6 years ago.
Same in Qemu 0.9.1 (std-vga)
Kubuntu-14.png Download (38.4 KB) - added by Graham 6 years ago.
Same after a "Back"->"Next"
Kubuntu-15.png Download (158.9 KB) - added by Graham 6 years ago.
Vmware with WinXP host
Kubuntu-16.png Download (195.3 KB) - added by Graham 6 years ago.
Ubuntu (Gnome) in VirtualBox on Linux -works
Kubuntu-17.png Download (123.7 KB) - added by Graham 6 years ago.
Kubuntu Hardy Alpha 3 in VirtualBox on Linux -works

Change History

Changed 6 years ago by Graham

Installer step 2 of 6 (Where are you?) in VMware (Linux host)

Changed 6 years ago by Graham

Same in Qemu 0.9.1 (std-vga)

Changed 6 years ago by Graham

Same after a "Back"->"Next"

Changed 6 years ago by Graham

Vmware with WinXP host

Changed 6 years ago by Graham

Ubuntu (Gnome) in VirtualBox on Linux -works

comment:1 Changed 6 years ago by Graham

It seems to be a combination of Kubuntu (KDE edition) and either VirtualBox or Qemu.

comment:2 Changed 6 years ago by Graham

Just checking out Ubuntu (Gnome) on Qemu

comment:3 Changed 6 years ago by Graham

Qemu on Linux with std-vga and cirrus works

Steps to reproduce:

  1. download and install VirtualBox 1.5.4 (Windows or Linux) or Qemu 0.9.1 (Linux)
  2. Download kubuntu-7.10-desktop-i386.iso
  3. Set up a VirtualBox to boot the CD image.
  4. When the desktop is ready click the "Install" icon.
  5. Go "Next" to step 2 "Where are you?" (select the Time Zone)
  6. Observe the missing world map.

I will see about raising a linked bug with the Kubuntu guys and add a reference here.

comment:4 follow-up: ↓ 6 Changed 6 years ago by michael

I have in the past seen a problem with the Ubuntu installer on VirtualBox which was due to the fact that it had not been properly tested using a generic VESA graphics card. Although I admittedly can't quite match the symptoms that you are getting to that.

comment:5 Changed 6 years ago by Graham

Also checking out Hardy Alpha 3

comment:6 in reply to: ↑ 4 Changed 6 years ago by Graham

Replying to michael:

I have in the past seen a problem with the Ubuntu installer on VirtualBox which was due to the fact that it had not been properly tested using a generic VESA graphics card. Although I admittedly can't quite match the symptoms that you are getting to that.

I saw it also on Qemu using the cirrus graphics card. Is there any way of configuring VirtualBox to use a different graphic card?

comment:7 Changed 6 years ago by michael

I do suspect though that the Ubuntu installers don't get as well tested as the rest of the distro, as most people only use them once.

comment:8 Changed 6 years ago by Graham

comment:9 Changed 6 years ago by Graham

Update appears to be fixed in Hardy Alpha 3

Changed 6 years ago by Graham

Kubuntu Hardy Alpha 3 in VirtualBox on Linux -works

comment:10 Changed 6 years ago by Graham

Actually I registered with the wrong package at Ubuntu. The installer is called Ubiquity and it appears they have done alot of testing, judging by the bug count.

comment:11 Changed 6 years ago by Graham

comment:12 Changed 5 years ago by frank

  • Status changed from new to closed
  • Resolution set to fixed

Reopen if this bug is still appropriate. But check release 2.2.2 first.

Note: See TracTickets for help on using tickets.

www.oracle.com
ContactPrivacy policyTerms of Use