VirtualBox

Ticket #11323 (reopened defect)

Opened 16 months ago

Last modified 4 months ago

Virtualbox Manager 4.2.6 hangs when certain inaccessible VMs are present => fixed in SVN

Reported by: kimus Owned by:
Priority: major Component: other
Version: VirtualBox 4.2.6 Keywords:
Cc: Guest type: other
Host type: all

Description

I've installed the latest Virtualbox (VirtualBox-4.2.6-82870-OSX.dmg) and the VirtualBox Manager opens and hangs (retrieving/populating the VM information?) and I need to force kill it!

Reverted to 4.2.2 and 4.2.4 and it works fine!

Attachments

virtualbox.txt Download (372.9 KB) - added by qosobrin 16 months ago.
report sent to apple when forced program quit
VirtualBoxHang.log.gz Download (51.9 KB) - added by lu_zero 4 months ago.
Apple log

Change History

comment:1 Changed 16 months ago by andykiss

Do have the same problem after upgrading to 4.2.6 on Macbook ML, 100% cpu usage. Force kill and installed 4.2.4 (as before) everything normal

Changed 16 months ago by qosobrin

report sent to apple when forced program quit

comment:2 Changed 16 months ago by qosobrin

I have the exact same problem. I attached a file with some information.

comment:3 Changed 16 months ago by kimus

I must ask what more is needed for this issue has some kind of reply. This seams to be a seriously issue because we can't update to the latest release of VB and it's confirmed by other users but still no response from the devs.

I can help on whatever you need but please inform me what's relevant for understanding this issue and fix it or put in the road map.

comment:4 Changed 16 months ago by Dsen

I can't reproduce the issue on my mac host, so it is not easy to find/fix the reason without help of any user who is able to reproduce it.
Could any of you please provide me with the list of machines you have registered (through VBoxManage)?
It may be also helpful to know if Virtualbox Manager still hangs (or not) after you will unregister all the machines (through VBoxManage too).

The file with the hang stack information attached by qosobrin (virtualbox.txt) is not informative. We will probably check the stack trace of the debug build.

comment:5 Changed 16 months ago by kimus

Hi, thank you for your reply. I could help in what ever you need.

There's some feedback in this thread (page 2):  https://forums.virtualbox.org/viewtopic.php?f=8&t=53225&start=15

But I could say that it hangs like this:  http://cl.ly/image/3i224614190r (populating the VM information) but I can start VM by command line and even go to their settings after started.

comment:6 Changed 16 months ago by Dsen

There is a test debug build for Mac OS X (based on 4.2.7 version) available at:
 http://www.virtualbox.org/download/testcase/VirtualBox-4.2.7-83123-OSX.dmg
Please note, this build should NOT be used as normal installation (its a test build to debug this issue).
If you wish to help us to find the reason of the hang, you can install this package (better to remove already installed before that) and run VirtualBox Manager in gdb in console terminal, then reproduce the full hang and then press "ctrl+c" (in console) to interrupt application execution in gdb, then call for back trace using "bt" command in gdb. Probably the call-stack will be helpful.

comment:7 Changed 16 months ago by kimus

When I try to debug on my normal user I get:

 (gdb) run
 Starting program: /Applications/VirtualBox.app/Contents/MacOS/VirtualBox 
 Reading symbols for shared libraries +++................................... done
 VirtualBox: Error -10 in SUPR3HardenedMain!
 VirtualBox: Effective UID is not root (euid=501 egid=20 uid=501 gid=20)
 
 VirtualBox: Tip! It may help to reinstall VirtualBox.

When I try it with sudo or with the root user no VM's are in the VBManager list and no hang occurs.

comment:8 Changed 16 months ago by kimus

Copied the VirtualBox settings from my user and the final result is:

(gdb) run
Starting program: /Applications/VirtualBox.app/Contents/MacOS/VirtualBox 
Reading symbols for shared libraries +++................................... done
Reading symbols for shared libraries .............................. done
Reading symbols for shared libraries ............................................................................................ done
Reading symbols for shared libraries . done
Reading symbols for shared libraries . done
Reading symbols for shared libraries . done
Reading symbols for shared libraries . done
Reading symbols for shared libraries . done
Reading symbols for shared libraries . done
Type Manifest File: /var/root/Library/VirtualBox/xpti.dat
Reading symbols for shared libraries . done
nsNativeComponentLoader: autoregistering begins.
nsNativeComponentLoader: autoregistering succeeded
nNCL: registering deferred (0)
Reading symbols for shared libraries . done
Reading symbols for shared libraries .. done
Reading symbols for shared libraries .. done
Reading symbols for shared libraries ........... done
Reading symbols for shared libraries . done
Reading symbols for shared libraries . done
^C
Program received signal SIGINT, Interrupt.
0x0000000101d12a96 in QPMCache::object ()
(gdb) bt
#0  0x0000000101d12a96 in QPMCache::object ()
#1  0x0000000101d12c06 in QPixmapCache::find ()
#2  0x0000000101d12c49 in QPixmapCache::find ()
#3  0x0000000101ce32f7 in QPixmapIconEngine::pixmap ()
#4  0x0000000101ce00dd in QIcon::pixmap ()
#5  0x0000000101252fde in QRect::setHeight ()
#6  0x0000000101253176 in QRect::setHeight ()
#7  0x00000001012458f9 in QPointF::QPointF ()
#8  0x0000000101233e15 in QString::operator[] ()
#9  0x000000010141f4b5 in QByteArray::isEmpty ()
#10 0x0000000101919116 in QMetaObject::activate ()
#11 0x000000010141d832 in QByteArray::isEmpty ()
#12 0x000000010141d909 in QByteArray::isEmpty ()
#13 0x00000001019fc169 in QObject::event ()
#14 0x0000000101c621fd in QApplicationPrivate::notify_helper ()
#15 0x0000000101c69a9e in QApplication::notify ()
#16 0x00000001019127cc in QCoreApplication::notifyInternal ()
#17 0x00000001019ef2ab in QCoreApplicationPrivate::sendPostedEvents ()
#18 0x00007fff91890101 in __CFRUNLOOP_IS_CALLING_OUT_TO_A_SOURCE0_PERFORM_FUNCTION__ ()
#19 0x00007fff9188fa25 in __CFRunLoopDoSources0 ()
#20 0x00007fff918b2dc5 in __CFRunLoopRun ()
#21 0x00007fff918b26b2 in CFRunLoopRunSpecific ()
#22 0x00007fff90a9d0a4 in RunCurrentEventLoopInMode ()
#23 0x00007fff90a9ce42 in ReceiveNextEventCommon ()
#24 0x00007fff90a9ccd3 in BlockUntilNextEventMatchingListInMode ()
#25 0x00007fff8e98d613 in _DPSNextEvent ()
#26 0x00007fff8e98ced2 in -[NSApplication nextEventMatchingMask:untilDate:inMode:dequeue:] ()
#27 0x00007fff8e984283 in -[NSApplication run] ()
#28 0x0000000101c1dff4 in QEventDispatcherMac::processEvents ()
#29 0x00000001019edc14 in QEventLoop::processEvents ()
#30 0x00000001019edf34 in QEventLoop::exec ()
#31 0x00000001019ef55c in QCoreApplication::exec ()
#32 0x0000000101111102 in TrustedMain ()
#33 0x0000000100003228 in start ()
(gdb)      

comment:9 Changed 16 months ago by Dsen

Hmm, that stack is not informative too, without debug-symbols I seems can only guess what happens there. There are no links to actual GUI code, only base Qt classes. I will ask our build-engineers if it is possible to include debug-symbols (into test debug version).
From that I see its something with pixmaps caching stuff. Could you please try to reproduce the hang few times and check if it happens always on the same place? If the places are different, other stacks can probably enlighten the situation.
Also, just to clarify it for me, when the hang happens - GUI become fully non-responsible to mouse/keyboard interactions?
Thanks in advance.

comment:10 Changed 16 months ago by kimus

When it's retrieving/populating the VM information it starts to become very, very, very slow and then it stops and become non-resposible.

Another trace if I wait a bit more:

Program received signal SIGINT, Interrupt.
0x00007fff911f90fa in __psynch_cvwait ()
(gdb) bt
#0  0x00007fff911f90fa in __psynch_cvwait ()
#1  0x00007fff92f19f89 in _pthread_cond_wait ()
#2  0x00000001031f55c1 in PR_DestroyLock ()
#3  0x00000001031f5998 in PR_WaitCondVar ()
#4  0x00000001031f5d05 in PR_Wait ()
#5  0x00000001044b1ebd in operator delete ()
#6  0x00000001044adc0f in GetMPManager()::mpMgr ()
#7  0x00000001044addd5 in GetMPManager()::mpMgr ()
#8  0x00000001044bcb8b in NSGetModule ()
#9  0x00000001031cc6e3 in nsXPTCStubBase::Sentinel0 ()
#10 0x00000001031cb507 in XPTC_InvokeByIndex ()
#11 0x00000001013aeae2 in QByteArray::isEmpty ()
#12 0x000000010121bfff in QCoreApplication::sendEvent ()
#13 0x000000010125316d in QRect::setHeight ()
#14 0x00000001012458f9 in QPointF::QPointF ()
#15 0x0000000101233e15 in QString::operator[] ()
#16 0x000000010141f4b5 in QByteArray::isEmpty ()
#17 0x0000000101919116 in QMetaObject::activate ()
#18 0x000000010141d832 in QByteArray::isEmpty ()
#19 0x000000010141d909 in QByteArray::isEmpty ()
#20 0x00000001019fc169 in QObject::event ()
#21 0x0000000101c621fd in QApplicationPrivate::notify_helper ()
#22 0x0000000101c69a9e in QApplication::notify ()
#23 0x00000001019127cc in QCoreApplication::notifyInternal ()
#24 0x00000001019ef2ab in QCoreApplicationPrivate::sendPostedEvents ()
#25 0x00007fff91890101 in __CFRUNLOOP_IS_CALLING_OUT_TO_A_SOURCE0_PERFORM_FUNCTION__ ()
#26 0x00007fff9188faed in __CFRunLoopDoSources0 ()
#27 0x00007fff918b2dc5 in __CFRunLoopRun ()
#28 0x00007fff918b26b2 in CFRunLoopRunSpecific ()
#29 0x00007fff90a9d0a4 in RunCurrentEventLoopInMode ()
#30 0x00007fff90a9ce42 in ReceiveNextEventCommon ()
#31 0x00007fff90a9ccd3 in BlockUntilNextEventMatchingListInMode ()
#32 0x00007fff8e98d613 in _DPSNextEvent ()
#33 0x00007fff8e98ced2 in -[NSApplication nextEventMatchingMask:untilDate:inMode:dequeue:] ()
#34 0x00007fff8e984283 in -[NSApplication run] ()
#35 0x0000000101c1dff4 in QEventDispatcherMac::processEvents ()
#36 0x00000001019edc14 in QEventLoop::processEvents ()
#37 0x00000001019edf34 in QEventLoop::exec ()
#38 0x00000001019ef55c in QCoreApplication::exec ()
#39 0x0000000101111102 in TrustedMain ()
#40 0x0000000100003228 in start ()

comment:11 Changed 16 months ago by kimus

When it stops completly (removed lines):

#0  0x00007fff911f90fa in __psynch_cvwait ()
#1  0x00007fff92f19f89 in _pthread_cond_wait ()
#2  0x00000001031f55c1 in PR_DestroyLock ()
#3  0x00000001031f5998 in PR_WaitCondVar ()
#4  0x00000001031f5d05 in PR_Wait ()
#5  0x00000001037b0ebd in operator delete ()
#6  0x00000001037acc0f in NSGetStaticModuleInfo ()
#7  0x00000001037acdd5 in NSGetStaticModuleInfo ()
#8  0x00000001037bbb8b in NSGetModule ()
#9  0x00000001031cc6e3 in nsXPTCStubBase::Sentinel0 ()
#10 0x00000001031cb507 in XPTC_InvokeByIndex ()
#11 0x00000001013aeae2 in QByteArray::isEmpty ()
#12 0x000000010121bfff in QCoreApplication::sendEvent ()
#13 0x000000010125316d in QRect::setHeight ()
...

comment:12 Changed 16 months ago by Dsen

The last two traces looks more like GUI hangs on worker thread termination (thread which acquires information from VM).
Could you please check if the issue happens with just one newly created VM in VM list? (you can unregister all your VMs with VBoxManage for example and you can backup your configuration folder before that). May be thats some particular VM configuration causes the hang.

comment:13 Changed 16 months ago by kimus

Ok... found/workaround the problem!! :-)

I had an "<inaccessible>" VM. Removed from VirtualBox.xml and now VirtualBox Manager works fine!

EDIT: Also removed all "*.log*" files but I guess it was the "<inaccessible>" VM

Last edited 16 months ago by kimus (previous) (diff)

comment:14 Changed 16 months ago by Dsen

Hmm, that is interesting.
I'm not able to reproduce the hang with inaccessible VM too. Indeed inaccessible VM handling even simpler than accessible one. So that makes issue even more strange. I hope you didn't removed that VM configuration file? Could you please provide me with .vbox from that VM folder? Also please check if returning back inaccessible VM declaration into VirtualBox.xml restores the hang behavior.
Thx in advance.

comment:15 Changed 16 months ago by kimus

I added:

<MachineEntry uuid="{642c2402-33da-4d25-871d-d2df044db6bd}" src="/Users/kimus/Virtual Machines/Windows XP/Windows XP.xml"/>

And it hangs again :-)

The VM folder does not exist! I have 2 VM groups (you can see it in the screenshot above) and this VM was inaccessible (was removed) and outside the groups.

comment:16 Changed 15 months ago by Dsen

Hi Kimus,
I can provide you with full debug trunk build with debug-symbols (to check the same as in comment 6).
Is it possible to discuss it with you in some irc-channel? For example we have external channel at irc.freenode.net (#vbox).

comment:17 Changed 15 months ago by klaus

  • Host type changed from Mac OS X to all
  • Summary changed from Virtualbox Manager 4.2.6 hangs in Mac OS X ML 64bit to Virtualbox Manager 4.2.6 hangs when certain inaccessible VMs are present

We finally found a way to reproduce. One needs a very special type of inaccessible VM to trigger a rather strange corner case which then leads to the API sending bogus events to the GUI, which re-trigger the strange API corner case. Effectively it's an endless loop in cooperation between the API (VBoxSVC) and the GUI.

Not host OS specific in any way.

comment:18 Changed 15 months ago by klaus

  • Summary changed from Virtualbox Manager 4.2.6 hangs when certain inaccessible VMs are present to Virtualbox Manager 4.2.6 hangs when certain inaccessible VMs are present => fixed in SVN

Fix will be included in the next maintenance release.

comment:19 Changed 15 months ago by frank

 Here is a test build of the upcoming next maintenance release of VirtualBox. Could you test if the bug is really fixed for you? Thank you!

comment:20 Changed 15 months ago by kimus

Hi, I tested with the 4.2.7-83652 and worked fine.

comment:21 Changed 15 months ago by frank

Thanks for the feedback!

comment:22 Changed 14 months ago by frank

  • Status changed from new to closed
  • Resolution set to fixed

Fix is part of VBox 4.2.8.

comment:23 Changed 4 months ago by lu_zero

  • Status changed from closed to reopened
  • Resolution fixed deleted

As for 4.3.4 the problem is still present for device-backed vmdk on macosx

Changed 4 months ago by lu_zero

Apple log

comment:24 Changed 4 months ago by lu_zero

Some backtrace now that I got lldb.

(lldb) thread backtrace all
* thread #1: tid = 0x140355, 0x00007fff8c57ba1a libsystem_kernel.dylib`mach_msg_trap + 10, queue = 'com.apple.main-thread, stop reason = signal SIGSTOP
    frame #0: 0x00007fff8c57ba1a libsystem_kernel.dylib`mach_msg_trap + 10
    frame #1: 0x00007fff8c57ad18 libsystem_kernel.dylib`mach_msg + 64
    frame #2: 0x00007fff8fef05ee IOKit`io_service_open_extended + 147
    frame #3: 0x00007fff8fe9894e IOKit`IOServiceOpen + 45
    frame #4: 0x00007fff8f2c9f50 OpenGL`___lldb_unnamed_function47$$OpenGL + 102
    frame #5: 0x00007fff8f2ca42e OpenGL`cglBadApplicationNotMuxAwareLockDown + 45
    frame #6: 0x00007fff8f2ca575 OpenGL`___lldb_unnamed_function51$$OpenGL + 307
    frame #7: 0x00007fff8f2cd705 OpenGL`___lldb_unnamed_function62$$OpenGL + 2192
    frame #8: 0x00007fff8f2cce0a OpenGL`CGLChoosePixelFormat + 126
    frame #9: 0x00007fff84f5af4b AppKit`createPixelFormat + 53
    frame #10: 0x00007fff84f5aee3 AppKit`-[NSOpenGLPixelFormat initWithAttributes:] + 66
    frame #11: 0x0000000103098736 QtOpenGLVBox`QGLContextPrivate::tryFormat(QGLFormat const&) + 422
    frame #12: 0x0000000103099157 QtOpenGLVBox`QGLContext::chooseMacVisual(GDevice**) + 39
    frame #13: 0x0000000103098cec QtOpenGLVBox`QGLContext::chooseContext(QGLContext const*) + 92
    frame #14: 0x000000010309dabe QtOpenGLVBox`QGLContext::create(QGLContext const*) + 62
    frame #15: 0x0000000103098b88 QtOpenGLVBox`QGLWidget::setContext(QGLContext*, QGLContext const*, bool) + 184
    frame #16: 0x000000010309efb4 QtOpenGLVBox`QGLWidgetPrivate::initContext(QGLContext*, QGLWidget const*) + 132
    frame #17: 0x00000001030993d6 QtOpenGLVBox`QGLWidgetPrivate::init(QGLContext*, QGLWidget const*) + 22
    frame #18: 0x000000010309f648 QtOpenGLVBox`QGLWidget::QGLWidget(QWidget*, QGLWidget const*, QFlags<Qt::WindowType>) + 296
    frame #19: 0x0000000101aa0a24 VirtualBox.dylib`___lldb_unnamed_function20098$$VirtualBox.dylib + 84
    frame #20: 0x0000000101aa6587 VirtualBox.dylib`___lldb_unnamed_function20104$$VirtualBox.dylib + 23
    frame #21: 0x0000000101a967e9 VirtualBox.dylib`___lldb_unnamed_function19917$$VirtualBox.dylib + 25
    frame #22: 0x0000000101882a69 VirtualBox.dylib`___lldb_unnamed_function14277$$VirtualBox.dylib + 9
    frame #23: 0x00000001019aa6d7 VirtualBox.dylib`___lldb_unnamed_function17599$$VirtualBox.dylib + 39
    frame #24: 0x0000000101978368 VirtualBox.dylib`___lldb_unnamed_function17175$$VirtualBox.dylib + 3176
    frame #25: 0x00000001019237b9 VirtualBox.dylib`___lldb_unnamed_function16313$$VirtualBox.dylib + 377
    frame #26: 0x0000000101b2d877 VirtualBox.dylib`___lldb_unnamed_function23328$$VirtualBox.dylib + 311
    frame #27: 0x0000000101fca116 QtCoreVBox`QMetaObject::activate(QObject*, QMetaObject const*, int, void**) + 710
    frame #28: 0x000000010230d6e1 QtGuiVBox`QAction::triggered(bool) + 49
    frame #29: 0x000000010230ea74 QtGuiVBox`QAction::activate(QAction::ActionEvent) + 180
    frame #30: 0x000000010269aa19 QtGuiVBox`QAbstractButtonPrivate::click() + 89
    frame #31: 0x000000010269acb1 QtGuiVBox`QAbstractButton::mouseReleaseEvent(QMouseEvent*) + 113
    frame #32: 0x0000000102767802 QtGuiVBox`QToolButton::mouseReleaseEvent(QMouseEvent*) + 18
    frame #33: 0x000000010236a7f5 QtGuiVBox`QWidget::event(QEvent*) + 2373
    frame #34: 0x0000000102699aa8 QtGuiVBox`QAbstractButton::event(QEvent*) + 40
    frame #35: 0x00000001027698bf QtGuiVBox`QToolButton::event(QEvent*) + 63
    frame #36: 0x00000001023131fd QtGuiVBox`QApplicationPrivate::notify_helper(QObject*, QEvent*) + 189
    frame #37: 0x000000010231c0d0 QtGuiVBox`QApplication::notify(QObject*, QEvent*) + 7776
    frame #38: 0x0000000101fc37cc QtCoreVBox`QCoreApplication::notifyInternal(QObject*, QEvent*) + 124
    frame #39: 0x0000000102313e1c QtGuiVBox`qt_sendSpontaneousEvent(QObject*, QEvent*) + 44
    frame #40: 0x00000001022ca179 QtGuiVBox`qt_mac_handleMouseEvent(void*, void*, QEvent::Type, Qt::MouseButton) + 2265
    frame #41: 0x00000001022ba996 QtGuiVBox`-[QCocoaView mouseUp:] + 22
    frame #42: 0x00007fff84e623f5 AppKit`-[NSWindow sendEvent:] + 781
    frame #43: 0x00000001022c1cac QtGuiVBox`-[QCocoaWindow sendEvent:] + 236
    frame #44: 0x00007fff84e03744 AppKit`-[NSApplication sendEvent:] + 2021
    frame #45: 0x0000000101b1b565 VirtualBox.dylib`___lldb_unnamed_function22629$$VirtualBox.dylib + 133
    frame #46: 0x00007fff84c53a29 AppKit`-[NSApplication run] + 646
    frame #47: 0x00000001022ceff4 QtGuiVBox`QEventDispatcherMac::processEvents(QFlags<QEventLoop::ProcessEventsFlag>) + 1588
    frame #48: 0x000000010209ec14 QtCoreVBox`QEventLoop::processEvents(QFlags<QEventLoop::ProcessEventsFlag>) + 68
    frame #49: 0x000000010209ef34 QtCoreVBox`QEventLoop::exec(QFlags<QEventLoop::ProcessEventsFlag>) + 180
    frame #50: 0x00000001020a055c QtCoreVBox`QCoreApplication::exec() + 188
    frame #51: 0x0000000101813b2f VirtualBox.dylib`TrustedMain + 2655
    frame #52: 0x0000000100001fad VirtualBox`start + 2973
    frame #53: 0x0000000100001444 VirtualBox`start + 52

  thread #2: tid = 0x140367, 0x00007fff8c580662 libsystem_kernel.dylib`kevent64 + 10, queue = 'com.apple.libdispatch-manager
    frame #0: 0x00007fff8c580662 libsystem_kernel.dylib`kevent64 + 10
    frame #1: 0x00007fff85c1143d libdispatch.dylib`_dispatch_mgr_invoke + 239
    frame #2: 0x00007fff85c11152 libdispatch.dylib`_dispatch_mgr_thread + 52

  thread #3: tid = 0x14037a, 0x00007fff8c57f9aa libsystem_kernel.dylib`select$DARWIN_EXTSN + 10, name = 'nspr-1
    frame #0: 0x00007fff8c57f9aa libsystem_kernel.dylib`select$DARWIN_EXTSN + 10
    frame #1: 0x000000010343da6d VBoxXPCOM.dylib`___lldb_unnamed_function5993$$VBoxXPCOM.dylib + 405
    frame #2: 0x00000001034400a9 VBoxXPCOM.dylib`PR_Poll + 841
    frame #3: 0x00000001059b097a VBoxXPCOMIPCC.dylib`___lldb_unnamed_function592$$VBoxXPCOMIPCC.dylib + 146
    frame #4: 0x00000001034444b2 VBoxXPCOM.dylib`___lldb_unnamed_function6067$$VBoxXPCOM.dylib + 149
    frame #5: 0x000000010024666f VBoxRT.dylib`___lldb_unnamed_function9631$$VBoxRT.dylib + 47
    frame #6: 0x00000001002ab265 VBoxRT.dylib`___lldb_unnamed_function10062$$VBoxRT.dylib + 101
    frame #7: 0x00007fff8b4f4899 libsystem_pthread.dylib`_pthread_body + 138
    frame #8: 0x00007fff8b4f472a libsystem_pthread.dylib`_pthread_start + 137
    frame #9: 0x00007fff8b4f8fc9 libsystem_pthread.dylib`thread_start + 13

  thread #4: tid = 0x14037b, 0x00007fff8c57f716 libsystem_kernel.dylib`__psynch_cvwait + 10, name = 'nspr-2
    frame #0: 0x00007fff8c57f716 libsystem_kernel.dylib`__psynch_cvwait + 10
    frame #1: 0x00007fff8b4f6c3b libsystem_pthread.dylib`_pthread_cond_wait + 727
    frame #2: 0x000000010344304b VBoxXPCOM.dylib`PR_WaitCondVar + 107
    frame #3: 0x0000000103443120 VBoxXPCOM.dylib`PR_Wait + 71
    frame #4: 0x00000001059ac882 VBoxXPCOMIPCC.dylib`___lldb_unnamed_function466$$VBoxXPCOMIPCC.dylib + 212
    frame #5: 0x000000010341b567 VBoxXPCOM.dylib`___lldb_unnamed_function5472$$VBoxXPCOM.dylib + 35
    frame #6: 0x00000001034444b2 VBoxXPCOM.dylib`___lldb_unnamed_function6067$$VBoxXPCOM.dylib + 149
    frame #7: 0x000000010024666f VBoxRT.dylib`___lldb_unnamed_function9631$$VBoxRT.dylib + 47
    frame #8: 0x00000001002ab265 VBoxRT.dylib`___lldb_unnamed_function10062$$VBoxRT.dylib + 101
    frame #9: 0x00007fff8b4f4899 libsystem_pthread.dylib`_pthread_body + 138
    frame #10: 0x00007fff8b4f472a libsystem_pthread.dylib`_pthread_start + 137
    frame #11: 0x00007fff8b4f8fc9 libsystem_pthread.dylib`thread_start + 13

  thread #5: tid = 0x1403a6, 0x00007fff8c57ba1a libsystem_kernel.dylib`mach_msg_trap + 10
    frame #0: 0x00007fff8c57ba1a libsystem_kernel.dylib`mach_msg_trap + 10
    frame #1: 0x00007fff8c57ad18 libsystem_kernel.dylib`mach_msg + 64
    frame #2: 0x00007fff8844f315 CoreFoundation`__CFRunLoopServiceMachPort + 181
    frame #3: 0x00007fff8844e939 CoreFoundation`__CFRunLoopRun + 1161
    frame #4: 0x00007fff8844e275 CoreFoundation`CFRunLoopRunSpecific + 309
    frame #5: 0x00007fff84e001ce AppKit`_NSEventThread + 144
    frame #6: 0x00007fff8b4f4899 libsystem_pthread.dylib`_pthread_body + 138
    frame #7: 0x00007fff8b4f472a libsystem_pthread.dylib`_pthread_start + 137
    frame #8: 0x00007fff8b4f8fc9 libsystem_pthread.dylib`thread_start + 13

  thread #6: tid = 0x1405be, 0x00007fff8c57fe6a libsystem_kernel.dylib`__workq_kernreturn + 10
    frame #0: 0x00007fff8c57fe6a libsystem_kernel.dylib`__workq_kernreturn + 10
    frame #1: 0x00007fff8b4f5f08 libsystem_pthread.dylib`_pthread_wqthread + 330
    frame #2: 0x00007fff8b4f8fb9 libsystem_pthread.dylib`start_wqthread + 13
Last edited 4 months ago by frank (previous) (diff)
Note: See TracTickets for help on using tickets.

www.oracle.com
ContactPrivacy policyTerms of Use