VirtualBox

Ticket #1129 (closed defect: fixed)

Opened 6 years ago

Last modified 6 years ago

Several VBoxSDL segfaults, during WindowsXP guest shutdowns, opensuse 10.3 32bit host

Reported by: chris Owned by:
Priority: critical Component: other
Version: VirtualBox 1.5.4 Keywords: sefaults segmentation faults shutdown windowsxp opensuse103
Cc: Guest type: other
Host type: other

Description (last modified by frank) (diff)

Hello, first of all, thanks for your great work.

Problem: VBoxSDL segfaults in about 1 out of 20 runs. Details: Most of the time, the segfaults occure during WindowsXP shutdowns, but very rarely also while working with some program, e.g. web-surfing (latter might be something completely different).

I found no reproducible conditions. Sessions started (most of the time) from same image; changes were written to a new snapshot file. Other versions: The same (or similar) problem (with segfaults during shutdown) was found with VBoxDSL 1.5.2. The "normal" VirtualBox did not show this effect (which might be just a matter of statistics).

Guest: WindowsXP including all patches and much add software (~10GB), guest-additions 1.5.4 installed, shared folders added (but not used)

Host: OpenSUSE 10.3 32 bit including all patches USB-Mount in /etc/fstab (2305=vboxusers) (if it's important at all):

usbfs on /proc/bus/usb type usbfs (rw,devgid=2305,devmode=640)

SGID-vboxusers: VBoxDSL is started with SGID-vboxusers wrapper, which hopefully should not be the problem.

Hardware: Athlon 64 X2 or Pentium 4 (segfaults on both hardware architectures)

(tested on several different computers, so it seems NOT to be a hardware defect)

Binary: virtualbox.org/download/1.5.4/VirtualBox-1.5.4_27034_openSUSE103-1.i586.rpm

Core: Size of core-dump 1.3 GB. After bzip2 ~70MB.

Dont' know, if I should post such large core files on this list. Can you give me instructions, were to put the core files (I have two different ones at the moment - both segfaults at shutdown)

Can you please help? Many Thanks.

VBox.log:

Intrestingly, all VBoxDSL runs *WITHOUT* segfaults show an "ERROR" tag at the end, where in runs *WITH* segfaults, the ERROR line is missing. (This only applies to the shutdown-segfault cases.)

(... many lines cut out ...)
00:02:21.600 ********************* End of statistics **********************
00:02:22.186 Changing the VM state from 'DESTROYING' to 'TERMINATED'.
00:02:22.299 vboxClipboardDestroy: shutting down host clipboard
00:02:22.300 vboxClipboardThread: clipboard thread terminated successfully with return code VINF_SUCCESS
00:02:22.630 ERROR [COM]: aRC=0x8000ffff aIID={09789f63-4525-48e5-a5e4-1080453b0eab} aComponent={Display} aText={The object is not ready} aPreserve=false

Attachments

VBoxSharedClipboard.so Download (108.0 KB) - added by michael 6 years ago.
Updated clipboard handler for VirtualBox 1.5.4, for 32bit Linux hosts with glibc 2.4 or newer

Change History

comment:1 Changed 6 years ago by chris

VBoxDSL is wrong. Sorry. VBoxSDL is correct.

comment:2 Changed 6 years ago by frank

  • Description modified (diff)
  • Summary changed from Several VBoxDSL segfaults, during WindowsXP guest shutdowns, opensuse 10.3 32bit host to Several VBoxSDL segfaults, during WindowsXP guest shutdowns, opensuse 10.3 32bit host

Please could you upload your compressed core dump to  http://www.rapidshare.de?

comment:3 Changed 6 years ago by chris

Both cores are "shutdown-time-cores" (Host: VBoxSDL 1.5.4 32bit OpenSUSE 10.3, Guest: WindowsXP):
1st core:  http://rapidshare.de/files/38430560/core.6543.bz2.html
2nd core:  http://rapidshare.de/files/38430420/core.7751.bz2.html

comment:4 Changed 6 years ago by frank

Thanks for the core dumps. Both dumps refer to the same code position. The problem is related to our clipboard code. We are investigating.

Changed 6 years ago by michael

Updated clipboard handler for VirtualBox 1.5.4, for 32bit Linux hosts with glibc 2.4 or newer

comment:5 Changed 6 years ago by michael

Chris, could you try the updated clipboard library which I have attached? Replace the corresponding file in your VirtualBox installation, after backing it up of course.

comment:6 Changed 6 years ago by chris

It seems, that the new VBoxSharedClipboard.so solved the segfault-problem.

-rwxr-xr-x 1 root root 110547  8. Feb 14:26 /usr/lib/VBoxSharedClipboard.so
-rwxr-xr-x 1 root root  30200  8. Feb 14:26 /usr/lib/VBoxSharedClipboard.so.orig-1.5.4

The problem had some statistical features, but up to now about 150 VBoxSDL starts without any segfault seems promising.

Thanks for your help.

comment:7 Changed 6 years ago by frank

We hope that VirtualBox 1.5.6 fixes your issues. Please could you try this version?

comment:8 Changed 6 years ago by chris

Up to now (one week of using it) VBoxSDL 1.5.6 did not show this segfault again. So I assume, that the problem is fixed now. Many thanks.

comment:9 Changed 6 years ago by frank

  • Status changed from new to closed
  • Resolution set to fixed

Thank you for the response.

Note: See TracTickets for help on using tickets.

www.oracle.com
ContactPrivacy policyTerms of Use