VirtualBox

Ticket #11286 (closed defect: obsolete)

Opened 10 years ago

Last modified 6 years ago

VBox 4.2.4 freezes on host with RT_PREEMPT kernel

Reported by: mako Owned by:
Component: other Version: VirtualBox 4.2.4
Keywords: RT_PREEMPT freeze vboxdrv Cc:
Guest type: other Host type: Linux

Description

Hi all,

I am using a x86 PC using the Linux RT_PREEMPT kernel 3.2.34-rt51. With this setup as host I can not use VirtualBox 4.2.4 as my PC freezes completlely when loading the kernel module "vboxdrv".

With the very same Linux kernel I can work fine using VirtualBox 4.1.18.

Any feedback on this issue is highly welcome!

Thanks a lot

Regards

mako

Change History

comment:1 Changed 10 years ago by frank

Hard to say what the problem is but actually we don't test against such special kernels. I'm running the 'normal' PREEMPT kernel (without RT) and don't see any problem. Perhaps someone with more inside knowledge has an idea.

comment:2 Changed 10 years ago by mako

See als the related ticket #11318

https://www.virtualbox.org/ticket/11318

Even with a non RT_PREEMPT kernel, there is an issue with the locks in vboxdrv.

mako

comment:3 Changed 6 years ago by aeichner

  • Status changed from new to closed
  • Resolution set to obsolete

Please reopen if still relevant with a recent VirtualBox release.

Note: See TracTickets for help on using tickets.

www.oracle.com
ContactPrivacy policyTerms of Use