VirtualBox

Ticket #11182 (closed defect: duplicate)

Opened 10 years ago

Last modified 10 years ago

Nonexistent host networking interface

Reported by: georgeby Owned by:
Component: network Version: VirtualBox 4.2.4
Keywords: Cc:
Guest type: Windows Host type: Windows

Description

The following error message is displayed when restoring a VM from a Saved state:

Failed to open a session for the virtual machine [VM NAME].

Nonexistent host networking interface, name 'Atheros AR8131 PCI-E Gigabit Ethernet Controller (NDIS 6.20) #2' (VERR_INTERNAL_ERROR).

Result Code: E_FAIL (0x80004005)
Component: Console
Interface: IConsole {db7ab4ca-2a3f-4183-9243-c1208da92392}

This occurs when the following is performed:

  1. VM is running fine, and in Bridged networking mode connected to the LAN network interface. This interface is connected to a wireless router
  2. The VM state is saved
  3. Host is put to sleep
  4. Wireless router is unplugged
  5. Host is woken up
  6. A different network device, in this case a network hub is plugged into the LAN
  7. The VM is started again, and the error appears

The workaround is to delete the savestate and start the VM again.

For interest, the VM is Windows 2012 with 8GB RAM, 2 CPUs and apart from Shared Folders there is nothing fancy configured.

This behaviour does occur for all OSs and configurations.

I would assume this has something to do with when a network interface is disabled and enabled again, it adds "#2", "#3" next to it. Note, though that no setting in the Host (in Windows 7) shows that the network interface has been renamed, this appears to be the internal NIC name.

Change History

comment:1 follow-up: ↓ 2 Changed 10 years ago by frank

  • Status changed from new to closed
  • Resolution set to duplicate

Duplicate of #11183.

comment:2 in reply to: ↑ 1 Changed 10 years ago by georgeby

Replying to frank:

Duplicate of #11183.

Thanks - sorry about the duplicate!

Note: See TracTickets for help on using tickets.

www.oracle.com
ContactPrivacy policyTerms of Use