Ticket #11158 (new defect)

Opened 3 years ago

Last modified 12 months ago

VirtualBox crashes on desktop login screen when visiting extension installed

Reported by: ORACLE Owned by:
Priority: critical Component: guest additions
Version: VirtualBox 4.2.4 Keywords:
Cc: Guest type: Linux
Host type: Windows


  1. First I install the gnome-shell, reboot.
  1. Second I install the guest extension, see video "desktop.mp4".
  1. Third I reboot, and then the desktop login screen appears, VirtualBox crashes!

Guestsystem: Ubuntu 12.04 LTS amd64 Host: Windows 7 x64


VBox.log.txt Download (71.1 KB) - added by ORACLE 3 years ago.
VBox2.log Download (59.3 KB) - added by ceztko 18 months ago.

Change History

Changed 3 years ago by ORACLE

comment:1 Changed 3 years ago by ORACLE



  Problemereignisname:	APPCRASH
  Anwendungsname:	VirtualBox.exe
  Anwendungszeitstempel:	508ac1cf
  Fehlermodulname:	atio6axx.dll
  Fehlermodulzeitstempel:	50650498
  Ausnahmecode:	c0000005
  Ausnahmeoffset:	0000000000084045
  Betriebsystemversion:	6.1.7601.
  Gebietsschema-ID:	1031
  Zusatzinformation 1:	6e57
  Zusatzinformation 2:	6e572c4f4fe125ad66efd9002eb445fe
  Zusatzinformation 3:	feab
  Zusatzinformation 4:	feab71c9bbb38fdee5da1cf797294692

Lesen Sie unsere Datenschutzbestimmungen online:

Wenn die Onlinedatenschutzbestimmungen nicht verfügbar sind, lesen Sie unsere Datenschutzbestimmungen offline:
Last edited 3 years ago by ORACLE (previous) (diff)

comment:2 follow-up: ↓ 3 Changed 3 years ago by frank

Looks 3D-related. I assume this does not happen if you disable 3D for this VM.

comment:3 in reply to: ↑ 2 Changed 3 years ago by ORACLE

Replying to frank:

Looks 3D-related. I assume this does not happen if you disable 3D for this VM.

Indeed. If I disable 3D, the crash does not happen!

XFX Radeon HD 6870 Black Edition:

Treiber-Paketversion	9.002-120928m-148276C-ATI
Catalyst-Version	12.10
Anbieter	Advanced Micro Devices, Inc.
2D-Treiberpfad	/REGISTRY/MACHINE/SYSTEM/ControlSet001/Control/CLASS/{4D36E968-E325-11CE-BFC1-08002BE10318}/0000
Catalyst Control Center-Version	2012.0928.1532.26058

Changed 18 months ago by ceztko

comment:4 Changed 18 months ago by ceztko

Reproduced a very similar bug with VirtualBox-4.2.24-92790 and VirtualBox 4.3.12-93733, Windows 8.1 Update 1 x64 host and Ubuntu 13.10 guest: VirtualBox.exe crashes as soon as the X server starts.

With 3D disabled it doesn't crash.

It seems related to the fact I use the host system (Windows 8.1) in a Remote Desktop session. Tomorrow I can tell if VirtualBox crashes also on a regular non-RDP session on the physical host.

Latest known working VirtualBox version: the guest used to work correctly with VirtualBox-4.2.22, both using the host in regular and RDP sessions. I don't known if it may be related to windows updates.

Attached VBox2.log.

Crash dump here:

comment:5 Changed 18 months ago by ceztko

Forgot to say: the crash dump is taken with VirtualBox 4.3.12-93733. Latest guest addition tools are installed on the guest (I managed to install them the on recovery console).

comment:6 Changed 18 months ago by ceztko

I can confirm 2 things:

1) My bug is indeed a regression. Removing guest additions tools, uninstalling 4.3.12, reinstalling 4.2.22 and installing tools from that version with 3D enabled does not crash. It seems related to something happened between 4.2.22 and 4.2.24.

2) this is only related to running the guest with 3D enabled in a native RDP session with the host. Running the host in a normal session is ok.

Should I open a new bug?

Last edited 18 months ago by ceztko (previous) (diff)

comment:7 Changed 13 months ago by kimi

Thank you. Having some time to start VBox from RDP, I may know - indeed since versions you mention - the same problem. Reading your ticket I've tried to upgrade to last VBox version and got a "file in use" issue. I killed some "Virtual Box Service" process to do the upgrade and it is working now. Now I'm believing that killing W7 service may be helpfull with this.

comment:8 Changed 12 months ago by ceztko

@kimi: I just tried to upgrade VBox to 4.3.20 ensuring there were no leftover vbox processes. Also, in the mean time I upgraded my ubuntu installation from 13.10 to 14.04. With the new variable combination I wasn't able to reproduce the crash anymore. I don't remember having had "file in use" issues in the past when I was observing the crash, but of course that may be the reason. I just hope the installer is properly shutting down VBox prior updating or register the update for the next reboot. Do you remember what file was in use?

Note: See TracTickets for help on using tickets.
ContactPrivacy policyTerms of Use