VirtualBox

Ticket #11159 (new defect)

Opened 3 years ago

Last modified 3 years ago

windows 8 as guest to windows 7 VM box installs fails

Reported by: mikb76 Owned by:
Priority: major Component: other
Version: VirtualBox 4.2.4 Keywords: NX bit not setting in guest
Cc: Guest type: Windows
Host type: Windows

Description

I am using VM box 4.2.4 r81684 under windows 7 Pro Processor setting is for NX bit to be set. Running Microsofts "Windows 8 upgrade assistant" on W7 host shows the NX bit is set i.e. turned on in the bios. The VM box has windows 7 Premium installed which is working ok. Running Microsofts "Windows 8 upgrade assistant" in the guest box under W7 Premium shows that NX bit is not set. This means that when I try to install windows 8 Pro it fails after loading all the stuff from dvd and the key is accepted. windows 8 will not install unless the NX bit is set.

Attachments

w8pro-2012-11-05-09-43-02.log Download (81.7 KB) - added by mikb76 3 years ago.
VBox.log.3 Download (81.8 KB) - added by Grayghost 3 years ago.
Grayghost log file windows 8 attempt to install
VBox.log Download (78.2 KB) - added by Grayghost 3 years ago.
this was an attempt to boot the window 8 update disk
VBox.2.log Download (80.6 KB) - added by Grayghost 3 years ago.
this is with PAE enabled trying to boot a attached .iso file of windows 8 update

Change History

Changed 3 years ago by mikb76

comment:1 Changed 3 years ago by Perryg

I don't believe the 4400 series of the Intel Core 2 supports Hardware Virtualization.

comment:2 Changed 3 years ago by Grayghost

I have the same problem .... can't install or update to windows 8 . Windows 7 work fine ... windows 8 will not update ... goes through complete install then will not boot and reverts back to windows 7.

I have added two log files ... the DVD will sometimes boot and go through the install and sometimes it will not boot ... when I attache window8.iso file will never boot .. it will hang or sometime it will end with a block of error and the instruction to turn off the power switch the second log file it just hung untill I powered off.

Last edited 3 years ago by Grayghost (previous) (diff)

comment:3 Changed 3 years ago by frank

mikb76, as correctly stated by Perry, your CPU does not support VT-x. And in non-VT-x mode, the PAE mode does not work correctly IIRC. Grayhost, please attach a VBox.log file of your VM session, it sounds like you have the same problem.

Changed 3 years ago by Grayghost

Grayghost log file windows 8 attempt to install

Changed 3 years ago by Grayghost

this was an attempt to boot the window 8 update disk

comment:4 Changed 3 years ago by mikb76

Hi Looking at the vbox logs one can see that the host has NX=1 and guest NX=0 hence windows 8 will not install as a guest. The check box in VM is ticked for NX bit. Surely this is a bug!

comment:5 Changed 3 years ago by mikb76

Hi Opps, Ive just googled VT-x. So its a new mother for me then! and while Iam at it add another hard drive. By the way the bi-directional clipboard feature from w7 guest to w7 host does not work. Must look into dual boot scenario.

comment:6 follow-up: ↓ 7 Changed 3 years ago by frank

Grayghost, in your case it looks like you didn't enable 'PAE' in the VM settings. Please do and try again.

comment:7 in reply to: ↑ 6 Changed 3 years ago by Grayghost

Replying to frank:

I did enable PAE ... and still will not boot I will add another log. I also tried to boot a DVD ... and it will not boot.

I have tried it in both Suse 12.2 and Mint LMDE hosts .. same results in both.

Why would PAE not be enabled when you set up a new guest with windows 8 selected as the guest ? I would think that it should be set to run windows 8.

I am beginning to think windows 8 (final release) was designed not to work in a virtual machine. I know many people are running the trial version.

Last edited 3 years ago by Grayghost (previous) (diff)

Changed 3 years ago by Grayghost

this is with PAE enabled trying to boot a attached .iso file of windows 8 update

comment:8 Changed 3 years ago by frank

Grayghost, I don't see any problem in your log file and yes, PAE is indeed enabled. What does exactly happen when you try to boot Windows 8 now?

comment:9 Changed 3 years ago by Grayghost

I get a black screen with a "window" on it and an infinate hang ...or an error message to reboot. This is the same with host of Suse or Mint LMDE ... so it must be my HP laptop. I have also install a modified bios. ... same results.

Note: See TracTickets for help on using tickets.

www.oracle.com
ContactPrivacy policyTerms of Use