VirtualBox

Ticket #11112 (closed defect: fixed)

Opened 18 months ago

Last modified 6 months ago

unable to play a FPS game which was playable with 4.2.0-80737

Reported by: courier Owned by:
Priority: major Component: 3D support
Version: VirtualBox 4.2.2 Keywords:
Cc: Guest type: Windows
Host type: Linux

Description

I was able to play Battlefield 1942 with version 4.2.0-80737. (insall guest addition in safemode. turn off mouse integration. host has a nvidia card)

This week I upgraded both vbox to version 4.2.2-81494 and installed the new guest addition in the windows xp guest. Then the game could still successfully go through menu selecting part. But just after the first 3D frame (or couple of 3D frames) got drawn, the game segfault.

I downgrade vbox to version 4.2.0-80737, install the old guest edition, and can play the game again. I take an extra step by just upgrading vbox but leaving the old guest addtion untouched. Under this combination I can still play the game.

So it seems the new guest addition has problem with 3D support.

Change History

comment:1 Changed 15 months ago by misha

This is most likely a duplicate of #11369.
Please give a try to the test build of VBox Guest Additions posted here: https://www.virtualbox.org/ticket/11369#comment:3 and let me know if it solves your crash problem.
Please use it with VBox 4.2.6 host installation.

comment:2 Changed 6 months ago by misha

  • Status changed from new to closed
  • Resolution set to fixed

No response, closing. Please try VBox 4.3 and 4.3 Additions and re-open if needed.

Note: See TracTickets for help on using tickets.

www.oracle.com
ContactPrivacy policyTerms of Use