VirtualBox

Opened 12 years ago

Closed 11 years ago

#11036 closed defect (fixed)

guest additions do not build with 3.7 kernel

Reported by: Andre Robatino Owned by:
Component: other Version: VirtualBox 4.2.0
Keywords: Cc:
Guest type: Linux Host type: all

Description

Fedora Rawhide just got the 3.7.0-0.rc0.git2.4.fc19 kernel. Guest additions fail to build on my Rawhide guest:

Error! Bad return status for module build on kernel: 3.7.0-0.rc0.git2.4.fc19.x86_64 (x86_64) Consult /var/lib/dkms/vboxguest/4.2.0/build/make.log for more information.

Attaching the above file along with VBox.log.

Attachments (7)

make.log (1.4 KB ) - added by Andre Robatino 12 years ago.
VBox.log (85.3 KB ) - added by Andre Robatino 12 years ago.
vboxadd-install.log (3.9 KB ) - added by Andre Robatino 11 years ago.
/var/log/vboxadd-install.log
make.2.log (1.4 KB ) - added by Andre Robatino 11 years ago.
/var/lib/dkms/vboxguest/4.2.2/build/make.log
VBox.2.log (83.8 KB ) - added by Andre Robatino 11 years ago.
make.3.log (1.3 KB ) - added by Andre Robatino 11 years ago.
/var/lib/dkms/vboxguest/4.2.6/build/make.log
make.4.log (1.1 KB ) - added by Andre Robatino 11 years ago.
/var/lib/dkms/vboxguest/4.2.6/build/make.log

Download all attachments as: .zip

Change History (28)

by Andre Robatino, 12 years ago

Attachment: make.log added

by Andre Robatino, 12 years ago

Attachment: VBox.log added

comment:1 by Andre Robatino, 11 years ago

Still having trouble with VirtualBox 4.2.2:

[root@localhost VBOXADDITIONS_4.2.2_81494]# ./VBoxLinuxAdditions.run 
Verifying archive integrity... All good.
Uncompressing VirtualBox 4.2.2 Guest Additions for Linux..........
VirtualBox Guest Additions installer
Removing installed version 4.2.0 of VirtualBox Guest Additions...
Removing existing VirtualBox DKMS kernel modules           [  OK  ]
Removing existing VirtualBox non-DKMS kernel modules       [  OK  ]
Building the VirtualBox Guest Additions kernel modules
Building the main Guest Additions module                   [FAILED]
(Look at /var/log/vboxadd-install.log to find out what went wrong)
Doing non-kernel setup of the Guest Additions              [  OK  ]
Installing the Window System drivers
Installing X.Org Server 1.13 modules                       [  OK  ]
Setting up the Window System to use the Guest Additions    [  OK  ]
You may need to restart the hal service and the Window System (or just restart
the guest system) to enable the Guest Additions.

Installing graphics libraries and desktop services components/etc/init.d/vboxadd-x11: line 275:  4418 Segmentation fault      (core dumped) semanage fcontext -a -t unconfined_execmem_exec_t '/usr/bin/VBoxClient' > /dev/null 2>&1
                                                           [  OK  ]
[root@localhost VBOXADDITIONS_4.2.2_81494]#

Attaching /var/log/vboxadd-install.log, /var/lib/dkms/vboxguest/4.2.2/build/make.log (referenced in vboxadd-install.log), and VBox.log.

by Andre Robatino, 11 years ago

Attachment: vboxadd-install.log added

/var/log/vboxadd-install.log

by Andre Robatino, 11 years ago

Attachment: make.2.log added

/var/lib/dkms/vboxguest/4.2.2/build/make.log

by Andre Robatino, 11 years ago

Attachment: VBox.2.log added

comment:2 by Andre Robatino, 11 years ago

After upgrading to VirtualBox 4.2.4, I decided to retest, even though I saw nothing about 3.7 kernel fixes in the Changelog. I have 3 kernels installed:

kernel-3.7.0-0.rc1.git1.1.fc19.x86_64
kernel-3.7.0-0.rc2.git2.1.fc19.x86_64
kernel-3.7.0-0.rc2.git3.1.fc19.x86_64

I found that when attempting to use VBoxLinuxAdditions.run, the build fails on the first two kernels, but succeeds on the third (and "dkms status" shows the expected output for a full successful build). I will continue to check if later kernel modules build successfully as well.

Last edited 11 years ago by Andre Robatino (previous) (diff)

comment:3 by Andre Robatino, 11 years ago

Guest additions build successfully for the next kernel (3.7.0-0.rc2.git4.2.fc19.x86_64) as well. Is this expected to be fixed?

comment:4 by Frank Mehnert, 11 years ago

Resolution: fixed
Status: newclosed

Might be more a question for the Fedora guys. The Linux modules of VBox 4.2.4 should build fine with Linux 3.7. Please reopen if still relevant.

comment:5 by zdavatz, 11 years ago

Resolution: fixed
Status: closedreopened

They do not build for me. I am on Gentoo Linux 3.7.0 and I get the following error:

/vbox.0/vboxdrv/ -I/tmp/vbox.0/vboxdrv/include -I/tmp/vbox.0/vboxdrv/r0drv/linux -D__KERNEL__ -DMODULE -DRT_OS_LINUX -DIN_RING0 -DIN_RT_R0 -DIN_SUP_R0 -DVBOX -DRT_WITH_VBOX -DVBOX_WITH_HARDENING -DCONFIG_VBOXDRV_AS_MISC -DRT_ARCH_AMD64 -DVBOX_WITH_64_BITS_GUESTS  -DMODULE  -D"KBUILD_STR(s)=#s" -D"KBUILD_BASENAME=KBUILD_STR(memobj_r0drv_linux)"  -D"KBUILD_MODNAME=KBUILD_STR(vboxdrv)" -c -o /tmp/vbox.0/r0drv/linux/memobj-r0drv-linux.o /tmp/vbox.0/r0drv/linux/memobj-r0drv-linux.c
/tmp/vbox.0/r0drv/linux/memobj-r0drv-linux.c: In Funktion »rtR0MemObjNativeMapUser«:
/tmp/vbox.0/r0drv/linux/memobj-r0drv-linux.c:1465:38: Fehler: »VM_RESERVED« nicht deklariert (erste Benutzung in dieser Funktion)
/tmp/vbox.0/r0drv/linux/memobj-r0drv-linux.c:1465:38: Anmerkung: jeder nicht deklarierte Bezeichner wird nur einmal für jede Funktion, in der er vorkommt, gemeldet
make[2]: *** [/tmp/vbox.0/r0drv/linux/memobj-r0drv-linux.o] Fehler 1
make[1]: *** [_module_/tmp/vbox.0] Fehler 2
make: *** [vboxdrv] Fehler 2

when I do

sudo /etc/init.d/vboxdrv setup

this worked fine for Kernel 3.6.0

uname -a 

Linux zenogentoo 3.7.0 #21 SMP Thu Dec 13 16:51:05 CET 2012 x86_64 Intel(R) Core(TM) i7 CPU 960 @ 3.20GHz GenuineIntel GNU/Linux

Best Zeno

Last edited 11 years ago by Frank Mehnert (previous) (diff)

comment:6 by Frank Mehnert, 11 years ago

You forgot to add an important information: Which VirtualBox version is that?

comment:7 by zdavatz, 11 years ago

Sorry!

It is: Version 4.2.4 r81684

Best Zeno

comment:8 by Frank Mehnert, 11 years ago

In that case I would like to see the preprocessed file. When you compile the kernel driver with 'V=1', the command line is written to the terminal. Copy and paste the command and replace '-c' with '-E -dD' and replace '-o <object>.o' with '<object>.i'. Please attach the compressed resulting <object>.i file to this ticket.

comment:9 by zdavatz, 11 years ago

I do not understand what you mean. I do the following:

sudo /etc/init.d/vboxdrv setup

and then I copied the last lines from

/var/log/vbox-install.log

Do I have to check some kernel options? I build the Kernel with

sudo make silentoldconfig

Normally I just rebuild the VirtualBox driver with:

sudo /etc/init.d/vboxdrv setup

Best Zeno

comment:10 by Frank Mehnert, 11 years ago

Please do the following:

  1. Go to /usr/src/vboxguest-4.2.4
  2. Do
    make V=1
    
  3. Copy and paste the last failing command
  4. Replace '-c' by '-E -dD' and '-o <object>.o' with '-o <object>.i'
  5. Execute the changed command, compress the resulting <object>.i and attach it to this ticket.

comment:11 by zdavatz, 11 years ago

Sorry, I do not have the following directories

/usr/src/vboxguest-4.2.4 /usr/src/vboxguest

I install VirtualBox by downloading the installer from

https://www.virtualbox.org/wiki/Linux_Downloads

I just tried with the newest version 4.2.6 and the problem is still there:

rv)" -c -o /tmp/vbox.0/r0drv/linux/memobj-r0drv-linux.o /tmp/vbox.0/r0drv/linux/memobj-r0drv-linux.c
/tmp/vbox.0/r0drv/linux/memobj-r0drv-linux.c: In Funktion »rtR0MemObjNativeMapUser«:
/tmp/vbox.0/r0drv/linux/memobj-r0drv-linux.c:1465:38: Fehler: »VM_RESERVED« nicht deklariert (erste Benutzung in dieser Funktion)
/tmp/vbox.0/r0drv/linux/memobj-r0drv-linux.c:1465:38: Anmerkung: jeder nicht deklarierte Bezeichner wird nur einmal für jede Funktion, in der er vorkommt, gemeldet
make[2]: *** [/tmp/vbox.0/r0drv/linux/memobj-r0drv-linux.o] Fehler 1
make[1]: *** [_module_/tmp/vbox.0] Fehler 2
make: *** [vboxdrv] Fehler 2

My VirtualBox installation is in /opt/VirtualBox

ls

/opt/VirtualBox> ls

LICENSE                VBoxEFI32.fd            VBoxPython2_4.so        VBoxXPCOMC.so          nls
UserManual.pdf         VBoxEFI64.fd            VBoxPython2_5.so        VBoxXPCOMIPCD          rdesktop-vrdp
VBox.png               VBoxExtPackHelperApp    VBoxPython2_6.so        VMMGC.gc               rdesktop-vrdp-keymaps
VBox.sh                VBoxGuestControlSvc.so  VBoxPython2_7.so        VMMR0.r0               rdesktop-vrdp.tar.gz
VBoxAuth.so            VBoxGuestPropSvc.so     VBoxREM.so              VirtualBox             routines.sh
VBoxAuthSimple.so      VBoxHeadless            VBoxRT.so               VirtualBox.chm         scripts
VBoxAutostart          VBoxHeadless.so         VBoxSDL                 VirtualBox.so          sdk
VBoxBalloonCtrl        VBoxHostChannel.so      VBoxSDL.so              accessible             src
VBoxCreateUSBNode.sh   VBoxKeyboard.so         VBoxSVC                 additions              uninstall.sh
VBoxDD.so              VBoxManage              VBoxSharedClipboard.so  components             vboxshell.py
VBoxDD2.so             VBoxNetAdpCtl           VBoxSharedCrOpenGL.so   helpers                vboxwebsrv
VBoxDD2GC.gc           VBoxNetDHCP             VBoxSharedFolders.so    icons                  virtualbox.desktop
VBoxDD2R0.r0           VBoxNetDHCP.so          VBoxSysInfo.sh          kchmviewer             virtualbox.xml
VBoxDDGC.gc            VBoxOGLhostcrutil.so    VBoxTestOGL             libQtCoreVBox.so.4     webtest
VBoxDDR0.r0            VBoxOGLhosterrorspu.so  VBoxTunctl              libQtGuiVBox.so.4
VBoxDDU.so             VBoxOGLrenderspu.so     VBoxVMM.so              libQtNetworkVBox.so.4
VBoxDbg.so             VBoxPython.so           VBoxVolInfo             libQtOpenGLVBox.so.4
VBoxDragAndDropSvc.so  VBoxPython2_3.so        VBoxXPCOM.so            libvboxjxpcom.so

Best Zeno

comment:12 by Andre Robatino, 11 years ago

kernel-3.7.1-2.fc18 was just pushed to Fedora 18 updates-testing. The guest additions don't build, even though they were building on Rawhide (although Rawhide currently only has kernel-3.7.0, and there hasn't been a new Rawhide kernel for a while). I will attach the indicated file.

[root@localhost ~]# dkms install vboxguest/4.2.6 -k 3.7.1-2.fc18.x86_64

Kernel preparation unnecessary for this kernel.  Skipping...

Building module:
cleaning build area....
make KERNELRELEASE=3.7.1-2.fc18.x86_64 -C /lib/modules/3.7.1-2.fc18.x86_64/build M=/var/lib/dkms/vboxguest/4.2.6/build....(bad exit status: 2)
Error! Bad return status for module build on kernel: 3.7.1-2.fc18.x86_64 (x86_64)
Consult /var/lib/dkms/vboxguest/4.2.6/build/make.log for more information.
[root@localhost ~]#

by Andre Robatino, 11 years ago

Attachment: make.3.log added

/var/lib/dkms/vboxguest/4.2.6/build/make.log

comment:13 by Andre Robatino, 11 years ago

My latest problem may be due to this bug:

3.7.1-2.fc18 - include/linux/version.h prevents kernel modules compiling https://bugzilla.redhat.com/show_bug.cgi?id=892373

I'll test the next hopefully fixed one and report back.

comment:14 by Andre Robatino, 11 years ago

Once I delete the empty file /usr/src/kernels/3.7.1-2.fc18.x86_64/include/linux/version.h referred to in the bug report, the guest additions compile for that kernel.

comment:15 by zdavatz, 11 years ago

Yes, thank you Robatino this solved it for me as well!

mv /usr/src/linux/include/linux/version.h /tmp/

something strange seems to have happened because of the header file...

Best Zeno

comment:16 by Frank Mehnert, 11 years ago

I saw the same problem on a Linux tree of an ArchLinux user.

comment:17 by Andre Robatino, 11 years ago

Trouble with the latest Fedora Rawhide 3.8 kernel:

[root@localhost ~]# dkms install vboxguest/4.2.6 -k 3.8.0-0.rc4.git1.1.fc19.x86_64

Kernel preparation unnecessary for this kernel.  Skipping...

Building module:
cleaning build area....
make KERNELRELEASE=3.8.0-0.rc4.git1.1.fc19.x86_64 -C /lib/modules/3.8.0-0.rc4.git1.1.fc19.x86_64/build M=/var/lib/dkms/vboxguest/4.2.6/build....(bad exit status: 2)
Error! Bad return status for module build on kernel: 3.8.0-0.rc4.git1.1.fc19.x86_64 (x86_64)
Consult /var/lib/dkms/vboxguest/4.2.6/build/make.log for more information.
[root@localhost ~]#

Attaching the indicated file.

by Andre Robatino, 11 years ago

Attachment: make.4.log added

/var/lib/dkms/vboxguest/4.2.6/build/make.log

comment:18 by Andre Robatino, 11 years ago

Also see https://forums.virtualbox.org/viewtopic.php?f=3&t=53708 . It appears to be the same issue.

comment:19 by Frank Mehnert, 11 years ago

r44317 fixes the compile problem with Linux 3.8-rc4.

comment:20 by Andre Robatino, 11 years ago

VirtualBox 4.2.8 builds guest additions for 3.8 and earlier kernels, but not for 3.9. Opened https://www.virtualbox.org/ticket/11529 for 3.9.

comment:21 by Frank Mehnert, 11 years ago

Resolution: fixed
Status: reopenedclosed
Note: See TracTickets for help on using tickets.

© 2023 Oracle
ContactPrivacy policyTerms of Use