VirtualBox

Ticket #11037 (closed defect: duplicate)

Opened 19 months ago

Last modified 19 months ago

32-bit guest additions incompatible with 64-bit kernel

Reported by: Tails developers Owned by:
Priority: major Component: guest additions
Version: VirtualBox 4.2.0 Keywords:
Cc: Guest type: Linux
Host type: all

Description

Most Linux distributions support running a 32-bit userland with an amd64 kernel. Unfortunately, VirtualBox Guest Additions choke on such environment.

The kernel output messages like the following:

[   24.433817] ioctl32(VBoxService:1934): Unknown cmd fd(3) cmd(c08c5610){t:'V';sz:140} arg(ffd3e804) on /dev/vboxguest

And a bunch of others from Xorg.

This could look like a niche problem, but Tails is a live system and for maximum compatibility we ship a 32-bit userland. Shipping a 32-bit kernel (for older computers) and a 64-bit kernel for newer systems is a good compatibility/memory access compromise. Unfortunately, we also advertise VirtualBox support and thus this bug currently prevents us from shipping a 64-bit kernel.

Change History

comment:1 Changed 19 months ago by Tails developers

Actually this looks like a duplicate of #8336. The later is unfortunately not assigned to guest additions as its component which is why we had not found it in the first place.

comment:2 Changed 19 months ago by frank

  • Status changed from new to closed
  • Resolution set to duplicate
Note: See TracTickets for help on using tickets.

www.oracle.com
ContactPrivacy policyTerms of Use