VirtualBox

Ticket #10906 (closed defect: duplicate)

Opened 20 months ago

Last modified 19 months ago

Unable to upgrade Extension Pack

Reported by: mkucharski Owned by:
Priority: major Component: other
Version: VirtualBox 4.1.22 Keywords:
Cc: Guest type: all
Host type: Windows

Description

Running VirtualBox 4.1.22 r80657. Navigating to Help -> Check for Updates -> You are already running the most recent version of Virtual Box -> OK -> You have an old version (4.1.18) of the Oracle VM VirtualBox Extension Pack installed. Do you wish to download latest one from the Internet? -> Download -> Are you sure you want... -> Download -> Do you wish to install this extension pack? -> Install -> An older version of the extension pack is already installed, would you like to upgrade?

Name: Oracle VM VirtualBox Extension Pack
New Version: 4.1.22r80657
Current Version: 4.1.18r78361
Description: USB 2.0 Host Controller, VirtualBox RDP, PXE ROM with E1000 support.

-> Upgrade -> PUEL -> I Agree -> Error:

Failed to install the Extension Pack C:/Users/mkucharski/.VirtualBox/Oracle_VM_VirtualBox_Extension_Pack-4.1.22.vbox-extpack.

The installer failed with exit code 1: VBoxExtPackHelperApp.exe: error: Failed to rename the extension pack directory: VERR_ALREADY_EXISTS

rcExit=1.

Result Code: E_FAIL (0x80004005)
Component: ExtPackManager
Interface: IExtPackManager {3295e6ce-b051-47b2-9514-2c588bfe7554}

Change History

comment:1 Changed 20 months ago by mkucharski

This issue was happening for ma also on VirtualBox 4.1.20

comment:2 Changed 20 months ago by mkucharski

Host OS: Windows 7 SP1 64-bit.

comment:3 Changed 20 months ago by frank

What is the type of the partition of C:? NTFS or FAT or anything else? I assume your VirtualBox application installed in 'C:\Program Files\Oracle\VirtualBox'. The extension pack is installed into the 'ExtensionPacks' directory within the applications directory. Does that directory have any special permissions or is it located on an external drive or something like that?

comment:4 Changed 19 months ago by mkucharski

Drive has one NTFS partition. I didn't change destination path during installation and VirtualBox is installed under:

c:\Program Files\Oracle\VirtualBox\

I had other issues with VB after upgrade to 4.1.22, so I've decided to uninstall everything, remove extensions by hand (no uninstall option, from VB installer?) from above location and install 4.1.22 again.

All works now, however I didn't install extensions again, as I don't need them anymore.

comment:5 Changed 19 months ago by frank

  • Status changed from new to closed
  • Resolution set to duplicate

Closing as duplicate as there are other reports. Actually it looks like the directory where the extension pack was stored is not writable by the Administrator.

comment:6 Changed 19 months ago by odupuy

Exactly the same issue for me today. I have first upgraded my Oracle VM BOX to 4.1.22.r80657 on my W7 Pro 32 bits. I am logged as a user with admin rights. Then once installed and when I started it, I had the message about the possible upgrade of the extension pack. I asked to get it and I had the same errors. After multiple tries, I have stopped Oracle VM Box. I have found the folders "C:\Program Files\Oracle\VirtualBox\ExtensionPacks\Oracle_VM_VirtualBox_Extension_Pack" "C:\Program Files\Oracle\VirtualBox\ExtensionPacks\Oracle_VM_VirtualBox_Extension_Pack - Uninst" (or something like this). I have renamed the second one and retried the update. This time it worked. Then I have deleted the old folder.

There is obviously a flaw in the installer. If the uninst folder exist, it should delete it. I suspect that after the upload it tries rename the main folder to uninst, does its install then if everything is fine delete the uninst folder. If the install fails, uninst become what is was as this is the solution to rollback to a good state. With uninst present before the upgrade and not deleted, everything fails.

comment:7 Changed 19 months ago by frank

Let's continue the discussion in #9269.

Note: See TracTickets for help on using tickets.

www.oracle.com
ContactPrivacy policyTerms of Use