VirtualBox

Ticket #9269 (new defect)

Opened 3 years ago

Last modified 6 months ago

Win7: Update Extension Pack 4.0.6 -> 4.1.0 failed, 0x80004005, VERR_ALREADY_EXIST

Reported by: fe02krma Owned by:
Priority: major Component: other
Version: VirtualBox 4.1.0 Keywords: Extension Pack
Cc: Guest type: other
Host type: Windows

Description

Hello,

I´ve got the following error after updating from VirtualBox 4.0.10 to 4.1.0:

If I try to update the Extension pack to current version 4.1.0 the update starts, but then it fails with the following error:

"Failed to install the Extension Pack" The installer failed with exit code 1: VBoxExtPackHelperApp.exe: error: Failed to rename the extension pack directory: VERR_ALREADY_EXIST

rcExit=1

Details

Result Code: E_FAIL (0x80004005)

Component: ExtPackManager

Interface: IExtPackManager {3295e6ce-b051-47b2-9514-2c588bfe7554}

See attached screenshots (s1, s2).

The old Extension pack can also not be uninstalled; while i tried to remove it a similar error occures (see screenshot s3)

Further informations about used versions:

Host: Windows 7 Professional 32bit SP1

Previous Version:

VirtualBox-4.0.10-72479-Win.exe

+ Extension Pack 4.0.6 (because it was not updated before)

Current Version:

VirtualBox-4.1.0-73009-Win.exe

+ Oracle_VM_VirtualBox_Extension_Pack-4.1.0-73009.vbox-extpack

Attachments

s1.jpg Download (136.8 KB) - added by fe02krma 3 years ago.
screenshot 1
s2.jpg Download (163.2 KB) - added by fe02krma 3 years ago.
screenshot 2
s3.jpg Download (40.3 KB) - added by fe02krma 3 years ago.
screenshot 3

Change History

Changed 3 years ago by fe02krma

screenshot 1

Changed 3 years ago by fe02krma

screenshot 2

Changed 3 years ago by fe02krma

screenshot 3

comment:1 Changed 3 years ago by fe02krma

Info:

After renaming the folder

C:\Program Files\Oracle\VirtualBox\ExtensionPacks to \ExtensionPacks.sik

and restarting the application the list of installed extension packs was empty.

Now i could install the extension pack for version 4.1.0 correctly :-)

comment:2 Changed 3 years ago by titantux

workaround works!!! even for 64 bits versions :)

comment:3 Changed 2 years ago by pikolo

I've encountered that same error VERR_ALREADY_EXISTS when try to uninstall extension pack of version 4.0.1 while Virtual Box version is 4.1.8
The work around was to delete the folder:

C:\Program Files\Oracle\VirtualBox\ExtensionPacks\Oracle_VM_VirtualBox_Extension_Pack-_-uninst

After that all went well, uninstall and install the new extension pack of version 4.1.8.

Host OS: Windows 7 32 bit.
 See this thread for more info

comment:4 Changed 2 years ago by frank

Great finding. Though I still don't know why the old _-uninst directory isn't correctly deleted. This works here, I've tried to reproduce this on a Windows 7 host.

comment:5 Changed 19 months ago by odupuy

See my comments in https://www.virtualbox.org/ticket/10906#comment:6

You may have an "Oracle_VM_VirtualBox_Extension_Pack - uninst" directory present in which case the installer cannot rename the existing "Oracle_VM_VirtualBox_Extension_Pack" to it. Delete/rename the uninst folder and retry. Have admin in rights to do it.

The installer should take care of this.

comment:6 Changed 6 months ago by tiandrey

Still not fixed. VirtualBox 4.3.0, Win64.

Note: See TracTickets for help on using tickets.

www.oracle.com
ContactPrivacy policyTerms of Use