VirtualBox

Ticket #10872 (reopened defect)

Opened 3 years ago

Last modified 9 months ago

Cannot open virtual machine (VERR_LDR_MISMATCH_NATIVE)

Reported by: pjhriz Owned by:
Priority: major Component: other
Version: VirtualBox 4.1.20 Keywords:
Cc: Guest type: Linux
Host type: Windows

Description

host = win7 Updated to 4.1.20 yesterday - everything worked

went in this morning - got

Failed to open a session for the virtual machine lbox.

Failed to load VMMR0.r0 (VERR_LDR_MISMATCH_NATIVE).

Result Code: E_FAIL (0x80004005) Component: Console Interface: IConsole {1968b7d3-e3bf-4ceb-99e0-cb7c913317bb}

had similar issue with 4.1.18 and reverted to 4.1.16

same issue with win server guest

Attachments

lbox-2012-08-30-08-45-03.log Download (1.1 KB) - added by pjhriz 3 years ago.
DMGS_LOGS.zip Download (43.6 KB) - added by DorianS 9 months ago.
Logs of VM fatal error

Change History

Changed 3 years ago by pjhriz

comment:1 Changed 3 years ago by frank

  • Summary changed from cannot open virtual machine to Cannot open virtual machine (VERR_LDR_MISMATCH_NATIVE)

comment:2 Changed 3 years ago by frank

Two ideas: The VirtualBox installation could be corrupted, for instance, the VMMR0.r0 file could be corrupt. Could you try if a complete uninstall + re-install would solve your problem? The other idea: Is that some kind of Windows server where several instances of VirtualBox on different accounts? Is there any other VM running, perhaps from a different VirtualBox release?

comment:3 Changed 2 years ago by frank

  • Status changed from new to closed
  • Resolution set to worksforme

No response, closing.

comment:4 Changed 19 months ago by Caemyr

  • Status changed from closed to reopened
  • Resolution worksforme deleted

I have the same issue on Win7 x64, with VBox 4.2.14. I tried uninstall/cleanup/reinstall, as well as uninstall and installing VBox 4.2.18. There are no other VBox versions running, this is also a single-user at a time, so there are no other users running VMs at a time. VMMR0.r0 file has md5 hash: b3d87036cbbca448204c6d294f06d8ff and SHA1: 1bc674a7005f3d3147340b8310d515d2f00075bd

Log below:

VirtualBox VM 4.2.18 r88780 win.amd64 (Sep 6 2013 14:21:01) release log
00:00:03.298081 Log opened 2013-09-12T08:49:50.421585700Z
00:00:03.298085 OS Product: Windows 7
00:00:03.298087 OS Release: 6.1.7601
00:00:03.298088 OS Service Pack: 1
00:00:03.298095 Host RAM: 8169MB total, 3332MB available
00:00:03.298097 Executable: C:\Program Files\Oracle\VirtualBox\VirtualBox.exe
00:00:03.298098 Process ID: 6380
00:00:03.298099 Package type: WINDOWS_64BITS_GENERIC
00:00:03.311131 Installed Extension Packs:
00:00:03.311169 Oracle VM VirtualBox Extension Pack (Version: 4.2.18 r88780; VRDE Module: VBoxVRDP)
00:00:03.334253 pdmR3LoadR0U: pszName="VMMR0.r0" rc=VERR_LDR_MISMATCH_NATIVE szErr="supLoadModule returned VERR_LDR_MISMATCH_NATIVE"

00:00:03.334366 VMSetError: D:\tinderbox\win-4.2\src\VBox\VMM\VMMR3\VM.cpp(602) int cdecl vmR3CreateU(struct UVM *,unsigned int,int (cdecl *)(struct VM *,void *),void *); rc=VERR_LDR_MISMATCH_NATIVE

00:00:03.334371 VMSetError: Failed to load VMMR0.r0
00:00:03.334486 ERROR [COM]: aRC=E_FAIL (0x80004005) aIID={db7ab4ca-2a3f-4183-9243-c1208da92392} aComponent={Console} aText={Failed to load VMMR0.r0 (VERR_LDR_MISMATCH_NATIVE)}, preserve=false

00:00:03.403128 Power up failed (vrc=VERR_LDR_MISMATCH_NATIVE, rc=E_FAIL (0X80004005))

Last edited 19 months ago by Caemyr (previous) (diff)

comment:5 Changed 19 months ago by bird

The error only occurs if the loading of the image by the Windows kernel doesn't match our expectations, i.e. if it thinks the image has a different size or if the loaded content differs in any way we think significant. This is most likely to be the latter case. Do you have any kind of antivirus or similar software installed? Kernel debugging software? That kind of software could tinker with the image and make our check fail - in theory at least, as we haven't seen anyone doing it yet. But there is always a first time...

comment:6 Changed 19 months ago by Caemyr

I rechecked my system bearing your explanations in mind. The problem was caused by EMET4, set to enforce ASLR throughout the system. Setting it back to per-app fixed the problem. I would only suggest adding a FAQ entry or some forum info about this kind of problem. Bug report can be closed.

comment:7 Changed 17 months ago by dragon9999

I started seeing this same problem when I upgraded to 4.2.18. If I uninstall, then reinstall the problem goes away until I reboot, then I get the same problem. Tried upgrading to 4.3.2, same problem. If I try creating a new VM get the same error message: VERR_LDR_MISMATCH_NATIVE, etc.

comment:8 Changed 17 months ago by frank

dragon9999, please read the statement from bird.

Changed 9 months ago by DorianS

Logs of VM fatal error

comment:9 Changed 9 months ago by DorianS

I just had a similar problem; all my Windows 7 VM's showed a column of "H" characters in the boot window. After several minutes I closed using "Power-off" radio button. Restarted and got a fatal error "Guru mode" window from VirtualBox. Similar thing happened with a Windows 8.1 VM, but got a multicolor display of garbage characters before the fatal error message.

Read the comment from "Bird" above and disabled my anti-virus program for 10 minutes; all the VM's started! Subsequently re-enabled the AV, and everything still works fine.

Below are details of environment:

Hardware: Intel I7 processor / ASUS P8BWS motherboard / 32Gb RAM.

Host OS: Windows 2008R2 Standard / SP1 / patches up to date.

Anti-Virus: AVG Internet Security Business Edition 2012 version 2012.0.2247.

I have attached the logs from a Windows 7 and Windows 8 VM failure in DMGS_LOGS.zip.

Note: See TracTickets for help on using tickets.

www.oracle.com
ContactPrivacy policyTerms of Use