VirtualBox

Ticket #10748 (closed defect: invalid)

Opened 22 months ago

Last modified 22 months ago

Shared folder not accessible from app running as administrator

Reported by: benjaminhill Owned by:
Priority: major Component: shared folders
Version: VirtualBox 4.1.18 Keywords:
Cc: Guest type: Windows
Host type: Mac OS X

Description

... which is very strange, because it used to be the opposite, where you could only access a shared drive when running as administrator!

I noticed this when running CloneSpy in administrator mode, and confirmed it through launching two CMD prompts. The one running as administrator (which I was sure of because the cmd started in C:\Windows\system32) can NOT change to the e: drive, where the one NOT running as administrator CAN change to the e: drive!

Totally bizarre.

Change History

comment:1 Changed 22 months ago by sunlover

  • Status changed from new to closed
  • Resolution set to invalid

You forgot to mention which version of Windows is that. I suppose it is a Vista or 7.

This behavior is expected on Windows, because network drives are mapped for a particular user. This is by design on Windows. See the corresponding Microsoft article:  http://support.microsoft.com/kb/2019185

We will not implement any workarounds for this Windows feature.

Note: See TracTickets for help on using tickets.

www.oracle.com
ContactPrivacy policyTerms of Use