VirtualBox

Ticket #1071 (closed enhancement: fixed)

Opened 6 years ago

Last modified 4 years ago

[feature-request] Add Mac OS X guest support (Intel Macintosh hardware target) => Fixed in SVN

Reported by: Technologov Owned by:
Priority: major Component: other
Version: VirtualBox 2.2.0 Keywords:
Cc: Guest type: other
Host type: other

Description

As written  here, it might be possible now.

Since Apple allows virtualization licensing for "Mac OS X Server", this also becomes legal now. In future, I believe, Mac OS X desktop will also be legal to run as guest.

-Technologov

Change History

comment:1 Changed 6 years ago by Technologov

oopps... should be an enchancement.

-Technologov, 11.jan.2008.

comment:2 Changed 6 years ago by michael

  • Type changed from defect to enhancement

#1704 has been marked a duplicate of this ticket. As with ticket #524, this is something which would be a good candidate for community contributions, perhaps working in common with the Qemu community, but unfortunately it is not something which Sun are likely to be able to do in the immediate future.

comment:3 Changed 6 years ago by filhocf

From Alexander Graf's page[1]: [1] http://alex.csgraf.de/self/?part/projects&folder/Qemu%20OSX&type/&project/projects&parameters/id=Qemu%20OSX/qemu

Legal While the EULA clearly states, that running Mac OS X only once and only on Apple hardware is allowed, this does not exclude running it legally in a virtual machine on Apple hardware. This is basically the same approach that Mac-on-Linux took, but this time with the Intel based version of Mac OS X. Of course, as all the hardware Mac OS X runs on with this solution is virtual, the very same approach enables potential users to run it on non-Apple hardware as well, which is illegal though.


so, i have macbook and wish to run Mac OS X inside it. I have a legal copy and machine. In this scene, i think that is possible YES! to get support to Mac OS X in VB.

comment:4 Changed 6 years ago by bill_mcgonigle

FWIW I've got a Macbook Pro here and I'd really rather run OSX as a guest since Linux is so much more stable and performant. If one is concerned about EULA's, it ought to be possible, as an initial pass, to verify the Apple hardware device string if OSX is detected. I'm writing this comment now in Firefox on Fedora - when I'm done I'll reboot the thing into OSX to do some stuff there. It's very '90's.

comment:5 Changed 5 years ago by michael

#3088 has been marked a duplicate of this ticket.

comment:6 Changed 5 years ago by bill_mcgonigle

Here are some DMI values that could be used as a check, per my previous comment:

Handle 0x0000, DMI type 0, 24 bytes BIOS Information

Vendor: Apple Inc.

Handle 0x0001, DMI type 1, 27 bytes System Information

Manufacturer: Apple Computer, Inc.

Handle 0x0002, DMI type 2, 16 bytes Base Board Information

Manufacturer: Apple Computer, Inc.

Handle 0x0003, DMI type 3, 21 bytes Chassis Information

Manufacturer: Apple Inc.

These were generated by dmidecode on linux.

comment:7 Changed 5 years ago by sandervl73

  • Version changed from VirtualBox 1.5.4 to VirtualBox 2.2.0

comment:8 in reply to: ↑ description Changed 5 years ago by sfranzyshen

Replying to Technologov:

As written  here, it might be possible now.

Since Apple allows virtualization licensing for "Mac OS X Server", this also becomes legal now. In future, I believe, Mac OS X desktop will also be legal to run as guest.

-Technologov

if other emulation software is already offering this functionality, then why wont virtualbox allow this to be done? if it is run from a mac then no eula violation ... right?

why can't virtualbox just prevent other platforms from running macos except macos host??

  • sfranzyshen

comment:9 Changed 4 years ago by Technologov

v3.1 Made a step in right direction, by adding EFI.

I hope Mac guests (+guest additions) will be supported some day.

-Technologov

comment:10 Changed 4 years ago by Technologov

FIXED in 3.2.0

-Technologov

comment:11 Changed 4 years ago by frank

  • Summary changed from [feature-request] Add Mac OS X guest support (Intel Macintosh hardware target) to [feature-request] Add Mac OS X guest support (Intel Macintosh hardware target) => Fixed in SVN

comment:12 Changed 4 years ago by frank

  • Status changed from new to closed
  • Resolution set to fixed

Fixed in 3.2.0

Note: See TracTickets for help on using tickets.

www.oracle.com
ContactPrivacy policyTerms of Use