VirtualBox

Ticket #10648 (closed defect: duplicate)

Opened 23 months ago

Last modified 23 months ago

Nokia Suite installer fails to run on virtualbox shared folder (works from normal network drive)

Reported by: Attila123 Owned by:
Priority: major Component: shared folders
Version: VirtualBox 4.1.16 Keywords:
Cc: Guest type: Windows
Host type: Linux

Description

I tried to install Nokia Suite on the guest. When I tried to do it via a virtualbox shared folder it always failed (the installer itself does not give a detailed message, so I don't know exactly why). Details:

Nokia Suite version 3.4.49 (just in case meanwhile Nokia fixes their installer). Installer exe: Nokia_Suite_webinstaller_ALL.exe Download from:  http://www.nokia.com/nokiasuite

After downloading, verify if the installer starts normally from local guest drive. You should get a dialog which lets you start the installation. Do not install yet. In case if it does not start you get a generic message: "Problem with the installation file There seems to be a problem with this installation file. To be able to install Nokia Suite, download the latest version from  http://www.nokia.com/nokiasuite.". You can verify that the digital signature of the exe is OK from the Properties of it. This message may be caused by some missing certificates or DLLs, so fix these following the instructions here:  http://discussions.europe.nokia.com/t5/Nokia-Suite/Nokia-Suite-3-2-100-installation-problem/td-p/1208369/page/3

Now run the installer from virtualbox shared drive. You should get the above error message, and that's a problem. Again, this works fine running the installer from normal network drive, so there seems to be a problem with virtualbox shared folder implementaion (the way it implements a network drive in the Windows guest).

In case Nokia would change their installer (and you don't grab it in time) and problem is no longer reproducible, I can upload the current version to a file hosting service (you don't have to worry about viruses even in the host, since you can verify the digital signature).

Just for the record, my host is running Arch Linux x86 (I updated it recently) with 3.4.0-1-pae kernel ( http://aur.archlinux.org/packages.php?ID=51326), but I guess that's not really important. If I get some time, I will test with Windows host as well.

I didn't attach the VBox.log, because I didn't see anything related to the shared folder. But if you let me know how to enable detailed debug log for the shared folder, I could create and upload a log file for you.

Change History

comment:1 Changed 23 months ago by sunlover

  • Status changed from new to closed
  • Resolution set to duplicate

Most likely this is the same problem as in ticket https://www.virtualbox.org/ticket/5732

Note: See TracTickets for help on using tickets.

www.oracle.com
ContactPrivacy policyTerms of Use