VirtualBox

Ticket #10633 (closed defect: duplicate)

Opened 23 months ago

Last modified 20 months ago

Host crashes when shutting down one of several guest systems

Reported by: vardyh Owned by:
Priority: major Component: other
Version: VirtualBox 4.1.16 Keywords: OSX HostCrash
Cc: Guest type: all
Host type: Mac OS X

Description

I'm using VirtualBox-4.1.16 and getting host system crashes when shutting down one of several guest systems sometimes. This issue not only exists in v4.1.16, but also crashes when using previous versions, but I couldn't tell which version it originates. Coredump is provided in the attachment.

Attachments

coredump.log.tgz Download (3.0 KB) - added by vardyh 23 months ago.
coredump
coredump.log.2.tgz Download (2.9 KB) - added by vardyh 23 months ago.
it just crashes again w/ coredump follows

Change History

Changed 23 months ago by vardyh

coredump

Changed 23 months ago by vardyh

it just crashes again w/ coredump follows

comment:1 Changed 22 months ago by vardyh

Any replies? This issue may caused by Nested Paging related code. I turned off Nested Paging of both VMs and haven't crashed so far.

comment:2 Changed 21 months ago by Mr. Derp

Why *aren't* there any replies?

I have seen the "same" behavior - I run 3 VMs (guests = Windows Server 2003 R2 Standard SP2 32-bit; host = Windows Server 2003 R2 Enterprise SP2 32-bit) in VirtualBox 4.1.18 r78361, and when I shut down one of them (but only that one), there's a good chance (maybe 2/3 of the time) it will kill the host machine.

This is a pretty critical bug - whatever VirtualBox does, it shouldn't be crashing the host.

Per vardyh, I turned off Nested Paging in all three, but on the second round of shutdown crash tests for the crashy VM, it again killed the host. Ditto for turning off VT-x/AMD-V.

This is bad enough that I'm probably going to have to port the apps that run on the VMs to the host, despite the effort and drawbacks....

comment:3 Changed 20 months ago by frank

  • Status changed from new to closed
  • Resolution set to duplicate

Looks really like a duplicate of #9897. Let's continue the discussion there.

Note: See TracTickets for help on using tickets.

www.oracle.com
ContactPrivacy policyTerms of Use