VirtualBox

Ticket #10632 (closed defect: fixed)

Opened 23 months ago

Last modified 18 months ago

a lot of App crashes under Windows 8 Release Preview

Reported by: Andre.Ziegler Owned by:
Priority: major Component: WDDM
Version: VirtualBox 4.1.16 Keywords:
Cc: Guest type: Windows
Host type: Windows

Description

I've install the Windows 8 RP (Build 8400) in VB 4.1.16, installed the guest additions, but it unusable. Al lot of apps crash (IE, Explorer, ADK setup, VS2012 setup)

WARNING: Stack unwind information not available. Following frames may be wrong.
wined3dwddm_x86!WineDirect3DCreateClipper
wined3dwddm_x86!WineDirect3DCreateClipper
wined3dwddm_x86!WineDirect3DCreateClipper
VBoxD3D9wddm_x86!VBoxWineExD3DRc9SetShRcState
VBoxDispD3D_x86!VBoxDispCrHgsmiQueryClient
d3d9
d3d9
d3d9
d3d9
d3d9
d3d9
d3d9
d3d9!DebugSetMute
wpfgfx_v0400!CHwPipelineShader::~CHwPipelineShader
wpfgfx_v0400!CMILRefCountBase::Release
wpfgfx_v0400!CHwShaderCacheNode::~CHwShaderCacheNode
wpfgfx_v0400!CMILRefCountBase::Release
wpfgfx_v0400!CHwSurfaceRenderTargetSharedData::~CHwSurfaceRenderTargetSharedData
wpfgfx_v0400!CD3DDeviceManager::UnusedNotification
wpfgfx_v0400!CMILPoolResource::Release
wpfgfx_v0400!CHwSurfaceRenderTarget::~CHwSurfaceRenderTarget
wpfgfx_v0400!CMILCOMBase::InternalRelease
wpfgfx_v0400!CMetaRenderTarget::~CMetaRenderTarget
wpfgfx_v0400!CMILCOMBase::InternalRelease
wpfgfx_v0400!CDrawingContext::Uninitialize
wpfgfx_v0400!CMILCOMBase::InternalRelease
wpfgfx_v0400!CRenderTarget::ReleaseDrawingContext
wpfgfx_v0400!CSlaveHWndRenderTarget::Present
wpfgfx_v0400!CComposition::Present
wpfgfx_v0400!CPartitionThread::PresentPartition
wpfgfx_v0400!CPartitionThread::Run
wpfgfx_v0400!CPartitionThread::ThreadMain
kernel32!BaseThreadInitThunk
ntdll!__RtlUserThreadStart
ntdll!_RtlUserThreadStart

Attachments

VBox.log Download (73.8 KB) - added by Andre.Ziegler 23 months ago.
VB_Error.png Download (21.3 KB) - added by Andre.Ziegler 22 months ago.
VirtualBox_VS2012_NuGet_Update_theme_issue.png Download (78.0 KB) - added by Andre.Ziegler 22 months ago.
VBox.2.log Download (114.0 KB) - added by Andre.Ziegler 22 months ago.
latest log
Windows8_VirtualBox_black_logon.png Download (17.3 KB) - added by Andre.Ziegler 22 months ago.
VBox.3.log Download (108.7 KB) - added by Andre.Ziegler 22 months ago.
BLKCACHE_IOERR message="The I/O cache encountered an error while updating data in medium "ahci-0-0"

Change History

Changed 23 months ago by Andre.Ziegler

comment:1 Changed 23 months ago by Andre.Ziegler

*bump* misha are you there? Do you have a new test version for me?

comment:2 Changed 23 months ago by misha

Sorry for delay: was on shot vacation.. we're looking into this issue now..

comment:3 Changed 23 months ago by Andre.Ziegler

ok, if you need dumps just ask. I've added a WinSAT dump to the WinSAT ticket.

comment:4 Changed 23 months ago by Andre.Ziegler

any news? Do you need dumps?

comment:5 Changed 23 months ago by Andre.Ziegler

I'll delete the VM now. Win8 is currently unusable in a VM. When you release 4.1.18 I'll test it again.

comment:6 Changed 22 months ago by misha

Sorry for delay again - again was out of the office. It would be great to have dumps in case you still have them.
I should be also able to provide you with a test build that fixes a number of issues we've found locally so far.

comment:7 Changed 22 months ago by Andre.Ziegler

I've installed all the apps with the Basic driver and I've already uninstalled VS2012 because I don't like it.

So I can't reproduce the crashes.

Last edited 22 months ago by Andre.Ziegler (previous) (diff)

comment:8 Changed 22 months ago by misha

Please give a try to the test build I posted to bug 9267.
Note again that this is a trunk build, which may not be stable since trunk is under a heavy development now, so use it for testing purposes only.
To test you will need to update both host installation and guest additions.

comment:9 Changed 22 months ago by Andre.Ziegler

I can't start the VMs any longer. I get this error message:

The device instance structure version has changed.

Changed 22 months ago by Andre.Ziegler

comment:10 Changed 22 months ago by frank

Please also install the corresponding extension pack from there.

comment:11 Changed 22 months ago by Andre.Ziegler

ok, removing the old installed Extension Pack fixed it. I'll install the new one and try to install VS2012 RC again.

comment:12 Changed 22 months ago by Andre.Ziegler

IE and VS2012 work now.

When updating an Addon in VS I have a small theming issue (some parts are black) with the VSIX Installer.

Last edited 22 months ago by Andre.Ziegler (previous) (diff)

Changed 22 months ago by Andre.Ziegler

comment:13 Changed 22 months ago by misha

Thanks a lot for testing. Please also attach a VM log here.

Changed 22 months ago by Andre.Ziegler

latest log

comment:14 Changed 22 months ago by Andre.Ziegler

log added

comment:15 Changed 22 months ago by Andre.Ziegler

1 question. Does version 4.1.18 contain these fixes or should I stay at this trunk build?

comment:16 Changed 22 months ago by misha

The 4.1.18 does NOT contain the fixes to avoid regressions, since the fixes are pretty invasive.
The fixes will be publicly available in the next major VBox release.

comment:17 Changed 22 months ago by Andre.Ziegler

ok. Today I got a black screen at logon with only the small spinning circle during logon.

Changed 22 months ago by Andre.Ziegler

comment:18 Changed 22 months ago by Andre.Ziegler

I also have DLLhost.exe crashes:

FAULTING_IP: 
wined3dwddm!unloaded+9bc90
00000092`37f4bc90 ??              ???

EXCEPTION_RECORD:  ffffffffffffffff -- (.exr 0xffffffffffffffff)
ExceptionAddress: 0000009237f4bc90 (<Unloaded_wined3dwddm.dll>+0x000000000009bc90)
   ExceptionCode: c0000005 (Access violation)
  ExceptionFlags: 00000000
NumberParameters: 2
   Parameter[0]: 0000000000000008
   Parameter[1]: 0000009237f4bc90
Attempt to execute non-executable address 0000009237f4bc90

DEFAULT_BUCKET_ID:  BAD_INSTRUCTION_PTR

PROCESS_NAME:  dllhost.exe

ERROR_CODE: (NTSTATUS) 0xc0000005 - Die Anweisung in 0x%08lx verweist auf Speicher 0x%08lx. Der Vorgang %s konnte nicht im Speicher durchgef hrt werden.

EXCEPTION_CODE: (NTSTATUS) 0xc0000005 - Die Anweisung in 0x%08lx verweist auf Speicher 0x%08lx. Der Vorgang %s konnte nicht im Speicher durchgef hrt werden.

EXCEPTION_PARAMETER1:  0000000000000008

EXCEPTION_PARAMETER2:  0000009237f4bc90

WRITE_ADDRESS:  0000009237f4bc90 

FOLLOWUP_IP: 
wined3dwddm!wined3d_mutex_unlock+f10
00000092`39dbbef0 4885c0          test    rax,rax

FAILED_INSTRUCTION_ADDRESS: 
wined3dwddm!unloaded+9bc90
00000092`37f4bc90 ??              ???

NTGLOBALFLAG:  400

APPLICATION_VERIFIER_FLAGS:  0

APP:  dllhost.exe

FAULTING_THREAD:  0000000000000258

PRIMARY_PROBLEM_CLASS:  BAD_INSTRUCTION_PTR

BUGCHECK_STR:  APPLICATION_FAULT_BAD_INSTRUCTION_PTR_SOFTWARE_NX_FAULT

LAST_CONTROL_TRANSFER:  from 000007fa105839a5 to 0000009237f4bc90

STACK_TEXT:  
00000092`3a03eee8 000007fa`105839a5 : 00000000`000e02f0 00000000`00000001 00000000`00000000 000007fa`12ba4eb0 : <Unloaded_wined3dwddm.dll>+0x9bc90
00000092`3a03eef0 000007fa`105836b9 : 00000000`00000000 00000000`00000000 00000000`00000000 00000000`00000000 : user32!UserCallWinProcCheckWow+0x18d
00000092`3a03efb0 000007fa`10588c6c : 00000000`00000000 00000092`3a03f070 000007f7`299b4000 00000000`00000000 : user32!DispatchClientMessage+0x79
00000092`3a03f010 000007fa`12ba5027 : 00000001`2476d886 000007fa`10581a45 00000092`3a03f228 00000000`00000200 : user32!_fnINLPCREATESTRUCT+0x98
00000092`3a03f070 000007fa`1058dbca : 000007fa`1058db4c 00000092`3a03f2a0 00000092`3a03f5b0 00000000`00000000 : ntdll!KiUserCallbackDispatcherContinue
00000092`3a03f198 000007fa`1058db4c : 00000092`3a03f2a0 00000092`3a03f5b0 00000000`00000000 00000092`387a6d8c : user32!NtUserCreateWindowEx+0xa
00000092`3a03f1a0 000007fa`1058d8e0 : 00000000`00000026 00000092`39e1aec8 00000092`3a03f620 00000000`00000000 : user32!VerNtUserCreateWindowEx+0x21c
00000092`3a03f520 000007fa`1058efaf : 00000000`00000010 00000092`36c3b098 00000000`00000000 00000000`8e000000 : user32!CreateWindowInternal+0x1f0
00000092`3a03f680 00000092`39dbbef0 : 00000000`00000000 00000092`36c3b090 00000000`00000000 000007fa`12ba5027 : user32!CreateWindowExA+0x7f
00000092`3a03f710 00000092`39dbc0ec : 00000092`36c3b090 00000000`00000000 00000000`00000000 00000000`00000000 : wined3dwddm!wined3d_mutex_unlock+0xf10
00000092`3a03f7e0 00000092`39dbb115 : 00000000`00000000 00000000`00000000 00000000`00000000 00000000`00000000 : wined3dwddm!wined3d_mutex_unlock+0x110c
00000092`3a03f810 000007fa`101e16ca : 00000000`00000000 00000000`00000000 00000000`00000000 00000000`00000000 : wined3dwddm!wined3d_mutex_unlock+0x135
00000092`3a03f880 000007fa`12bdeb1d : 00000000`00000000 00000000`00000000 00000000`00000000 00000000`00000000 : kernel32!BaseThreadInitThunk+0x1a
00000092`3a03f8b0 00000000`00000000 : 00000000`00000000 00000000`00000000 00000000`00000000 00000000`00000000 : ntdll!RtlUserThreadStart+0x1d


SYMBOL_STACK_INDEX:  9

SYMBOL_NAME:  wined3dwddm!wined3d_mutex_unlock+f10

FOLLOWUP_NAME:  wintriag

MODULE_NAME: wined3dwddm

IMAGE_NAME:  wined3dwddm.dll

DEBUG_FLR_IMAGE_TIMESTAMP:  4fe0a9a5

STACK_COMMAND:  ~11s; .ecxr ; kb

FAILURE_BUCKET_ID:  BAD_INSTRUCTION_PTR_c0000005_wined3dwddm.dll!wined3d_mutex_unlock

BUCKET_ID:  APPLICATION_FAULT_BAD_INSTRUCTION_PTR_SOFTWARE_NX_FAULT_BAD_IP_wined3dwddm!wined3d_mutex_unlock+f10

I've set the Photo-Viewer as default picture viewer and looked at some pictures. Do you need a full or minidump?

comment:19 Changed 22 months ago by Andre.Ziegler

Now I got a BLKCACHE_IOERR error after leaving my PC so that the VM was idle for a few minutes:

00:32:32.809318 Console: VM runtime error: fatal=false, errorID=BLKCACHE_IOERR message="The I/O cache encountered an error while updating data in medium "ahci-0-0" (rc=VERR_NO_MEMORY). Make sure there is enough free space on the disk and that the disk is working properly. Operation can be resumed afterwards"

Disk is fine and I have over 500GB free space on the host and the guest VHD size is 20GB and the max size is 45GB. So there also space. Is this an trunk build issue?

Last edited 22 months ago by Andre.Ziegler (previous) (diff)

Changed 22 months ago by Andre.Ziegler

BLKCACHE_IOERR message="The I/O cache encountered an error while updating data in medium "ahci-0-0"

comment:20 Changed 22 months ago by misha

Are these issues for the trunk build I gave you or for 4.1.18?
Could you post crashdumps for the crashes you observe please?

comment:21 Changed 22 months ago by Andre.Ziegler

those are all trunk issues. I'll use this version until you gave me a 4.1.19 testbuild or when 4.1.20 will be released.

Link to the dllhost.exe dump:

 http://db.tt/9XjsjFwl

comment:22 Changed 22 months ago by Andre.Ziegler

the DLLhost.exe crash is not fixed in the 4.1.51.78858.

FAULTING_IP: 
wined3dwddm!unloaded+9bbf0
00000069`9f91bbf0 ??              ???

EXCEPTION_RECORD:  ffffffffffffffff -- (.exr 0xffffffffffffffff)
ExceptionAddress: 000000699f91bbf0 (<Unloaded_wined3dwddm.dll>+0x000000000009bbf0)
   ExceptionCode: c0000005 (Access violation)
  ExceptionFlags: 00000000
NumberParameters: 2
   Parameter[0]: 0000000000000008
   Parameter[1]: 000000699f91bbf0
Attempt to execute non-executable address 000000699f91bbf0

DEFAULT_BUCKET_ID:  BAD_INSTRUCTION_PTR

PROCESS_NAME:  dllhost.exe

ERROR_CODE: (NTSTATUS) 0xc0000005 - Die Anweisung in 0x%08lx verweist auf Speicher 0x%08lx. Der Vorgang %s konnte nicht im Speicher durchgef hrt werden.

EXCEPTION_CODE: (NTSTATUS) 0xc0000005 - Die Anweisung in 0x%08lx verweist auf Speicher 0x%08lx. Der Vorgang %s konnte nicht im Speicher durchgef hrt werden.

EXCEPTION_PARAMETER1:  0000000000000008

EXCEPTION_PARAMETER2:  000000699f91bbf0

WRITE_ADDRESS:  000000699f91bbf0 

FOLLOWUP_IP: 
wined3dwddm!wined3d_mutex_unlock+f10
00000069`a17bbe50 4885c0          test    rax,rax

FAILED_INSTRUCTION_ADDRESS: 
wined3dwddm!unloaded+9bbf0
00000069`9f91bbf0 ??              ???

NTGLOBALFLAG:  400

APPLICATION_VERIFIER_FLAGS:  0

APP:  dllhost.exe

FAULTING_THREAD:  0000000000000604

PRIMARY_PROBLEM_CLASS:  BAD_INSTRUCTION_PTR

BUGCHECK_STR:  APPLICATION_FAULT_BAD_INSTRUCTION_PTR_SOFTWARE_NX_FAULT

LAST_CONTROL_TRANSFER:  from 000007ff230d39a5 to 000000699f91bbf0

Call Site
<Unloaded_wined3dwddm.dll>
user32!UserCallWinProcCheckWow
user32!DispatchClientMessage
user32!_fnINLPCREATESTRUCT
ntdll!KiUserCallbackDispatcherContinue
user32!NtUserCreateWindowEx
user32!VerNtUserCreateWindowEx
user32!CreateWindowInternal
user32!CreateWindowExA
wined3dwddm!wined3d_mutex_unlock
wined3dwddm!wined3d_mutex_unlock
wined3dwddm!wined3d_mutex_unlock
kernel32!BaseThreadInitThunk
ntdll!RtlUserThreadStart

Do you need a new dump?

comment:23 Changed 22 months ago by misha

Yes, a minidump would be very useful.

comment:24 Changed 22 months ago by misha

For the record: I've posted a link to the trunk test build additions with instructions on using them  to the forum.
Please give it a try, and thanks a lot for testing and the valuable info you provide!

comment:25 Changed 22 months ago by frank

  • Priority changed from blocker to major

Just adapting the priority as Windows 8 is not officially supported in VBox 4.1.x yet. Of course we still working on fixing these problems but most of them probably with the next major release.

comment:26 Changed 22 months ago by Andre.Ziegler

ok, the trunk build works so far.

comment:27 Changed 18 months ago by frank

Andre, for the BLKCACHE_IOERR also read here.

comment:28 Changed 18 months ago by Andre.Ziegler

I've already deleted the Win8 RP VM.

The RTM under VB 4.2.0 doesn't have this issue.

comment:29 Changed 18 months ago by frank

  • Status changed from new to closed
  • Resolution set to fixed

Thanks. So let's close this ticket.

comment:30 Changed 18 months ago by Andre.Ziegler

ok

Note: See TracTickets for help on using tickets.

www.oracle.com
ContactPrivacy policyTerms of Use