VirtualBox

Ticket #10621 (closed defect: fixed)

Opened 23 months ago

Last modified 3 months ago

EFI Panic: Unexpected trap!! on POWERING ON

Reported by: milan.opa Owned by:
Priority: major Component: EFI
Version: VirtualBox 4.1.16 Keywords: EFI BOOT CRASH PANIC 4.1.16
Cc: Guest type: all
Host type: Linux

Description

Completele new VM crashes before boot screen when Enable EFI turned on under these circumtances:

Host: KUbuntu 12.04, 3GB RAM, I3 CPU

Guest: Mac OS X Server (the result is same with every other guest type) Base Memory: 1024 MB Acceleration: VT-x/AMD-V, Nested Paging, PAE/NX Video Memory: 6 MB (tried with 16MB and 32MB also) Remote Desktop Server: Disabled

I've tried to delete the machine and create new ones but they all crashed before even boot screen VirtualBox logo appears.

Please note that there are 4 other guest machines (WinXP x 2, Ubuntu 12.04 and Win 7) working perfectly. There must be something wrong with EFI boot option.

Attachments

VBox.log Download (49.7 KB) - added by milan.opa 23 months ago.
Last after-crash log file…
VBox.2.log Download (47.3 KB) - added by milan.opa 23 months ago.
Windows 7 VBOX.LOG after crash
VBox-MacOS.log Download (51.1 KB) - added by Hichem 23 months ago.
EFI Panic - OS/X Guest turning on OS/X Host
2012-05-30-08-35-07.097-VirtualBox-3750.log Download (299 bytes) - added by milan.opa 23 months ago.
Log found in /home/user/Documents
VBox.3.log Download (52.0 KB) - added by Ryan 23 months ago.
Windown 7 64bit host w/OSX guest log from Ryan.
2012-06-23-08-41-22.114.VBox.log Download (47.8 KB) - added by jvj24601 22 months ago.
OS X 10.7.4 host w/OSX Snow Leopard Server guest log from Jean.

Change History

Changed 23 months ago by milan.opa

Last after-crash log file...

comment:1 Changed 23 months ago by Hachiman

  • Status changed from new to closed
  • Resolution set to invalid

We aren't allowed to provide any support for Mac OS guest on non-Apple hardware.

Changed 23 months ago by milan.opa

Windows 7 VBOX.LOG after crash

comment:2 follow-up: ↓ 5 Changed 23 months ago by milan.opa

  • Status changed from closed to reopened
  • Resolution invalid deleted

You should read more carefully !

Forget about Mac OS (I regret mentioning).

Important thing is it behaves the same on any OS choice...(even unknown).

Please reopen the problem...here is the same VBox.log when Windows 7 is selected choice.

comment:3 follow-up: ↓ 4 Changed 23 months ago by Hichem

Hi,

The same issue happens with OS X Snow Leopard guest running on an OS X Snow Leopard host (machine is MacBook Pro). Log file is attached VBox-MacOS.log The crash seems to happen in the EFI boot.

Could you help please?

Thanks.

Changed 23 months ago by Hichem

EFI Panic - OS/X Guest turning on OS/X Host

comment:4 in reply to: ↑ 3 ; follow-up: ↓ 6 Changed 23 months ago by Hachiman

Replying to Hichem:

  1. it happens on on EFI boot, or while Mac goest starting?
  2. Does it make any difference whether 64-bit MacOS guest is selected?

comment:5 in reply to: ↑ 2 ; follow-up: ↓ 7 Changed 23 months ago by Hachiman

Replying to milan.opa:

You should read more carefully !

Ok, MacOs guest is important selection, which on general PC could require addition configuration to start just EFI shell. I've also have noticed OSX_10.6.7.iso in the first log ;)

comment:6 in reply to: ↑ 4 Changed 23 months ago by Hichem

Replying to Hachiman:

  1. it happens on on EFI boot, or while Mac goest starting?
  2. Does it make any difference whether 64-bit MacOS guest is selected?

Thanks for your quick feedback. Actually, when the 64 bits mode is enabled, OSX on the guest starts just fine. Thanks for this clue ;) To answer your first question, the VM crashes on EFI, just before the mac boot process. No text is thrown on the console, not even the VirtualBox's starting page.

Last edited 23 months ago by Hichem (previous) (diff)

comment:7 in reply to: ↑ 5 Changed 23 months ago by milan.opa

Replying to Hachiman:

Replying to milan.opa:

You should read more carefully !

Ok, MacOs guest is important selection, which on general PC could require addition configuration to start just EFI shell. I've also have noticed OSX_10.6.7.iso in the first log ;)

Yeah, I admit, that's how I bummped into the problem in the first place. :) I run several VM's (for testing purposes only), and was curious to see a Java app I built lately running on Mac (not any more) :)

When started digging it turned out that the problem repeats on any initial OS selection.

There is one thing I didn't mention...before upgrading to 4.1.16, I was using 4.1.14. I first tried EFI boot on that version, but it didn't work either. The problem, though, was different. The VBox initial LOGO did show up but few seconds later message poped out complaining about some EFI BIOS error...I don't remember well, and since I deleted everything there is no log I can send...

comment:8 Changed 23 months ago by frank

  • Priority changed from blocker to major

Not working EFI support is a bug but surely not a blocker.

Changed 23 months ago by milan.opa

Log found in /home/user/Documents

comment:9 Changed 23 months ago by Ryan

I also get this, but on a Windows 7 (64bit) host. I'm using an unsupported configuration, but I'll attach a log just in case it's helpful when trying to track down the problem.

Changed 23 months ago by Ryan

Windown 7 64bit host w/OSX guest log from Ryan.

Changed 22 months ago by jvj24601

OS X 10.7.4 host w/OSX Snow Leopard Server guest log from Jean.

comment:10 follow-up: ↓ 11 Changed 22 months ago by jvj24601

Just added my log, running OS X 10.7.4 (Mac Pro) host w/OSX Snow Leopard Server guest log. Not sure when it stopped working - haven't run this VM in a couple months. Downloaded VBox 4.1.18 r78361 this morning and this VM doesn't work anymore.

comment:11 in reply to: ↑ 10 Changed 22 months ago by Hachiman

Replying to jvj24601: Does EFI 64 fix issue for you?

comment:12 Changed 21 months ago by antony.kikaxa

got same crash with efi.
how-to:
create new VM, finish wizard. go to settings, check efi. start -> crash.

tested win xp x86. full soft virtualization.

!!Assertion Failed!!
Expression: <NULL>
Location : /home/vbox/vbox-4.1.16/src/VBox/Devices/EFI/DevEFI.cpp(372) int efiIOPortWrite
Unexpected trap during early EFI bootstrap!!

related to #8604

between startup and crash have variable number of
Display::handleDisplayResize(): debug messages

Version 3, edited 21 months ago by antony.kikaxa (previous) (next) (diff)

comment:13 Changed 21 months ago by hajjar

My 2 cents:

x86 xp host v4.1.18 - vm crashed. Could not reproduce with EFI64.

Downgraded to vbox 4.1.12 - now EFI works.

cheers

Last edited 21 months ago by hajjar (previous) (diff)

comment:14 follow-up: ↓ 15 Changed 20 months ago by dgatwood

Those of us hosting VirtualBox on Mountain Lion can't downgrade to 4.1.12. Any versions that doesn't panic the host OS also won't run any EFI-based client OS. This pretty much means VirtualBox is useless for hosting any version of OS X on top of Mountain Lion. Please raise the priority of this bug.

comment:15 in reply to: ↑ 14 Changed 20 months ago by Hachiman

Replying to dgatwood:

Those of us hosting VirtualBox on Mountain Lion can't downgrade to 4.1.12. Any versions that doesn't panic the host OS also won't run any EFI-based client OS. This pretty much means VirtualBox is useless for hosting any version of OS X on top of Mountain Lion. Please raise the priority of this bug.

You don't need to downgrade anything, you may just use 64-bit EFI.

comment:16 Changed 3 months ago by frank

  • Status changed from reopened to closed
  • Resolution set to fixed

Most likely fixed in 4.3.x (many EFI fixes).

Note: See TracTickets for help on using tickets.

www.oracle.com
ContactPrivacy policyTerms of Use