VirtualBox

Ticket #8604 (reopened defect)

Opened 3 years ago

Last modified 3 years ago

128 MB display adapter causes EFI crash

Reported by: jpetz Owned by:
Priority: minor Component: EFI
Version: VirtualBox 4.0.8 Keywords:
Cc: Guest type: other
Host type: other

Description

Hi,

Please forgive me if this is in the wrong area.

When making a new virtual machine in 4.0.4. If I set the display memory to 128MB and have EFI enabled it causes a crash on starting the VM. I suspect it has to do with EFI software as if I turn EFI off and go back to a traditional BIOS then everything is fine. Also if I reduce the display memory to 64MB it is also fine.

Attachments

Logs.zip Download (22.2 KB) - added by jpetz 3 years ago.
VBox logs of crashing(128MB) and non crashing (64MB) display VMs
efi_64mb.zip Download (43.6 KB) - added by jpetz 3 years ago.
Working startup
efi_128mb.zip Download (15.0 KB) - added by jpetz 3 years ago.
Failed startup
FreeBSD 9 201102.vbox Download (7.0 KB) - added by jpetz 3 years ago.
VM config
vbox_408_logs.zip Download (55.0 KB) - added by jpetz 3 years ago.
Vbox 4.0.8 logs
OS X-2011-05-17-16-45-20.log Download (44.0 KB) - added by ivanz 3 years ago.
VBoxDD.dll Problem Log

Change History

Changed 3 years ago by jpetz

VBox logs of crashing(128MB) and non crashing (64MB) display VMs

comment:1 Changed 3 years ago by frank

  • Component changed from host support to EFI

comment:2 Changed 3 years ago by Hachiman

Sorry for delaying. Could you please describe a bit when does it happen? Does it happens on pure EFI boot, let's say without any attachments, are you able to see EFI shell with 128Mb.

comment:3 Changed 3 years ago by Hachiman

Actually I wasn't able to reproduce the issue, and probably I've mistaken but It looks like you're trying to boot the FreeBSD 9 (according to the attached log). From what I've found about FreeBSD boot on mac it should be some sort of mixed environment, as I understand loader.efi is required from  http://blogs.freebsdish.org/rpaulo/2008/08/31/freebsd-ia32-efi-boot-loader/, right? So that why I've asked first series of the questions, to understand on what stage of the boot efi asserts internally.

comment:4 Changed 3 years ago by ivanz

Same issue here. I can see an assert in the log:

00:00:03.517 !!Assertion Failed!! 00:00:03.517 Expression: <NULL> 00:00:03.517 Location : D:\tinderbox\win-4.0\src\VBox\Devices\EFI\DevEFI.cpp(372) efiIOPortWrite 00:00:03.517 Unexpected trap during early EFI bootstrap!!

comment:5 follow-up: ↓ 7 Changed 3 years ago by Hachiman

Could you please download  VBoxDD.dll and place DSO instead of installed one. Please run your vm with following environment variables, then:

set VBOX_LOG=dev_efi.e.l2
set VBOX_LOG_DEST=file=c:\efi.log

and please attach the resulted log to the defect.

comment:6 Changed 3 years ago by jpetz

Hi Hachiman,

Thanks for reviewing my report. I'll do what I can to help. I just updated VirtualBox to 4.0.6 and still see this error. As ivanz states the error occurs before you get the Oracle VBox splash screen and also therefore before the EFI shell. I have followed your instructions.

  1. Replace DLL temporarily
  2. Set environment variables

But still got no log file. Turns out windows stupid file protection had me. If I run VBox with elevated admin privs I get a log file. I will upload the 64MB woking log and again the 128MB log from a failed startup.

I have also attached my vbox config file for the VM perhaps that will help you replicate the issue.

Regards Jarrod

Changed 3 years ago by jpetz

Working startup

Changed 3 years ago by jpetz

Failed startup

Changed 3 years ago by jpetz

VM config

comment:7 in reply to: ↑ 5 Changed 3 years ago by ivanz

Replying to Hachiman:

Could you please download  VBoxDD.dll and place DSO instead of installed one. Please run your vm with following environment variables, then:

set VBOX_LOG=dev_efi.e.l2
set VBOX_LOG_DEST=file=c:\efi.log

and please attach the resulted log to the defect.

I did that (and ran VBox from cmd to make sure the ENV VARs apply), but the VM won't start due to: VERR_PDM_DEVICE_NAME_CLASH

comment:8 Changed 3 years ago by ivanz

To be more specific:

00:00:01.509 VMSetError: D:\tinderbox\win-4.0\src\VBox\VMM\VMMR3\VM.cpp(354) VMR3Create; rc=VERR_PDM_DEVICE_NAME_CLASH
00:00:01.509 VMSetError: Unknown error creating VM
00:00:01.510 ERROR [COM]: aRC=E_FAIL (0x80004005) aIID={515e8e8d-f932-4d8e-9f32-79a52aead882} aComponent={Console} aText={Unknown error creating VM (VERR_PDM_DEVICE_NAME_CLASH)}, preserve=false
00:00:01.522 Power up failed (vrc=VERR_PDM_DEVICE_NAME_CLASH, rc=E_FAIL (0X80004005))

comment:9 follow-up: ↓ 11 Changed 3 years ago by Hachiman

Thanks, Jarrod and Ivan for feedbacks. I've noticed that your vm requires more then 1Gb, that might be an issue as well. So just to be sure could you try config with RAM <= 1Gb? For this test no need the be lunched with modified DSO and no log need to be attached, just note if RAM size value influences in your cases anyhow.

comment:10 Changed 3 years ago by Hachiman

  • Version changed from VirtualBox 4.0.4 to VirtualBox 4.0.6

comment:11 in reply to: ↑ 9 ; follow-ups: ↓ 12 ↓ 13 Changed 3 years ago by ivanz

Replying to Hachiman:

Thanks, Jarrod and Ivan for feedbacks. I've noticed that your vm requires more then 1Gb, that might be an issue as well. So just to be sure could you try config with RAM <= 1Gb? For this test no need the be lunched with modified DSO and no log need to be attached, just note if RAM size value influences in your cases anyhow.

You are right. With the RAM set to 512mb VBox doesn't crash.

comment:12 in reply to: ↑ 11 Changed 3 years ago by Hachiman

  • Status changed from new to closed
  • Resolution set to duplicate

Replying to ivanz:

Replying to Hachiman:

Thanks, Jarrod and Ivan for feedbacks. I've noticed that your vm requires more then 1Gb, that might be an issue as well. So just to be sure could you try config with RAM <= 1Gb? For this test no need the be lunched with modified DSO and no log need to be attached, just note if RAM size value influences in your cases anyhow.

You are right. With the RAM set to 512mb VBox doesn't crash.

Thanks for testing looks like duplicate of  8826, which hopefully fixed. And it will available in 4.0.8. I'll mark it as duplicate for now, but feel free to reopen in case it if the issue will persists in 4.0.8 ofc.

comment:13 in reply to: ↑ 11 Changed 3 years ago by jpetz

Replying to ivanz:

Replying to Hachiman:

Thanks, Jarrod and Ivan for feedbacks. I've noticed that your vm requires more then 1Gb, that might be an issue as well. So just to be sure could you try config with RAM <= 1Gb? For this test no need the be lunched with modified DSO and no log need to be attached, just note if RAM size value influences in your cases anyhow.

You are right. With the RAM set to 512mb VBox doesn't crash.

Confirmed also. I can start the VM without a crash if I set the memory to 512MB.

Question, is 4.0.8 ofc or a development binary(windows) with this fix available for download? If so can you provide a link?

comment:14 follow-up: ↓ 15 Changed 3 years ago by Hachiman

please try with  4.0.8

comment:15 in reply to: ↑ 14 Changed 3 years ago by ivanz

  • Status changed from closed to reopened
  • Resolution duplicate deleted

Replying to Hachiman:

please try with  4.0.8

Unfortunately it still crashes with 4.0.8:

00:00:03.522 EFI Panic: Unexpected trap!!
00:00:03.522 
00:00:03.522 !!Assertion Failed!!
00:00:03.522 Expression: <NULL>
00:00:03.522 Location  : D:\tinderbox\win-4.0\src\VBox\Devices\EFI\DevEFI.cpp(372) efiIOPortWrite
00:00:03.522 Unexpected trap during early EFI bootstrap!!

comment:16 follow-up: ↓ 18 Changed 3 years ago by ivanz

If you give me a build of the logging-enabled .dll for 4.0.8 I can get you a log.

comment:17 Changed 3 years ago by Hachiman

  • Version changed from VirtualBox 4.0.6 to VirtualBox 4.0.8

comment:18 in reply to: ↑ 16 ; follow-up: ↓ 19 Changed 3 years ago by Hachiman

Replying to ivanz:

If you give me a build of the logging-enabled .dll for 4.0.8 I can get you a log.

please try  VBoxDD.dll and send me log via mail [vasily _dot_ levchenko _at_ oracle _dot_ com].

comment:19 in reply to: ↑ 18 ; follow-up: ↓ 20 Changed 3 years ago by ivanz

Replying to Hachiman:

Replying to ivanz:

If you give me a build of the logging-enabled .dll for 4.0.8 I can get you a log.

please try  VBoxDD.dll and send me log via mail [vasily _dot_ levchenko _at_ oracle _dot_ com].

the VM won't start with that .dll, because of VERR_PDM_DEVICE_NAME_CLASH . How to workaround that?

comment:20 in reply to: ↑ 19 ; follow-up: ↓ 21 Changed 3 years ago by Hachiman

Replying to ivanz:

Replying to Hachiman:

Replying to ivanz:

If you give me a build of the logging-enabled .dll for 4.0.8 I can get you a log.

please try  VBoxDD.dll and send me log via mail [vasily _dot_ levchenko _at_ oracle _dot_ com].

the VM won't start with that .dll, because of VERR_PDM_DEVICE_NAME_CLASH . How to workaround that?

Please make sure that original VBoxDD.dll isn't in path or current folder.

comment:21 in reply to: ↑ 20 ; follow-up: ↓ 22 Changed 3 years ago by ivanz

Replying to Hachiman:

Replying to ivanz:

Replying to Hachiman:

Replying to ivanz:

If you give me a build of the logging-enabled .dll for 4.0.8 I can get you a log.

please try  VBoxDD.dll and send me log via mail [vasily _dot_ levchenko _at_ oracle _dot_ com].

the VM won't start with that .dll, because of VERR_PDM_DEVICE_NAME_CLASH . How to workaround that?

Please make sure that original VBoxDD.dll isn't in path or current folder.

It's not, because I moved it to my desktop and put yours in place in C:\Program Files\Oracle\VirtualBox

comment:22 in reply to: ↑ 21 ; follow-up: ↓ 24 Changed 3 years ago by Hachiman

Replying to ivanz:

Replying to Hachiman:

Replying to ivanz:

Replying to Hachiman:

Replying to ivanz:

If you give me a build of the logging-enabled .dll for 4.0.8 I can get you a log.

please try  VBoxDD.dll and send me log via mail [vasily _dot_ levchenko _at_ oracle _dot_ com].

the VM won't start with that .dll, because of VERR_PDM_DEVICE_NAME_CLASH . How to workaround that?

Please make sure that original VBoxDD.dll isn't in path or current folder.

It's not, because I moved it to my desktop and put yours in place in C:\Program Files\Oracle\VirtualBox

Could you please send me your log file with this DSO?

comment:23 Changed 3 years ago by jpetz

Hi Guys,

Thanks again for the interest in my report. I uninstalled VBox and installed VMWare Workstation yesterday so I could do some work on FreeBSD VMs. I thought 4.0.8 would take some time to get my hands on. I guess I was wrong.

So I have loaded up 4.0.8 and run up a new VM with the settings that caused the crash last time. Unfortunatly the error looks the same in the logs(as below).

efi: EFI Assertion failed! File=/home/vbox/tinderbox/efi-4.0/edk2/PcAtChipsetPkg/PciHostBridgeDxe/PciHostBridge.c line=0x0000000000000171 EFI Panic: Unexpected trap!! Unexpected trap during early EFI bootstrap!!

I have attached three logs in my ZIP this time.

  1. Successful boot to EFI shell with 64MB video memory set.
  2. Failed startup with 128MB video memory.
  3. Successful boot to EFI shell with base memory set to 1GB instead of 4GB.

Changed 3 years ago by jpetz

Vbox 4.0.8 logs

comment:24 in reply to: ↑ 22 Changed 3 years ago by ivanz

Replying to Hachiman:

Replying to ivanz:

Replying to Hachiman:

Replying to ivanz:

Replying to Hachiman:

Replying to ivanz:

If you give me a build of the logging-enabled .dll for 4.0.8 I can get you a log.

please try  VBoxDD.dll and send me log via mail [vasily _dot_ levchenko _at_ oracle _dot_ com].

the VM won't start with that .dll, because of VERR_PDM_DEVICE_NAME_CLASH . How to workaround that?

Please make sure that original VBoxDD.dll isn't in path or current folder.

It's not, because I moved it to my desktop and put yours in place in C:\Program Files\Oracle\VirtualBox

Could you please send me your log file with this DSO?

Relevant part below, I will attach the full log as well:

00:00:01.647 VMSetError: D:\tinderbox\win-4.0\src\VBox\VMM\VMMR3\VM.cpp(354) VMR3Create; rc=VERR_PDM_DEVICE_NAME_CLASH
00:00:01.647 VMSetError: Unknown error creating VM
00:00:01.647 ERROR [COM]: aRC=E_FAIL (0x80004005) aIID={515e8e8d-f932-4d8e-9f32-79a52aead882} aComponent={Console} aText={Unknown error creating VM (VERR_PDM_DEVICE_NAME_CLASH)}, preserve=false
00:00:01.689 Power up failed (vrc=VERR_PDM_DEVICE_NAME_CLASH, rc=E_FAIL (0X80004005))

I run VirtualBox.exe from cmd after doing (as per your instructions earlier):

set VBOX_LOG=dev_efi.e.l2
set VBOX_LOG_DEST=file=c:\efi.log

Changed 3 years ago by ivanz

VBoxDD.dll Problem Log

Note: See TracTickets for help on using tickets.

www.oracle.com
ContactPrivacy policyTerms of Use