VirtualBox

Ticket #10622 (closed defect: worksforme)

Opened 23 months ago

Last modified 21 months ago

VBox 4.1.14 w guest Win7 crashes after several days, is not working anymore

Reported by: gucky Owned by:
Priority: major Component: host support
Version: VirtualBox 4.1.16 Keywords:
Cc: Guest type: all
Host type: Solaris

Description (last modified by Hachiman) (diff)

Hi folks,

my VB installation isnt working anymore. the 4.1.14 inst. has crashed some days before, rm of all VM dir and files, pkgrm and installation of the actual version doesnt work. The main window appears, after several sec VM is coredumping.

The machine was started with root-rights, actual there is no VM attached or created

My system:

SunOS r2d4 5.11 11.0 i86pc i386 i86pc

VBoxlog

cat  VBoxSVC.log
VirtualBox (XP)COM Server 4.1.16 r78094 solaris.amd64 (May 22 2012 14:31:38) release log
00:00:00.001 main     Log opened 2012-05-29T17:53:14.513355000Z
00:00:00.001 main     OS Product: SunOS
00:00:00.001 main     OS Release: 5.11
00:00:00.001 main     OS Version: 11.0
00:00:00.001 main     OS Service Pack: 11.0
00:00:00.001 main     Executable: /opt/VirtualBox/amd64/VBoxSVC
00:00:00.001 main     Process ID: 3301
00:00:00.001 main     Package type: SOLARIS_64BITS_GENERIC
00:00:00.118 nspr-2   Loading settings file "/root/.VirtualBox/VirtualBox.xml" with version "1.12-solaris"
00:00:01.226 nspr-2   VDInit finished
00:00:14.598 Watcher  ERROR [COM]: aRC=E_ACCESSDENIED (0x80070005) aIID={c28be65f-1a8f-43b4-81f1-eb60cb516e66} aComponent={VirtualBox} aText={The object is not ready}, preserve=false

hope somebody could help

thanks a lot best regards

Change History

comment:1 Changed 23 months ago by gucky

Here is pstack core:

core 'core' of 3295:	/opt/VirtualBox/amd64/VirtualBox
-----------------  lwp# 1 / thread# 1  --------------------
 fffffd7ff8bb3dde _ZNK7QString7indexOfE5QChariN2Qt15CaseSensitivityE () + e
 fffffd7ff96f452d _ZN15UIUpdateManager40checkIfUpdateIsNecessaryForExtensionPackEb () + 50d
 fffffd7ff96f4a0f _ZN15UIUpdateManager27sltCheckIfUpdateIsNecessaryEb () + 1ef
 fffffd7ff97e6cd8 _ZN15UIUpdateManager11qt_metacallEN11QMetaObject4CallEiPPv () + a8
 fffffd7ff8c5630b _ZN11QMetaObject8activateEP7QObjectiiPPv () + 33b
 fffffd7ff8c5eab7 _ZN16QSingleShotTimer10timerEventEP11QTimerEvent () + 27
 fffffd7ff8c56bcc _ZN7QObject5eventEP6QEvent () + 8c
 fffffd7ff832466d _ZN19QApplicationPrivate13notify_helperEP7QObjectP6QEvent () + bd
 fffffd7ff83247ae _ZN12QApplication6notifyEP7QObjectP6QEvent () + de
 fffffd7ff8c47219 _ZN16QCoreApplication14notifyInternalEP7QObjectP6QEvent () + b9
 fffffd7ff8c6dd23 _ZN14QTimerInfoList14activateTimersEv () + 3a3
 fffffd7ff8c6e73c _ZN20QEventDispatcherUNIX13processEventsE6QFlagsIN10QEventLoop17ProcessEventsFlagEE () + 13c
 fffffd7ff83a7ff6 _ZN19QEventDispatcherX1113processEventsE6QFlagsIN10QEventLoop17ProcessEventsFlagEE () + 236
 fffffd7ff8c46b95 _ZN10QEventLoop13processEventsE6QFlagsINS_17ProcessEventsFlagEE () + 45
 fffffd7ff8c46d45 _ZN10QEventLoop4execE6QFlagsINS_17ProcessEventsFlagEE () + b5
 fffffd7ff8c4aee8 _ZN16QCoreApplication4execEv () + 98
 fffffd7ff957e4f5 TrustedMain () + a65
 0000000000403e52 SUPR3HardenedMain () + 2d2
 000000000040306c _start () + 6c
-----------------  lwp# 2 / thread# 2  --------------------
 fffffd7fff25b3ea __pollsys () + a
 fffffd7fff1fdaa7 poll () + 5f
 fffffd7ff8f22a1e _pr_poll_with_poll () + 3b4
 fffffd7ff8f22ba9 VBoxNsprPR_Poll () + 9
 fffffd7ff7b9de31 _Z10ConnThreadPv () + 41
 fffffd7ff8f248aa _pt_root () + 90
 fffffd7ff8f2496f _pt_iprt_root () + c
 fffffd7ff9bcfc1c rtThreadMain () + 2c
 fffffd7ff9c1cd11 _Z18rtThreadNativeMainPv () + 81
 fffffd7fff2522ad _thrp_setup () + a5
 fffffd7fff252550 _lwp_start ()
-----------------  lwp# 3 / thread# 3  --------------------
 fffffd7fff252597 __lwp_park () + 17
 fffffd7fff24bfae cond_wait_queue () + 62
 fffffd7fff24c3ec cond_wait_common () + 1dc
 fffffd7fff24c631 __cond_timedwait () + 5d
 fffffd7fff24c6c5 cond_timedwait () + 29
 fffffd7fff24c6f9 pthread_cond_timedwait () + 9
 fffffd7ff8f23d9f pt_TimedWait () + b4
 fffffd7ff8f23f71 VBoxNsprPR_WaitCondVar () + 7f
 fffffd7ff8f24269 VBoxNsprPR_Wait () + 46
 fffffd7ff7b91874 _Z10WaitTargetRK4nsIDjPP10ipcMessagePFjPvP13ipcTargetDataPKS2_ES5_ () + 30e
 fffffd7ff7b91f4a _Z16WaitIPCMResponsejPP10ipcMessage () + 38
 fffffd7ff7b92029 _Z15MakeIPCMRequestP10ipcMessagePS0_ () + 55
 fffffd7ff7b92b7a _Z15IPC_SendMessagejRK4nsIDPKhj () + 12a
 fffffd7ff7b98648 _ZN12DConnectStub10CallMethodEtPK15nsXPTMethodInfoP17nsXPTCMiniVariant () + 64a
 fffffd7ff8f02190 PrepareAndDispatch () + 230
 fffffd7ff8f02233 SharedStub () + 5b
 fffffd7ff9799bbd _ZNK22CExtraDataChangedEvent6GetKeyEv () + 4d
 fffffd7ff95f753c _ZN19UIMainEventListener11HandleEventEjP6IEvent () + 9dc
 fffffd7ff95fec6b _ZN12ListenerImplI19UIMainEventListenerP7QObjectE11HandleEventEP6IEvent () + 3b
 fffffd7ff8f01f49 VBoxNsxpXPTC_InvokeByIndex () + 173
 fffffd7ff7b9b92b _ZN18ipcDConnectService8OnInvokeEjPK14DConnectInvokej () + 41b
 fffffd7ff7b9aa2c _ZN18ipcDConnectService17OnIncomingRequestEjPK10DConnectOpj () + 42
 fffffd7ff7b99171 _ZN14DConnectWorker3RunEv () + 21d
 fffffd7ff8ef390e _ZN8nsThread4MainEPv () + 2e
 fffffd7ff8f248aa _pt_root () + 90
 fffffd7ff8f2496f _pt_iprt_root () + c
 fffffd7ff9bcfc1c rtThreadMain () + 2c
 fffffd7ff9c1cd11 _Z18rtThreadNativeMainPv () + 81
 fffffd7fff2522ad _thrp_setup () + a5
 fffffd7fff252550 _lwp_start ()
-----------------  lwp# 5 / thread# 5  --------------------
 fffffd7fff252597 __lwp_park () + 17
 fffffd7fff24bfae cond_wait_queue () + 62
 fffffd7fff24c54c __cond_wait () + 78
 fffffd7fff24c591 cond_wait () + 1d
 fffffd7fff24c5bd pthread_cond_wait () + 9
 fffffd7ff8b7720c _ZN14QWaitCondition4waitEP6QMutexm () + 1bc
 fffffd7ff7f00f14 _ZN14QHostInfoAgent3runEv () + 1a4
 fffffd7ff8b76057 _ZN14QThreadPrivate5startEPv () + a7
 fffffd7fff2522ad _thrp_setup () + a5
 fffffd7fff252550 _lwp_start ()
Last edited 23 months ago by gucky (previous) (diff)

comment:2 in reply to: ↑ description Changed 23 months ago by gucky

Sorry for the code"salad"

Replying to gucky:

Hi folks,

my VB installation isnt working anymore. the 4.1.14 inst. has crashed some days before, rm of all VB dir and files, pkgrm and installation of the actual version doesnt work. The main window appears, after several sec VM is coredumping.

The machine was started with root-rights, actual there is no VM attached or created

My system:

SunOS r2d4 5.11 11.0 i86pc i386 i86pc

VBoxlog

cat  VBoxSVC.log
 VirtualBox (XP)COM Server 4.1.16 r78094 solaris.amd64 (May 22 2012 14:31:38) release log
 00:00:00.001 main     Log opened 2012-05-29T17:53:14.513355000Z
 00:00:00.001 main     OS Product: SunOS
 00:00:00.001 main     OS Release: 5.11
 00:00:00.001 main     OS Version: 11.0
 00:00:00.001 main     OS Service Pack: 11.0
 00:00:00.001 main     Executable: /opt/VirtualBox/amd64/VBoxSVC
 00:00:00.001 main     Process ID: 3301
 00:00:00.001 main     Package type: SOLARIS_64BITS_GENERIC
 00:00:00.118 nspr-2   Loading settings file "/root/.VirtualBox/VirtualBox.xml" with version "1.12-Solaris"
 00:00:01.226 nspr-2   VDInit finished
 00:00:14.598 Watcher  ERROR [COM]: aRC=E_ACCESSDENIED (0x80070005) aIID={c28be65f-1a8f-43b4-81f1-eb60cb516e66} aComponent={VirtualBox} aText={The object is not ready}, preserve=false
 

comment:3 Changed 23 months ago by Hachiman

  • Description modified (diff)

comment:4 Changed 23 months ago by gucky

Hi Folks,

PROBLEM SOLVED ++++++

after several deinstalls and reinstalls :

Somehow Virtualbox check the permission for the /opt directory these should be 755 owner root / grp sys It seems that VB is thinking that everything higher than gid 0 is ++NOT++ a system-grp.

and something ++ not me as far as I know ++, maybe during packetinstallation, changed the permissions.

The question is, why is VB checking the permission on /opt ?

May there should be a hint during the installation or during the startup of VB.

comment:5 Changed 23 months ago by frank

I can only answer the question regarding why does VBox check the permissions of /opt. The reason is that VirtualBox is system software which has special privileges. If the permissions of the directory where VirtualBox is stored would be wrong then an unprivileged user could replace some binaries and could do bad this. Same problem if a user could write to parent directories (e.g. /opt). Some checks are perhaps a bit pedantic but better safe than sorry.

comment:6 Changed 21 months ago by ramshankar

  • Status changed from new to closed
  • Resolution set to worksforme

Looks like some weird Qt crash while checking for updates. Please re-open if this problem resurfaces since you mention the problem is solved/disappeared. Closing this ticket for now.

Note: See TracTickets for help on using tickets.

www.oracle.com
ContactPrivacy policyTerms of Use