VirtualBox

Ticket #10528 (closed defect: fixed)

Opened 2 years ago

Last modified 22 months ago

64-bit win7 guest freezes 32-bit ubuntu 12.04 host => Fixed in SVN

Reported by: dovshap Owned by:
Priority: critical Component: host support
Version: VirtualBox 4.1.14 Keywords: io-apic host freeze
Cc: Guest type: Windows
Host type: Linux

Description

after upgrading ubuntu to 12.04, trying to start a Win7 64 bit guest, freezes the host which is 32-bit, when trying to power it on. If I disable io-apic the guest will boot up and go to a windows stop screen, (expected behavior when disabling io-apic after installing windows).

Attachments

Win7-2012-05-08-08-33-45.log Download (44.9 KB) - added by dovshap 2 years ago.
Ubuntu_12.04_32bit.log Download (46.9 KB) - added by roryg 23 months ago.

Change History

comment:1 Changed 2 years ago by frank

Please attach a VBox.log file of such a VM session. Even if the host freezes there should be such a file available (GUI / Machine menu / Show Log File...)

Which was the previous VBox version you used to successfully boot this guest? Was it VirtualBox 4.1.2 from Ubuntu 11.10?

Changed 2 years ago by dovshap

comment:2 Changed 2 years ago by dovshap

This worked under Ubuntu 11.10 with Virtualbox 4.1.4. I have attached a log from trying to boot with io-apic enabled, the host hung after a few minutes and neeeded to be hard rebooted

comment:3 Changed 23 months ago by roryg

I've had the same issue, just with Windows Server 2003 64 bit. Running on Ubuntu 12.04 32 bit, Dell Vostro 3750, Intel i7 2670QM. I'll attach a log as well.

Changed 23 months ago by roryg

comment:4 Changed 22 months ago by frank

This is again some problem with the NMI watchdog of recent Linux kernels. A workaround is to add nmi_watchdog=0 nowatchdog to the command line of the host kernel. After a reboot, 64-bit guests should run stable on such 32-bit hosts. If some users could confirm this would be helpful.

We are currently investigating the problem. The real fix is to disable the NMI during the world switch. We already do that but obviously something is missing.

comment:5 Changed 22 months ago by frank

  • Summary changed from 64-bit win7 guest freezes 32-bit ubuntu 12.04 host to 64-bit win7 guest freezes 32-bit ubuntu 12.04 host => Fixed in SVN

Finally found and fixed the problem. The fix is in r41645. This fix is required to run 64-bit guests on 32-bit Linux hosts. Not relevant for other hosts.

comment:6 Changed 22 months ago by Martin Wildam

@frank: Let me kiss your feet for providing the workaround and fix! BTW: Thanks to bph in  https://forums.virtualbox.org/viewtopic.php?f=7&t=50009 here the complete list of steps to do the workaround:

  1. open a terminal window
  2. type "sudo gedit /etc/default/grub" (without the quotes) and press enter
  3. Comment out the line GRUB_CMDLINE_LINUX_DEFAULT="quiet splash" by adding a "#" character in front.
  4. Add new line below: GRUB_CMDLINE_LINUX_DEFAULT="quiet splash nmi_watchdog=0 nowatchdog"
  5. Save and exit
  6. type "sudo update-grub" (without the quotes) and press enter
  7. reboot.

comment:7 Changed 22 months ago by Martin Wildam

Note: I did not have this problem from the beginning with the newer kernels and first it did not happen all the time (even if very often). I did several changes (uninstalled latest updated packages etc) which first seem to help but not in the long run. Since 2 days it happened nearly ever on two machines - and finally I found this - so many thanks again!

comment:8 Changed 22 months ago by frank

  • Status changed from new to closed
  • Resolution set to fixed

Fix in VBox 4.1.18. Martin, thanks for your feedback!

Note: See TracTickets for help on using tickets.

www.oracle.com
ContactPrivacy policyTerms of Use