VirtualBox

Ticket #10527 (closed defect: fixed)

Opened 2 years ago

Last modified 2 years ago

Crash when connecting to certain FTP servers -> fixed in svn

Reported by: fzylogic Owned by:
Priority: major Component: network/NAT
Version: VirtualBox 4.1.14 Keywords: NAT,networking,FTP
Cc: Guest type: Linux
Host type: all

Description

One particular FTP server (tummy.com) causes VirtualBox to crash when initiating a passive FTP connection.
It appears that the bug is triggered by the FTP server sending an ICMP Host Administratively Prohibited message after the connection is initiated. I've got a network dump attached that shows the packets.
The bug seems specific to NAT networking, but is not dependent on host OS (It's been verified in OSX 10.6-10.8 and on Debian Squeeze).

Attachments

VBox.log Download (45.3 KB) - added by fzylogic 2 years ago.
VBox.log

Change History

Changed 2 years ago by fzylogic

VBox.log

comment:1 Changed 2 years ago by fzylogic

comment:2 Changed 2 years ago by Hachiman

duplicate #10513

comment:3 follow-up: ↓ 4 Changed 2 years ago by frank

Actually I'm not that sure that this is a duplicate of #10513. fzylogic, I cannot access your core dump, could you fix the permission problem?

comment:4 in reply to: ↑ 3 Changed 2 years ago by fzylogic

Replying to frank:

Actually I'm not that sure that this is a duplicate of #10513. fzylogic, I cannot access your core dump, could you fix the permission problem?

All fixed. Sorry about that!

comment:5 Changed 2 years ago by fzylogic

I finally got a debug build of VBox put together and got the following info out of gdb:

#0 0x00007f8dffcaca08 in send_icmp_to_guest (pData=0x7f8e003edd90, buff=0x2573c20 "E", len=88, addr=0x7f8dfc73da10)

at /root/vbox/src/VBox/Devices/Network/slirp/socket.c:1369

1369 Assert(m != NULL);

comment:6 Changed 2 years ago by frank

Great! Which source tree is that, VBox 4.1.14 or from the subversion repository on this server? If the latter, which revision?

comment:7 Changed 2 years ago by fzylogic

That's straight out of subversion as of a couple of hours ago.

comment:8 follow-up: ↓ 9 Changed 2 years ago by fzylogic

revision 41182

comment:9 in reply to: ↑ 8 Changed 2 years ago by Hachiman

Replying to fzylogic:

Thanks for reporting and testing.

comment:10 Changed 2 years ago by Hachiman

  • Summary changed from Crash when connecting to certain FTP servers to Crash when connecting to certain FTP servers -> fixed in svn

comment:11 follow-up: ↓ 12 Changed 2 years ago by frank

The fix is in r41198. Please verify.

comment:12 in reply to: ↑ 11 Changed 2 years ago by fzylogic

Replying to frank:

The fix is in r41198. Please verify.

Looks like that did the trick! I can now get a file listing from that ftp server without a crash.

comment:13 Changed 2 years ago by frank

  • Status changed from new to closed
  • Resolution set to fixed

Fix is part of VirtualBox 4.1.16.

Note: See TracTickets for help on using tickets.

www.oracle.com
ContactPrivacy policyTerms of Use