VirtualBox

Ticket #10467 (closed defect: invalid)

Opened 2 years ago

Last modified 2 years ago

VBoxManage clonehd placing output file somewhere other than the explicitly specified full path.

Reported by: dakra Owned by:
Priority: major Component: other
Version: VirtualBox 4.1.8 Keywords: VBoxManage clonehd explicit path
Cc: dakra137@… Guest type: Windows
Host type: Linux

Description (last modified by frank) (diff)

Scenario: VBoxManage clonehd specifying full paths for input and output files enclosed in double quotes on the bash command line. There are spaces in the input file name.

Result: The output file was placed in an odd place on a different device than specified.

This is not the same as:
https://www.virtualbox.org/ticket/3888
https://www.virtualbox.org/ticket/7402
nor as discussed in:
 http://muffinresearch.co.uk/archives/2009/07/23/virtualbox-error-cannot-register-the-hard-disk/[[BR]]

Environment: VirtualBox 4.1.8 r75467 running on Ubuntu 10.04 PAE on i7. Real disks are NTFS, as is the VDISK.

Specifics:

Command:
dakra@EVENTEE:/media/Windoze7$ VBoxManage clonehd "/media/Windoze7/Users/dakra/.VirtualBox/Machines/XP 8 Jan 2012 /XP 8 Jan 2012 -disk1.vdi" "/media/SSD88/XPSYSPREPPED.img" --format RAW
Actual Output file:
"/media/Windoze7/ /media/SSD88/XPSYSPREPPED.img"

I cannot prove, but I believe that VBoxManage created the directory hierarchy " /media/SSD88/" on the Windoze7 partition. It appears that the first level is a one character Unicode directory name x'C2A0', which I believe is a non-breaking space.

Once I found where the result went and had cleared enough disk space for it. I could let it go there and then do what I needed with it.

It may be that some of the erroneous "insufficient disk space" messages in other bug reports and the fora may be due to this misplacement of output onto devices with insufficient space, rather than the specified target destination.

Change History

comment:1 Changed 2 years ago by frank

  • Description modified (diff)

I cannot reproduce your problem. The output file is created at the exact position specified at the command line.

comment:2 Changed 2 years ago by dakra

OK. MMMV. Please lower the priority, maybe even close due to irreproducibility. At least this will show up in a search by someone with a similar experience.

comment:3 Changed 2 years ago by klaus

  • Status changed from new to closed
  • Resolution set to invalid

My gut feeling is that this was caused by accidentally entering a non-breaking space (and the UTF-8 encoding 0xc2 0xa0 indeed corresponds to U+00A0, which is "no-break space") before the string enclosed in double quotes (and a real space before that), or some variation of this theme. This would make it a relative path and would explain the behavior. I can't imagine the simple check in VBoxManage could go wrong (if absolute path then pass it straight to API, otherwise make it absolute).

Note: See TracTickets for help on using tickets.

www.oracle.com
ContactPrivacy policyTerms of Use